-   Linux - Newbie (
-   -   LOL..I did it again, as root! Damn it Jim! Help! (

linus72 07-16-2009 07:32 PM

LOL..I did it again, as root! Damn it Jim! Help!(SOLVED)
LOL, playing around, as root, and chowned the partition containg my new sidux-2009-xfce
FRUGAL install
and now if I try to become root or open root terminal


sidux@sidux:~$ sux
sudo: /etc/sudoers is owned by uid 1000, should be 0
Segmentation fault

Damn it Jim!

LOL, being that it's frugal I can simply delete all the rw stuff and start anew
but would have to re-install/re-update flash10, etc

I often "chown" the partition(s) containg the frugal's so's I can
edit stuff, move stuff, etc as root

see, this why we don't run as root Linus!

so, I did
chown -R bz /media/disk

from Ubuntu-9.04 to sidux partition

other day I ACCIDENTLY did
chown -R bz /


full re-install of ubuntu please

I was trying to chown the usb and hit enter before hitting media/disk

so, can I fix it or ditch it?

LOL, this 2nd time this happened today
1st time I thouhgt it was sidux bug..
now, at least I know...

chown baby!

alienDog 07-16-2009 09:08 PM

Well... you could change the ownership of etc/sudoers of your sidux from your Ubuntu installation. That wouldn't fix rest of the faulty ownerships though...

I'm not really sure what you're trying to accomplish by changing the ownership of every file in the filesystem. Surely it will break any Linux installation?

linus72 07-16-2009 09:10 PM

good thing it's frugal...

this time I'll clone it after I hook it up

how should I get permissions over a partition without screwing up sudoers??

is it possible?

thanks also:)

alienDog 07-16-2009 09:28 PM

Er... yes, it's possible. Be root :D

linus72 07-16-2009 09:35 PM

that's what I did
oh, so I should become root in Ubuntu and issue gnome file manager as root?
what's gnome file manager
nautilus or what?

alienDog 07-16-2009 09:42 PM

Yep. Nautilus is the thing. Just be careful... ;)

If I understand correctly, your sidux resides on a real unix-style filesystem. That means that it also gets treated as such under your Ubuntu installation, with the permissions and all that in place. As far as I know it's not possible to override that. If it's on some other (non-unix) filesystem, it might be possible to use a mount option that sets the owner of the files on it upon mount. See man mount for that.

linus72 07-16-2009 09:45 PM

yea itt's all ext3 dude
no dindows here:)

alienDog 07-16-2009 10:29 PM

Ok, so it's Nautilus as root with extra caution then :)

linus72 07-17-2009 07:35 PM

that is what it is
you can't CHOWN a partition holding debian or debian based or it freaks out

ubuntu doesn't do this, I've chowned ubuntu on another partition as root
and no bad stuff

Note to self:no more chowning dude

linus72 07-17-2009 07:37 PM

how do i mark it as solved??
EDIT:OH I got it

SqdnGuns 07-17-2009 07:40 PM


Originally Posted by linus72 (Post 3611303)
how do i mark it as solved??

Thread Tools

All times are GMT -5. The time now is 11:05 PM.