LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-28-2010, 01:26 AM   #1
jack083
LQ Newbie
 
Registered: Oct 2010
Location: 12078 newyork
Distribution: red hat 5
Posts: 2

Rep: Reputation: 0
Question login problem


i am using red hat 5. It is asking me for a user name at the terminal.
I do not understand what it is asking of me. A user name was never established during installation of the program. it did ask for a root password during installation which i provided.
At the terminal i did try typing "root" for the log in and the actual root password for the password. It gave me administrative access.

However, i don't know the correct command that will take me to the desktop. For windows i simply typed in win or exit to go to the main windows desktop. Linux is foreign to me... can anyone help? I would be greatful for the advice. I am a windows junky from way back.

p.s. If Linux pans out i will install it on many of my computers.
Linux will provide much better security then windows.

thank you!!
 
Old 10-28-2010, 01:30 AM   #2
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,145
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Are you able to login as root?

Which main windows desktop you are taking about?

What are the things you want to do?

We can suggest you so many things as to how to start learning Linux,but first let us konw did you login with root user successfully?
 
Old 10-28-2010, 01:32 AM   #3
NakedNacho
LQ Newbie
 
Registered: Jan 2009
Distribution: Kubuntu, Bohdi, Mint Lisa
Posts: 21

Rep: Reputation: 1
I would start by reading up on the basics .

http://www.linux.org/lessons/beginner/index.html

After that you can probably answer your own questions.
 
Old 10-28-2010, 01:37 AM   #4
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Hi Jack & welcome to LQ! It all depends on what you did during the installation procedure. It is normal for you to be able to login as root at a terminal prompt. If you weren't prompted to set up a user during installation then you'll have to use RH's method for setting up users from the command line. When you're logged in as root try typing the command
Code:
startx
If the response is something like "command not found" then you don't have an x-server installed.
Maybe somebody more familiar with RH than me can tell you how to do it.
ciao,
jdk
 
Old 10-28-2010, 02:15 AM   #5
jack083
LQ Newbie
 
Registered: Oct 2010
Location: 12078 newyork
Distribution: red hat 5
Posts: 2

Original Poster
Rep: Reputation: 0
startx spit out the following: (x10 I/O error 104)
 
Old 10-28-2010, 02:21 AM   #6
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,145
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Hi,

Cay you do this and post output here:

Code:
cat /etc/inittab | grep -i "initdefault"
and

Code:
 runlevel
 
Old 10-28-2010, 02:27 AM   #7
alli_yas
Member
 
Registered: Apr 2010
Location: Johannesburg
Distribution: Fedora 14, RHEL 5.5, CentOS 5.5, Ubuntu 10.04
Posts: 559

Rep: Reputation: 92
As per previous posts your system is either configured to boot into the terminal OR you don't have X11 installed.

To check your default run level run:

Code:
# /sbin/runlevel
In your case it will most likely return 3 indicating your system is by default configured to boot into run level 3 which is the terminal.

To change the run level to boot into the desktop environment:

Code:
# vim /etc/inittab
The contents of the inittab should be similar to:

Code:
# Default runlevel. The runlevels used by RHS are:
#   0 - halt (Do NOT set initdefault to this)
#   1 - Single user mode
#   2 - Multiuser, without NFS (The same as 3, if you do not have networking)
#   3 - Full multiuser mode
#   4 - unused
#   5 - X11
#   6 - reboot (Do NOT set initdefault to this)
#
id:3:initdefault:
Change the line id:3:initdefault: to:

Code:
id:5:initdefault:
Save the file and reboot. It would be a good idea to backup the inittab before you make the change.

If your system does not have X installed; you need to run:

Code:
# yum groupinstall "X Window System" "GNOME Desktop Environment"
This will install X and GNOME packages required. Note that you MUST have a Red Hat subscription to be able to install the packages via yum.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] SSH login problem for additional users after password-less login setup uncle-c Linux - Newbie 3 02-10-2010 01:51 PM
SSH Problem - Can't login using Hostname, can login using ip address jqweezy Linux - Networking 7 01-26-2009 03:21 PM
Login Problem ajkannan83 Linux - Software 5 03-28-2007 06:44 AM
Login Problem Peter_APIIT Fedora 4 03-06-2007 09:33 PM
RH 8 login problem don_dimo Linux - General 3 11-10-2003 04:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration