LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-19-2010, 03:36 AM   #1
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Rep: Reputation: 55
Logic Screen in Local Language


Dear All,

I have installed my local language font in ubuntu 10.04. During login when I click my local language and continue. I can see system wide settings in my local language.

But I would like to have only login screen in my local language. How to achieve this ?
 
Old 09-20-2010, 01:17 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,890

Rep: Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608
Maybe you can use ~/.bash_profile to change your locale settings to en_US.utf8:
Code:
LANG=en_US.utf8
LC_ALL=en_US.utf8
export LANG LC_ALL
 
Old 09-28-2010, 02:30 PM   #3
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Original Poster
Rep: Reputation: 55
Thanks for your reply bathory.

Sorry for my delayed response. I am using Ubuntu 10.04 LS.

I added following lines in my ~/.bashrc file as there is no ~/.bash_profile in Ubuntu unlike other linux distros.

Code:
LANG=kn_IN
LC_ALL=kn_IN
export LANG LC_ALL
I could see following locales are available in my system
Code:
vinay@Nanna-Laptop:~$ locale -a
C
en_AG
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IN
en_NG
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZW.utf8
kn_IN
POSIX
Still I am not able to see my local language during login prompt.

After login, I can see this.
Code:
vinay@Nanna-Laptop:~$ echo $LANG
kn_IN
Thanks.

Last edited by vinaytp; 09-28-2010 at 02:31 PM.
 
Old 09-29-2010, 01:51 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,890

Rep: Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608
Hi,

From your 1st post I was under the impression that you already have your system localized in your local language and just want to use the default English locale after login.
Please note that contents of ~/.bashrc are read once you logged in.
To set a locale system-wide you should edit /etc/environment. You can read more on locales here.

Regards
 
Old 09-29-2010, 02:59 AM   #5
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Original Poster
Rep: Reputation: 55
Hi bathory,

Mostly I have not asked my problem properly. I will put it this way.

I have installed Kannda font on my machine. I am able to do the system wide settings in kannada.

During login I need to select the language as Kannada. Then Ubuntu will take care of displaying Menus, Folder names, Window names etc in Kannada.

My question is I would like to see only my login prompt in Kannada. When it shows login window it should display my name in Kannada.

This is what I am trying to achive. I googled a lot, everywhere they tell about how to make system wide settings.

Please Advice.

Warm Regards,
 
Old 09-29-2010, 06:04 AM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,890

Rep: Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608
Hi,

You can take a look at this howto

Regards
 
Old 09-29-2010, 02:13 PM   #7
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Original Poster
Rep: Reputation: 55
Quote:
Originally Posted by bathory View Post
Hi,

You can take a look at this howto

Regards
Hi bathory,

I have already tried this. This will make system wide settings of local language. But Cannot display only login prompt with Kannada.

Thanks
 
Old 09-29-2010, 02:34 PM   #8
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,890

Rep: Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608
You didn't read it carefully.
You set your preferred language (Kannda) system-wide and then after logging in as the user you want to use a different language (English?), change again the language, but this time don't select "Apply System-Wide...". Quoting from the howto:
Quote:
The changes we just made will only affect this user account; the login screen and startup will not be affected. If you wish to change the language in the startup and login screens also, click Apply System-Wide in both dialogs. Other user accounts will still retain their original language settings; if you wish to change them, you must do it from those accounts.
So your system will be in Kannda, so you'll be presented with the localized login screen, but after you log in, it will turn into the other language (hopefully).
 
Old 10-01-2010, 05:25 AM   #9
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Original Poster
Rep: Reputation: 55
Hi bathory,

I read the howto carefully and tried.

I am getting login prompt with English/Kannada mixed, I need to select English every time during login from the login screen to make English as default language inside the system to use.

Thanks a lot for your efforts.
 
Old 10-01-2010, 06:27 AM   #10
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,890

Rep: Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608
Sorry but I can't help you further on this, as I don't use ubuntu, so I can test it.
From what Ive read, I guess you have to login as root and set the whole system interface into Kannada (Note: you have to use "Apply System-Wide" for both Language and Test.).
So when Ubuntu boots next time, it will present the login screen localized.

After that, if you login as a regular user for the 1st time you will see the localized desktop Then you can redo the same procedure to change your environment to English.
Next time you'll be presented again with the localized login screen, but after login everything will turn into English.

If this is what you've done but it doesn't work, you may ask directly in ubuntu forums to get more specific help

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
a problem about local language kingliang123 Linux - General 3 01-15-2010 04:03 AM
What does one need to do to be able to write in the local language? svar Slackware 6 11-03-2009 02:57 AM
LSI Logic / Symbios Logic 53c875 (rev 14) -> HP Storageworks 1/8 G2 gileravxr Linux - Hardware 0 07-21-2009 05:45 AM
Local language change Carroarmato0 Mandriva 2 03-10-2005 12:28 PM
can't get my local language right InDIo Mandriva 3 02-17-2005 05:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration