LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-25-2007, 03:07 PM   #1
vaalu
Member
 
Registered: Jun 2007
Posts: 54

Rep: Reputation: 15
Post logging in as root in gui


hai
i am using debian linux.i understnd that in debian etch linux i cant login as root in gui..but one friend of mine told me that by editing some file you can do tat..can any one help me please??
regards
 
Old 12-25-2007, 03:27 PM   #2
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 75
You need to edit your login managers configuration files and allow the option to enable root logins. If you need more details, then you need to let us know which login manager you are using e.g. gdm for GNOME or kdm for KDE. Personally I would advise against routinely logging in as root because of security reasons as well as the possibility of you accidentally damaging your system.
 
Old 12-25-2007, 03:30 PM   #3
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,125

Rep: Reputation: 165Reputation: 165
EDIT: Never mind - reddazz already advised against doing this.
 
Old 12-25-2007, 04:14 PM   #4
vaalu
Member
 
Registered: Jun 2007
Posts: 54

Original Poster
Rep: Reputation: 15
Post

Quote:
Originally Posted by reddazz View Post
You need to edit your login managers configuration files and allow the option to enable root logins. If you need more details, then you need to let us know which login manager you are using e.g. gdm for GNOME or kdm for KDE. Personally I would advise against routinely logging in as root because of security reasons as well as the possibility of you accidentally damaging your system.
how will iedit login managers configuraion file..i couldnt get that..would u elaborate more please
 
Old 12-25-2007, 04:22 PM   #5
AceofSpades19
Senior Member
 
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 58
You should be able to log in as root in debian login manager, I think ubuntu is the onyl distro that stops you from logging in as root
 
Old 12-25-2007, 05:28 PM   #6
townie
Member
 
Registered: Oct 2007
Distribution: Ubuntu 8.10 beta and Debian etch
Posts: 75

Rep: Reputation: 15
yeah that's right you cant login graphically in ubuntu but....
if you want to change that go to
/etc/kde3/kdm/kdmrc

and you just have to change boolean variable the code looks like this.

# Allow root logins?
# Default is true
AllowRootLogin=false

just change allow root login to true.
 
Old 12-25-2007, 05:36 PM   #7
vaalu
Member
 
Registered: Jun 2007
Posts: 54

Original Poster
Rep: Reputation: 15
i am also using kde but i went to the /etc/kde3/kdm but ter are no file name called kdmrc nor anything starting with kdmrc....wat may be the reason behind this
 
Old 12-25-2007, 05:42 PM   #8
AceofSpades19
Senior Member
 
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 58
You are probably using gdm, so that wouldn't work
 
Old 12-25-2007, 05:48 PM   #9
vaalu
Member
 
Registered: Jun 2007
Posts: 54

Original Poster
Rep: Reputation: 15
which means??how can i activate the root login.??and by the way how come i be using gdm when my desktop is kde..and also i have gnome and Xfce installed.....
 
Old 12-25-2007, 06:56 PM   #10
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
Hi,

Since you've gnome and kde installed, you still may be using gdm as your dm since all dms can be configured to start the desktop environment selected by the user, so, gdm can call kde with no problems.

About the system file, if you're using gdm, then, I think that the config file is at /etc/gdm/gdm.conf, debian users can clarify about that

If you don't find those, you can try with

Code:
whereis dm
or

Code:
find / -name dm
or if you have locate/slocate installed, then:

Code:
updatedb && locate dm
Change "dm" for kdmrc or gdm.conf.

And finally, sorry, even when reddazz made the advice, I've to ask, why do you want to login as root in X?

Really, I just hope that you're trying to do this for some very important reason (which I don't see) and not just because some friend told you that this was a good thing to do....




Regards

Last edited by Acron_0248; 12-25-2007 at 06:58 PM.
 
Old 12-26-2007, 01:38 AM   #11
AceofSpades19
Senior Member
 
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 58
Quote:
Originally Posted by vaalu View Post
which means??how can i activate the root login.??and by the way how come i be using gdm when my desktop is kde..and also i have gnome and Xfce installed.....
the desktop environment is independent of the login manager
 
Old 12-26-2007, 05:08 AM   #12
vaalu
Member
 
Registered: Jun 2007
Posts: 54

Original Poster
Rep: Reputation: 15
Post

Quote:
Originally Posted by Acron_0248 View Post
Hi,

Since you've gnome and kde installed, you still may be using gdm as your dm since all dms can be configured to start the desktop environment selected by the user, so, gdm can call kde with no problems.

About the system file, if you're using gdm, then, I think that the config file is at /etc/gdm/gdm.conf, debian users can clarify about that

If you don't find those, you can try with

Code:
whereis dm
or

Code:
find / -name dm
or if you have locate/slocate installed, then:

Code:
updatedb && locate dm
Change "dm" for kdmrc or gdm.conf.

And finally, sorry, even when reddazz made the advice, I've to ask, why do you want to login as root in X?

Really, I just hope that you're trying to do this for some very important reason (which I don't see) and not just because some friend told you that this was a good thing to do....




Regards
i am sorry..its just out of curiosity..i would just like to know..i typed whereis dm and found it is /etc/dm/ and i could find no files in tat..is it tat i should change the directory name..and still nobody has given me the answer to activating the root login.. iam sorry if it was because i didnt get u people because i am new to this environment..i would have been glad to know
regards
 
Old 12-26-2007, 05:10 AM   #13
vaalu
Member
 
Registered: Jun 2007
Posts: 54

Original Poster
Rep: Reputation: 15
i also found the /etc/gdm/gdm.conf file and it contains the following lines..what should i edit in it to activate root login ..would be nice to know
:-

# GDM Configuration Customization file.
#
# This file is the appropriate place for specifying your customizations to the
# GDM configuration. If you run gdmsetup, it will automatically edit this
# file for you and will cause the daemon and any running GDM GUI programs to
# automatically update with the new configuration. Not all configuration
# options are supported by gdmsetup, so to modify some values it may be
# necessary to modify this file directly by hand.
#
# Older versions of GDM used the "gdm.conf" file for configuration. If your
# system has an old gdm.conf file on the system, it will be used instead of
# this file - so changes made to this file will not take effect. Consider
# migrating your configuration to this file and removing the gdm.conf file.
#
# To hand-edit this file, simply add or modify the key=value combination in
# the appropriate section in the template below. Refer to the comments in the
# /usr/share/gdm/defaults.conf file for information about each option. Also
# refer to the reference documentation.
#
# If you hand edit a GDM configuration file, you should run the following
# command to get the GDM daemon to notice the change. Any running GDM GUI
# programs will also be notified to update with the new configuration.
#
# gdmflexiserver --command="UPDATE_CONFIG <configuration key>"
#
# e.g, the "Enable" key in the "[debug]" section would be "debug/Enable".
#
# You can also run gdm-restart or gdm-safe-restart to cause GDM to restart and
# re-read the new configuration settings. You can also restart GDM by sending
# a HUP or USR1 signal to the daemon. HUP behaves like gdm-restart and causes
# any user session started by GDM to exit immediately while USR1 behaves like
# gdm-safe-restart and will wait until all users log out before restarting GDM.
#
# For full reference documentation see the gnome help browser under
# GNOME|System category. You can also find the docs in HTML form on
# http://www.gnome.org/projects/gdm/
#
# NOTE: Lines that begin with "#" are considered comments.
#
# Have fun!

[daemon]

[security]

[xdmcp]

[gui]

[greeter]
GraphicalThemeRand=true
Welcome=Vishnu's Computer
DefaultWelcome=false
GraphicalThemes=circles/:debian-moreblue/:happygnome/:happygnome-list

[chooser]

[debug]

# Note that to disable servers defined in the defaults.conf file (such as
# 0=Standard, you must put a line in this file that says 0=inactive, as
# described in the Configuration section of the GDM documentation.
#
[servers]

# Also note, that if you redefine a [server-foo] section, then GDM will
# use the definition in this file, not the defaults.conf file. It is
# currently not possible to disable a [server-foo] section defined
# in the defaults.conf file.
#
 
Old 12-26-2007, 05:37 AM   #14
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
Quote:
Originally Posted by vaalu View Post
i am sorry..its just out of curiosity..i would just like to know..i typed whereis dm and found it is /etc/dm/ and i could find no files in tat..is it tat i should change the directory name..and still nobody has given me the answer to activating the root login.. iam sorry if it was because i didnt get u people because i am new to this environment..i would have been glad to know
regards

1) If it's just curiosity, that's fine

2) You were to look for gdm.conf or kdmrc, nor "dm"; as I said when I told you how to look out the files:
Quote:
Change "dm" for kdmrc or gdm.conf.


3) Someone already gave you the answer, at least for kdmrc:
Quote:
Originally Posted by townie
and you just have to change boolean variable the code looks like this.

# Allow root logins?
# Default is true
AllowRootLogin=false

just change allow root login to true.

4) For the gdm.conf, under [security] you need to add AllowRoot=true, so, it will end like this:
Code:
[security]
AllowRoot=true



Regards
 
Old 12-26-2007, 06:05 AM   #15
vaalu
Member
 
Registered: Jun 2007
Posts: 54

Original Poster
Rep: Reputation: 15
really tat was great information..thank you for the fast response
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
logging in as root on ubuntu 7.10 (GUI) jessica_lilly Linux - Newbie 7 11-22-2007 11:48 PM
RedHat8 - No GUI for Root after Logging In rlane3907 Linux - General 2 02-18-2007 11:13 PM
Problem logging into Mandrake 10 GUI brownsview Linux - Newbie 1 08-16-2004 01:25 PM
error when logging into GUI Lleb_KCir Linux - General 3 03-27-2004 11:23 PM
using red-carpet without logging out and logging as root. packman Linux - Software 1 12-09-2002 02:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration