LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   logging in as root in gui (https://www.linuxquestions.org/questions/linux-newbie-8/logging-in-as-root-in-gui-609071/)

vaalu 12-25-2007 03:07 PM

logging in as root in gui
 
hai
i am using debian linux.i understnd that in debian etch linux i cant login as root in gui..but one friend of mine told me that by editing some file you can do tat..can any one help me please??
regards

reddazz 12-25-2007 03:27 PM

You need to edit your login managers configuration files and allow the option to enable root logins. If you need more details, then you need to let us know which login manager you are using e.g. gdm for GNOME or kdm for KDE. Personally I would advise against routinely logging in as root because of security reasons as well as the possibility of you accidentally damaging your system.

gilead 12-25-2007 03:30 PM

EDIT: Never mind - reddazz already advised against doing this.

vaalu 12-25-2007 04:14 PM

Quote:

Originally Posted by reddazz (Post 3001326)
You need to edit your login managers configuration files and allow the option to enable root logins. If you need more details, then you need to let us know which login manager you are using e.g. gdm for GNOME or kdm for KDE. Personally I would advise against routinely logging in as root because of security reasons as well as the possibility of you accidentally damaging your system.

how will iedit login managers configuraion file..i couldnt get that..would u elaborate more please

AceofSpades19 12-25-2007 04:22 PM

You should be able to log in as root in debian login manager, I think ubuntu is the onyl distro that stops you from logging in as root

townie 12-25-2007 05:28 PM

yeah that's right you cant login graphically in ubuntu but....
if you want to change that go to
/etc/kde3/kdm/kdmrc

and you just have to change boolean variable the code looks like this.

# Allow root logins?
# Default is true
AllowRootLogin=false

just change allow root login to true.
:)

vaalu 12-25-2007 05:36 PM

i am also using kde but i went to the /etc/kde3/kdm but ter are no file name called kdmrc nor anything starting with kdmrc....wat may be the reason behind this

AceofSpades19 12-25-2007 05:42 PM

You are probably using gdm, so that wouldn't work

vaalu 12-25-2007 05:48 PM

which means??how can i activate the root login.??and by the way how come i be using gdm when my desktop is kde..and also i have gnome and Xfce installed.....

Acron_0248 12-25-2007 06:56 PM

Hi,

Since you've gnome and kde installed, you still may be using gdm as your dm since all dms can be configured to start the desktop environment selected by the user, so, gdm can call kde with no problems.

About the system file, if you're using gdm, then, I think that the config file is at /etc/gdm/gdm.conf, debian users can clarify about that

If you don't find those, you can try with

Code:

whereis dm
or

Code:

find / -name dm
or if you have locate/slocate installed, then:

Code:

updatedb && locate dm
Change "dm" for kdmrc or gdm.conf.

And finally, sorry, even when reddazz made the advice, I've to ask, why do you want to login as root in X?

Really, I just hope that you're trying to do this for some very important reason (which I don't see) and not just because some friend told you that this was a good thing to do....




Regards

AceofSpades19 12-26-2007 01:38 AM

Quote:

Originally Posted by vaalu (Post 3001409)
which means??how can i activate the root login.??and by the way how come i be using gdm when my desktop is kde..and also i have gnome and Xfce installed.....

the desktop environment is independent of the login manager

vaalu 12-26-2007 05:08 AM

Quote:

Originally Posted by Acron_0248 (Post 3001436)
Hi,

Since you've gnome and kde installed, you still may be using gdm as your dm since all dms can be configured to start the desktop environment selected by the user, so, gdm can call kde with no problems.

About the system file, if you're using gdm, then, I think that the config file is at /etc/gdm/gdm.conf, debian users can clarify about that

If you don't find those, you can try with

Code:

whereis dm
or

Code:

find / -name dm
or if you have locate/slocate installed, then:

Code:

updatedb && locate dm
Change "dm" for kdmrc or gdm.conf.

And finally, sorry, even when reddazz made the advice, I've to ask, why do you want to login as root in X?

Really, I just hope that you're trying to do this for some very important reason (which I don't see) and not just because some friend told you that this was a good thing to do....




Regards

i am sorry..its just out of curiosity..i would just like to know..i typed whereis dm and found it is /etc/dm/ and i could find no files in tat..is it tat i should change the directory name..and still nobody has given me the answer to activating the root login.. iam sorry if it was because i didnt get u people because i am new to this environment..i would have been glad to know
regards

vaalu 12-26-2007 05:10 AM

i also found the /etc/gdm/gdm.conf file and it contains the following lines..what should i edit in it to activate root login ..would be nice to know
:-

# GDM Configuration Customization file.
#
# This file is the appropriate place for specifying your customizations to the
# GDM configuration. If you run gdmsetup, it will automatically edit this
# file for you and will cause the daemon and any running GDM GUI programs to
# automatically update with the new configuration. Not all configuration
# options are supported by gdmsetup, so to modify some values it may be
# necessary to modify this file directly by hand.
#
# Older versions of GDM used the "gdm.conf" file for configuration. If your
# system has an old gdm.conf file on the system, it will be used instead of
# this file - so changes made to this file will not take effect. Consider
# migrating your configuration to this file and removing the gdm.conf file.
#
# To hand-edit this file, simply add or modify the key=value combination in
# the appropriate section in the template below. Refer to the comments in the
# /usr/share/gdm/defaults.conf file for information about each option. Also
# refer to the reference documentation.
#
# If you hand edit a GDM configuration file, you should run the following
# command to get the GDM daemon to notice the change. Any running GDM GUI
# programs will also be notified to update with the new configuration.
#
# gdmflexiserver --command="UPDATE_CONFIG <configuration key>"
#
# e.g, the "Enable" key in the "[debug]" section would be "debug/Enable".
#
# You can also run gdm-restart or gdm-safe-restart to cause GDM to restart and
# re-read the new configuration settings. You can also restart GDM by sending
# a HUP or USR1 signal to the daemon. HUP behaves like gdm-restart and causes
# any user session started by GDM to exit immediately while USR1 behaves like
# gdm-safe-restart and will wait until all users log out before restarting GDM.
#
# For full reference documentation see the gnome help browser under
# GNOME|System category. You can also find the docs in HTML form on
# http://www.gnome.org/projects/gdm/
#
# NOTE: Lines that begin with "#" are considered comments.
#
# Have fun!

[daemon]

[security]

[xdmcp]

[gui]

[greeter]
GraphicalThemeRand=true
Welcome=Vishnu's Computer
DefaultWelcome=false
GraphicalThemes=circles/:debian-moreblue/:happygnome/:happygnome-list

[chooser]

[debug]

# Note that to disable servers defined in the defaults.conf file (such as
# 0=Standard, you must put a line in this file that says 0=inactive, as
# described in the Configuration section of the GDM documentation.
#
[servers]

# Also note, that if you redefine a [server-foo] section, then GDM will
# use the definition in this file, not the defaults.conf file. It is
# currently not possible to disable a [server-foo] section defined
# in the defaults.conf file.
#

Acron_0248 12-26-2007 05:37 AM

Quote:

Originally Posted by vaalu (Post 3001730)
i am sorry..its just out of curiosity..i would just like to know..i typed whereis dm and found it is /etc/dm/ and i could find no files in tat..is it tat i should change the directory name..and still nobody has given me the answer to activating the root login.. iam sorry if it was because i didnt get u people because i am new to this environment..i would have been glad to know
regards


1) If it's just curiosity, that's fine :)

2) You were to look for gdm.conf or kdmrc, nor "dm"; as I said when I told you how to look out the files:
Quote:

Change "dm" for kdmrc or gdm.conf.
;)

3) Someone already gave you the answer, at least for kdmrc:
Quote:

Originally Posted by townie
and you just have to change boolean variable the code looks like this.

# Allow root logins?
# Default is true
AllowRootLogin=false

just change allow root login to true.


4) For the gdm.conf, under [security] you need to add AllowRoot=true, so, it will end like this:
Code:

[security]
AllowRoot=true




Regards

vaalu 12-26-2007 06:05 AM

really tat was great information..thank you for the fast response


All times are GMT -5. The time now is 07:41 PM.