-   Linux - Newbie (
-   -   Locked out of files and cant change permissions on SAMBA share NAS (

Quantaa 01-20-2011 10:40 PM

Locked out of files and cant change permissions on SAMBA share NAS
Hi all,

This is my third day trying to solve this. My lack of understanding is really keeping me from getting to the cause of the problem. I'll try to explain what happened, rather than giving technical details that I probably dont understand well enough to make sense with.

I had a Mac Pro and decided to sell it so I copied all my valuable data on to this DLink DNS343 NAS that I bought thinking they would be safe until the new mac arrived.

Got the new imac and went to copy it all off the NAS onto my the local drive.

For some reason, I am now locked out of various files. A JPEG here, a DMG there, no consistency to it that I can tell. And when I say locked out I mean LOCKED OUT. I cant even read the files in order to copy them off the NAS.

So after all my days of trolling through the web, I seem to have narrowed it down a BIT.
I THINK the files have attributes that are not allowing ME (my UID?) to read those files. I'm fairly sure its not the NAS because I have removed ALL restrictions. Its 100% open. I can write and read new files but cant touch certain things i put on there before the new mac.

From my reading, I gather that I am no longer the "OWNER" of those files. But also that I cant change the owner because it cant be done over a SAMBA share.

What I've tried:
* resetting access control
* chmod and chown commands
* tried using UBUNTU to copy off files, no result
* etc etc etc

I'm at my wits end

Are these files actually encrypted or is this just an issue of permissions attributes that cant be modified?



jschiwal 01-20-2011 10:57 PM

If you can mount the samba share, list the ownership/permissions of the files and directories. How is the share mounted?

Does this NAS have a USB interface where you can mount the filesystem directly? What is the filesystem used on the nas?

Post the actual error.

Quantaa 01-20-2011 11:27 PM

How do I list the ownership/permissions of the files and directories?

The share is mounted via SAMBA using the GO>CONNECT TO SERVER in OSX Snow Leopard
NAS has ethernet only
File system is EXT3

When I try to open the file, i get...

When I try to copy the enclosing folder or file to my desktop, i get...

When I try to change permissions using 'get info', I get this...

jschiwal 01-21-2011 07:40 AM

Open the shell and enter the "mount" command to list the mounts. "Connecting" to the server my cause the smb share to be mounted. If so, you can cd to the mount point and use "ls -l" to list the files and their permissions.

I thought you were between macs and using Ubuntu to transfer the files out of the NAT.

Since the mac also uses Samba, you can also use "smbclient" to access the share.

"smbclient -l <hostname>" to list the shares.
Try entering "help" and see which commands are available.

smbclient //host/sharename
will access the share as you might with ftp.
If cifs is used (maybe not on the mac), you will have access to commands such as getfacl, setfacl. Try to list a problem file with "getfacl". It should list the permissions and ownership of the file. CIFS allows you to use and change unix/linux ownership & permissions on a samba share. Since the nas uses ext3, it uses linux and may support CIFS.

Here is an example of mounting a share (in Linux) on a nas device (maxtor external drive with ethernet port):

sudo mount -t cifs //maxtor/jschiwal /mnt/maxtor/ -o uid=jschiwal,gid=jschiwal,dir_mode=0777,file_mode=0666,rw
Look at the mount manpage on your mac or you could use Ubuntu as before.
Now I can use "ls -l" to list the owner and the permissions. I can even use "sudo chown bob" to change the owner, and chmod to change the permissions.

Another possibility is to create a user & samba owner to match the ownership of the files.
Also try to remember your previous username/password under the old system.

All times are GMT -5. The time now is 11:37 AM.