LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-28-2004, 03:11 PM   #1
stabu
Member
 
Registered: Mar 2004
Location: dublin IRL
Distribution: Slackv12.1, Slamd64v12.1,Xubuntu v8.10_64, FC8_64
Posts: 438
Blog Entries: 5

Rep: Reputation: 32
locale errors help


Hi

I'm getting locale errors in connection with my C and man.
Can anybody help me figure them out?

1. Gdk-WARNING **: Locale not supported by C library

2. Locale: cannot set LC_CTYPE to default locale: no such file or directory

3. man: can't set the locale; make sure $LC_CTYPE and $LANG are correct.

What is the best way of avoid locale problems?

Any help appreciated. I did a search on "locale", but actually I didn't find any explanations on how to deal with locales, just suggestions on what to try. I got to wondering how many people really understand them.

I have also checked my two books on the subject (RUTE and Running Linux) and they are very patchy on the subject.

Thanks
 
Old 06-28-2004, 07:35 PM   #2
mysterio
Member
 
Registered: Sep 2003
Location: Springfield Ma.
Distribution: Mandrake 9.2,Knoppix 3.7,Slackware 10.0, FreeBSD. 5.3, OpenBSD 3.6, NetBSD 2.0, Debian
Posts: 275

Rep: Reputation: 30
Don't know what distro your using, but I was getting those errors in debian. This fixed it.
As root "dpkg-reconfigure locales" then pick your language.
 
Old 06-29-2004, 01:49 AM   #3
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
stabu, since you are running Knoppix, whixh is Debian based,
dpkg-reconfigure-locales
should solve your problem, just as mysterio says.
 
Old 06-29-2004, 04:12 AM   #4
stabu
Member
 
Registered: Mar 2004
Location: dublin IRL
Distribution: Slackv12.1, Slamd64v12.1,Xubuntu v8.10_64, FC8_64
Posts: 438
Blog Entries: 5

Original Poster
Rep: Reputation: 32
Hi misterio and linuxlala,

Thanks for your replies. Yes, I have a debian based distro, but as I mentioned I have been researching the locale issue. So, yes, I already was using dpkg-reconfigure locales.

In many ways, it's what got me into this mess in the first place. It definitely looks powerful, but it doesn't seem to tell C what's going on, or what has changed. I would use with caution if I was anybody else.

It's kanotix I'm having the trouble with, it's my second distro. At this rate I'm considering reinstalling, all because of the locale problem.
 
Old 05-15-2005, 11:49 AM   #5
stabu
Member
 
Registered: Mar 2004
Location: dublin IRL
Distribution: Slackv12.1, Slamd64v12.1,Xubuntu v8.10_64, FC8_64
Posts: 438
Blog Entries: 5

Original Poster
Rep: Reputation: 32
a year later and my problem persists

OK, I did a search and came up with this, my post from about a year back.

And it's still ongoing. I fidn locales very messy: there's several places where you can modify things: i18n and in X directories: it's really confusing.

Is there anybody who has seen a decent explanation of them? A webpage of some guy who decided one day he was going to sort it out?

ANybody with a better explanation of locales?
 
Old 05-15-2005, 12:52 PM   #6
mugstar
Member
 
Registered: Jun 2004
Location: Scotland
Distribution: Anything that'll install...
Posts: 305

Rep: Reputation: 30
There's some explanation here. The article is about using UTF-8 under Gentoo, but does refer to locales a lot. May be useful.
 
Old 05-15-2005, 02:00 PM   #7
stabu
Member
 
Registered: Mar 2004
Location: dublin IRL
Distribution: Slackv12.1, Slamd64v12.1,Xubuntu v8.10_64, FC8_64
Posts: 438
Blog Entries: 5

Original Poster
Rep: Reputation: 32
thanx Mugstar,

Yes, having a look at that ... my problem seems to reside in missing local files.

Code:
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
Each locale needs certain files? I mean stuff I have to download? checking it out further, if nay body else has more suggestions, welcome!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
locale: Cannot Set LC_ALL to default locale: No such file or directory. asym Linux - General 10 03-24-2013 08:35 PM
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 03:34 AM
"locale not supported by Xlib, locale set to C" Irad Linux - Software 3 06-25-2006 03:59 PM
C locale and system locale johnnydangerous Fedora 4 04-11-2005 03:37 PM
Locale Errors on Logon liquidcool Linux - Newbie 0 04-22-2004 08:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration