-   Linux - Newbie (
-   -   Local repository message: " ... missing from override file" (

babypeng 06-12-2008 12:55 AM

Local repository message: " ... missing from override file"
Hello all,

I am trying to figure out the way to ceate a trivial local repository.
I am following the instructions in the article "Debian repository HOWTO"
but something is not working.

Here is what I am doing:

I put the desired .deb packages in a folder.
I navigate to that folder and run the command:
dpkg-scanpackages . /dev/null | gzip -9c > Packages.gz
and I get the following message :
** packages in archive but missing from override file: **
and then the list of all the packages in the folder.

The same happens when I run the dpkg-scanpackages command with absolute
locations of the folder (and not just ".") .

When I run the command apt-get update
I get the following text:
"Ign file: packages/ Release.gpg"
"Ign file: packages/ Release"
"Ign file: packages/ Packages"

I know "Ign" stands for "Ignore" but I don't know
what are these 3 files, and why are they ignored.

When I try to install packages using Aptitude it says
the packages do not exit, but I know they do exist
because I see them in the folder I put them in.

I also added the proper line in sources.list :
deb file:/// .........

I am using Etch.

Any help appreciated.


All times are GMT -5. The time now is 03:21 AM.