LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Loads of errors when trying to compile Apache (https://www.linuxquestions.org/questions/linux-newbie-8/loads-of-errors-when-trying-to-compile-apache-426265/)

NewToasted 03-19-2006 09:57 AM

Loads of errors when trying to compile Apache
 
Hi!

I'm fairly new to the world of Linux (I've used it for 1.5 days now), but I think I'm starting to get the hang of it now :) I have an old 800 MHz Intel Celeron with 384 Mb of RAM that I'm trying to convert to a little Linux HTTP-server. For this I'm intending to use Apache 2.2.0 on ubuntu 5.10 with Xfce 4, and I've managed to get the configuration done correctly by using the command:

Code:

./configure --prefix=/usr/local/apache2
After executing that command it works for a minute or so, and then lets me type the next command, which should be
Code:

make
but then things get messed up. It finishes in about 10-20 seconds, and every row looks something like:

Code:

3c90x. h: xxxx(numbers): error: previous declaration  of 'full duplex' was here
And so the list goes on, replacing xxxx with numbers and 'full duplex' with a lot of other networking words. 3c90x is the name of the driver for my ethernet card I've tried to install, but thought I never managed to get working..

Should I start looking into my network card's driver / modules and such, or is the error something else?

Any help would be greatly appreciated!

Matir 03-19-2006 10:46 AM

How did the 3c90x.h file get into the same place as the apache2 sources? There isn't any driver code in apache2. Have you tried re-extracting the sources and trying it again?

NewToasted 03-20-2006 12:33 AM

I got it working. I emptied the working directory and removed a bad alias from the modules.conf :)


All times are GMT -5. The time now is 04:27 PM.