LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-09-2006, 06:03 PM   #1
Glass Casket
LQ Newbie
 
Registered: Jan 2006
Posts: 1

Rep: Reputation: 0
Smile Loading GRUB With 'Error 17', Need Help Badly


So here is my problem:

So I just finished trying to dual boot XP with Ubuntu for the tenth time. I set up my first linux partition as the primary and all other partitions logical. Then it asked me if I wanted to load the bootstrap loader in the MBR, I didnt know exactly what to do, so I checked yes.

Then when my system finished rebooting to finish the instalation, it goes straight to XP. So i'm now begining to think that I wasen't supposed to put the bootstrap loader in the MBR.

If that's what stopped me from dual booting, is there a way I can move the bootstrap loader? Or do I have to redo the whole instalation and pick not put the bootstrap loader in the MBR?

My system is as follows:

I have three hardrives.

Drive #1: One partition with all my music in NTFS.
Drive #2: Windows XP with 5 partitions.
Drive #3: Trying to get Linux on it.

The bootloader was GRUB.

Also, when I was setting up al my partitions on the third disk, I put it as type '/' (root). But there was also an option to put it as type boot.

I set up XP first.

And for some reason, the drive with Linux dosen't show up in the BIOS.

Any help would be greatly appreciated.

My Msn is also concubine_@hotmail.com if you wish to help me through there.
 
Old 01-09-2006, 08:48 PM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,807

Rep: Reputation: 2168Reputation: 2168Reputation: 2168Reputation: 2168Reputation: 2168Reputation: 2168Reputation: 2168Reputation: 2168Reputation: 2168Reputation: 2168Reputation: 2168
We need a little more detail.
What happens on boot - exactly.
- do you get an error 17 ??
- from selecting what ???.
- what do you mean it boots straight to XP ??. Do you select it, does it time-out to XP, does it not use grub at all (if so where is the error 17 coming from).
 
Old 01-10-2006, 06:59 AM   #3
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,072

Rep: Reputation: Disabled
There must be a mess with hard drives. With hard disk order as described it shouldn't boot at all. AFAIK XP boots only from first drive. Third HDD does not show up in BIOS ... Cabling, jumpers ...
Probably GRUB is installed to the wrong drive and this is why it boots directly to XP.
 
Old 01-12-2006, 09:40 AM   #4
gonzojd7
Member
 
Registered: Oct 2005
Location: Florida, USA
Distribution: Ubuntu 8.04, 9.04
Posts: 37

Rep: Reputation: 15
Maybe this will help. I installed MEPIS on my 3rd Hardrive and when GRUB installed, the MBR got corrupted. First I got the error 17 code, then I tried a bootloader called GAG but then there were no operating systems found. I researched the net and found a simple solution that another linux user suggested and it worked perfect. I installed SUSE linux 10 on my 3rd drive, in my case hdc. After the install of SUSE, Ii rebooted and had a beautiful menu screen prompting me for my choices of O/S. Thanks to the workers at SUSE, somehow it recognized my other drives, including Windows and now I can boot into both.
I'm not sure at this point if I'm going to change SUSE but for now I am a loyal user because of the mess it got me out of !!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB loading Error 17 cmlal Slackware - Installation 38 11-27-2010 03:21 AM
Error after loading Ubuntu from GRUB rapaport Ubuntu 7 06-09-2008 05:27 AM
GRUB Loading stage2Geom Error fr0zen Linux - Software 2 07-27-2005 11:04 AM
GRUB loading statge2read error rollerhl Linux - General 2 03-05-2005 08:04 PM
GRUB Error When Loading From Yast linuxdawg SUSE / openSUSE 3 02-07-2005 11:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration