-   Linux - Newbie (
-   -   Loaded Kernel modules on virtual server and CSF confusion (

mazz75 12-24-2010 02:29 PM

Loaded Kernel modules on virtual server and CSF confusion
Hi all, I wonder if anyone can suggest what is happening on my Centos virtual server (ps I'm having a great time re-learning Linux after a large gap and usually try and find out myself but this has me confused)

First thing I did was install Tomcat and try and change the port to 80 using iptables -nat and it complained a kernel module was missing. Instead setup Apache to redirect requests so that's now working

I then tried to install CSF firewall and the validation perl script returned fatal errors so I assumed OK my virtual server Kernel is restricted and used denyhosts instead which is working great

Here's the confusion..
I later retried the csftest script and it now works including all the iptables and nat stuff that fataled before. I've not rebooted or changed anything except run denyhosts and the postgres daemon + ended a few daemons that I didn't need (eg pickup,tlsmgr,courier,postfix,qmgr,saslauthd)

Running lsmod returns nothing and /proc/modules is zero bytes so I'm not able to tell what is loaded?

I'm tempted to try and get Tomcat redirecting via iptables and see what happens but if it works I don't like that something seems to have changed..

Oh.. before I ran it direct as root now I'm SU into root from another login

Maybe the sky gods at 1and1 saw what I was up to and intervened...

Thanks for any clues


wpeckham 12-24-2010 04:36 PM

virtual confusion
You did not mention what version of CentOS or what kind or version of virtualization you are using.

All times are GMT -5. The time now is 05:24 PM.