LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 07-25-2010, 04:08 PM   #1
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 716

Rep: Reputation: 102Reputation: 102
LM 9 LXDE -> Change Wallpaper ?


I just switched my netbook over to LM 9 LXDE and for the life of me I can't figure out how to change the wallpaper.....

Any ideas ?


I wanted something more light weight than the full Gnome version. Anybody have any luck with this version ?

All input appreciated.
 
Old 07-25-2010, 04:46 PM   #2
fbobraga
Member
 
Registered: Jul 2010
Location: São Paulo - Brasil
Distribution: Fedora 17 amd64 / Fedora 17 i686 LXDE (w e17)
Posts: 229

Rep: Reputation: 41
I'm using LXDE on Ubuntu 10.04: here, just right click the desktop and choose the "configure desktop" item, leads to it :P
 
Old 07-26-2010, 05:48 AM   #3
TheIndependentAquarius
Senior Member
 
Registered: Dec 2008
Posts: 4,598
Blog Entries: 29

Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
LXDE on OpenSuse 11.2

1. Right click the Desktop.
2. Select "Desktop Preferences".
 
Old 07-26-2010, 02:28 PM   #4
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 716

Original Poster
Rep: Reputation: 102Reputation: 102
Once you select the option to have the applications (PCman / Browser etc) off the right click menu added to the desktop menu the option to change the wallpaper disappears. It is initially there as everyone suggested. From a GUI aspect I have out yet to figure it out how to change it back. But if you go to->

/home/name/.config/pcmanfm/pcman.conf & edit the wallpaper= line you can change the background.

Seems like a a lot of work for a simple task.

Any other input welcome !!!!!

Code:
[config]
bm_open_method=0
su_cmd=gksu %s

[volume]
mount_on_startup=1
mount_removable=1
autorun=1

[desktop]
wallpaper_mode=1
wallpaper=/media/Abyss/Memories/Cool Graphics/Wallpaper/Artwork/ab_the_snatcher.jpg
desktop_bg=#000000
desktop_fg=#ffffff
desktop_shadow=#000000
show_wm_menu=1

[ui]
always_show_tabs=0
hide_close_btn=0
win_width=640
win_height=480
splitter_pos=150
view_mode=0
show_hidden=1
sort_type=0
sort_by=2
 
Old 07-26-2010, 03:59 PM   #5
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,732
Blog Entries: 12

Rep: Reputation: 454Reputation: 454Reputation: 454Reputation: 454Reputation: 454
LXDE - Have trouble with PCManFM 0.9.x? Read this FAQ!
http://blog.lxde.org/?p=737

You can start it pcmanfm –desktop to get to the preferences.
 
Old 07-26-2010, 04:27 PM   #6
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 716

Original Poster
Rep: Reputation: 102Reputation: 102
Question

Thanks for the reply but the command does not bring back the option.





Any other thoughts ?
 
Old 07-26-2010, 07:16 PM   #7
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
try assuming you are right handed

RH click empty space on desktop should bring up...desktop settings or "lxde" settings
go to TAB advanced if desktop settings came up...check the box and exit

RH click again and go to desktop settings ...first tab....and click on icon next to wallpaper and navigate to picture...it should appear immediately you select it otherwise reload settings

2) if that fails my settings diff from yours are

/home/gordy/.config/pcmanfm/main.lxde

[Desktop]
show_wallpaper=1
wallpaper=/home/gordy/pix/3d.jpeg
bg2=54908,46896,13240
[Interface]

3) I don't use LM but I wonder if you need to have that media mounted?...try moving that file out of media and into home


good luck
 
Old 07-26-2010, 08:30 PM   #8
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,732
Blog Entries: 12

Rep: Reputation: 454Reputation: 454Reputation: 454Reputation: 454Reputation: 454
Edit ~/.config/pcmanfm/pcmanfm.conf

change the line that has show_wm_menu
to show_wm_menu=0
 
Old 07-27-2010, 06:43 AM   #9
Pode
LQ Newbie
 
Registered: Oct 2008
Posts: 20

Rep: Reputation: 1
Run this command from terminal or Alt+F2
Code:
pcmanfm --desktop-pref
I think you use the openbox menu. For system wide edit this
Code:
sudo leafpad /usr/share/lxde/openbox/menu.xml
Then scroll down until you will see something this
Code:
  <item label="Desktop Settings">
    <action name="Execute">
      <startupnotify><enabled>yes</enabled></startupnotify>
      <command>pcmanfm --show-pref 2</command>
    </action>
  </item>
Then change the line where it writes
Code:
<command>pcmanfm --show-pref 2</command>
To
Code:
<command>pcmanfm --desktop-pref</command>
I use Slackware so it is maybe different in Linux Mint or the menu.xml is in different place.
Look it also in /home/YOURUSERNAME/.config/openbox/menu.xml
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Resizing VirtualBox with LXDE inside doesn't restretch wallpaper mmatt Linux - Newbie 16 07-06-2010 02:35 PM
[SOLVED] Screen goes blank after ten minutes (in LXDE), how to change this? cantab Arch 6 03-27-2010 11:31 AM
Can't change wallpaper w/ openbox / how to change mousespeed johnnyxxxcakes Linux - Newbie 14 05-24-2009 07:11 PM
Change time in Arch Linux + LXDE casperh Linux - Newbie 4 02-13-2009 03:33 PM
How to change wallpaper pacranch Amigo 9 06-27-2005 01:30 PM


All times are GMT -5. The time now is 08:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration