LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-25-2005, 04:33 PM   #16
MarkieC
LQ Newbie
 
Registered: Sep 2004
Distribution: Gentoo
Posts: 22

Original Poster
Rep: Reputation: 15

Well, thanks again for the prompt response...

It seems though there is still soemthing elementary im not doing. When I run the command;

cdrecord -scanbus

I get the following output;

Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J?rg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

i tried also deleting the link from /dev/cdrom1 to /dev/hdc but didnt have a /dev/sr0... although thats probably machine specific. I have a /dev/scd0 and /de/scd1. Is there any way of finding out hoe to make my link point to the right device?

Once I get this working I can then use DH's command line for trying to get the files to actually burn to disc.

Im sure im only a couple of steps away from cracking this
 
Old 01-25-2005, 05:03 PM   #17
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
On my system, I have a burner hooked up over IDE. It's referred to with two different device nodes:
/dev/scd0
/dev/sg0

Here are the two file listings in /dev for those entries:
Code:
brw-rw----    1 root     disk      11,   0 Jan 30  2003 /dev/scd0
crw-rw----    1 root     disk      21,   0 Jan 30  2003 /dev/sg0
If you're using a 2.4 series kernel, one thing you could try is to forcibly create the appropriate device entry. 2.6 kernels create devices dynamically, and I'm not sure how to go about setting that up. You can try this with a 2.6 kernel, and if it works, you could make it a part of your startup sequence as a temporary solution until you find the "proper" way of getting udev to do what you need.

Anyway, you create device files with the mknod command. For instance:
Code:
mknod -m 660 /dev/sg0 c 21 0
The "-m 660" sets the permissions to 660. /dev/sg0 is the path to, and name of, the device file to create. The 'c' indicates it is a character-based device (that corresponds to the first letter of the ls output for /dev/sg0 above). The "21 0" are the major and minor numbers for the device. These numbers specify what kind of device this file represents. Think of it as a mapping for the kernel between a device and a driver. You'll need to be root to execute the command, and you'll need to substitute the device cdrecord was looking for in its output. I honestly don't know if there is any pattern to naming the device sg0, sr0, or whatever. The only things that matter are the major & minor numbers, and matching the device name that cdrecord is expecting.

If you give it a try, and don't meet with success, then delete the device file as a precaution. You can get rid of it with good ol' rm.

Last edited by Dark_Helmet; 01-25-2005 at 05:05 PM.
 
Old 01-26-2005, 09:32 AM   #18
MarkieC
LQ Newbie
 
Registered: Sep 2004
Distribution: Gentoo
Posts: 22

Original Poster
Rep: Reputation: 15
I have both these devices too, my current symbolic link in /dev points to;

/dev/cdrom -> /dev/hdd
/dev/cdrom1 -> /dev/hdc (this one is the burner)

I tried changing my link to point;

/dev/cdrom1 -> /dev/scd0

or;

/dev/cdrom1 -> /dev/sr0

but i still get the same problems when running;

cdrecord -scanbus

 
Old 01-26-2005, 06:37 PM   #19
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Did you run cdrecord -scanbus as root?

I'm a little lost here. The error posted from the -scanbus command earlier said it couldn't read/access a device ('/dev/pg*' - typo?). The only reason I'm aware of to get that error is if the device file does not exist or the user doesn't have permission to access it. Then it's mentioned later that the device file does exist, or at least /dev/sg0 exists. So, is /dev/sg0 the same device file that the -scanbus command was looking for? Were you root when you ran the -scanbus command? If /dev/sg0 is not the device -scanbus wanted, what was it expecting, and does that device file exist?
 
Old 01-26-2005, 07:30 PM   #20
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,898

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
Oops! My bad. There's something you need to add to your bootloader's kernel line to boot with the appropriate capabilities. Google up a copy of "Karnervor's Linux HOWTO", which gives step-by-step instructions, with examples, of which files to edit, and what to enter. Adapt the entries to your system.
 
Old 01-30-2005, 01:56 PM   #21
MarkieC
LQ Newbie
 
Registered: Sep 2004
Distribution: Gentoo
Posts: 22

Original Poster
Rep: Reputation: 15
Hi DH, sorry for not replying sooner, if did run the commands as root. The device it is looking for is pg0 it wasnt a typo.

Im going to try a little something later tonight and see how it goes. There a Linux PC at work and its running RH9 like mine at home and it has the same problem it seems, the CDR drive is not a LITEON either. Its definately a config thing. I'll keep on bashing away here

Big Rig, I'll take a look cheers
 
Old 01-31-2005, 04:20 PM   #22
MarkieC
LQ Newbie
 
Registered: Sep 2004
Distribution: Gentoo
Posts: 22

Original Poster
Rep: Reputation: 15
Ok, here we go again...

heres an output from my cmd line for those pg* devices

[root@LinuxPC dev]# ls -l pg*
crw-rw---- 1 root disk 97, 0 Jan 30 2003 pg0
crw-rw---- 1 root disk 97, 1 Jan 30 2003 pg1
crw-rw---- 1 root disk 97, 2 Jan 30 2003 pg2
crw-rw---- 1 root disk 97, 3 Jan 30 2003 pg3

[root@LinuxPC dev]# cdrecord -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J?rg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

[root@LinuxPC dev]# cdrecord dev=ATAPI -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J?rg Schilling
scsidev: 'ATAPI'
devname: 'ATAPI'
scsibus: -2 target: -2 lun: -2
Warning: Using ATA Packet interface.
Warning: The related libscg interface code is in pre alpha.
Warning: There may be fatal problems.
Using libscg version 'schily-0.7'
scsibus0:
0,0,0 0) 'LITE-ON ' 'LTR-32123S ' 'XS0X' Removable CD-ROM
cdrecord: Warning: controller returns wrong size for CD capabilities page.
0,1,0 1) 'LITEON ' 'CD-ROM LTN301 ' 'ML16' Removable CD-ROM
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *

So I dont really know what the dev=ATAPI means but i read it somewhere on the web.

Quote:
Google up a copy of "Karnervor's Linux HOWTO",
I tried this but i couldnt find anything. I really know b*gger all when it comes to Linux
 
Old 01-31-2005, 11:20 PM   #23
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Actually, I had never seen the "dev=ATAPI" option before. It made me pull up the man page, and after a quick search, saw where it was mentioned.

In short, using ATAPI tells the computer that you're using scsi emulation for an IDE device. That's really not that important though.

Ok, so looking at the output from the ATAPI version with the -scanbus option, you have two drives. I don't know if you have two LITEON drives or if it's a single drive showing up at two different IDs. If you only have one drive, it may very well be that the CDR functionality was achieved by making the device look like two different devices (that's entirely speculation on my part). Anyway, I can't tell from the printed descriptions which one you should use. So, it's now experimentation time.

I assume you have an iso file you can burn (or that you can make one easily enough). As soon as you have one, execute (as root) a cdrecord command, and test both devices.
Code:
cdrecord dev=ATAPI:0,0,0 speed=?? iso_image_filename
and

Code:
cdrecord dev=ATAPI:0,1,0 speed=?? iso_image_filename
If one of them works, then make a note, and you're in business. If not, then you may be forced to search for the howto bigrigdriver mentioned, because my bag of tricks is definitely empty at this point...
 
Old 02-01-2005, 07:59 AM   #24
MarkieC
LQ Newbie
 
Registered: Sep 2004
Distribution: Gentoo
Posts: 22

Original Poster
Rep: Reputation: 15
OK DH, I'll give that a try. Not sure I actually tried that command line...

Bigrigdriver.... can you paste me a URL of that "how to" please
 
Old 02-02-2005, 05:57 PM   #25
MarkieC
LQ Newbie
 
Registered: Sep 2004
Distribution: Gentoo
Posts: 22

Original Poster
Rep: Reputation: 15


Heres what happened...

[root@LinuxPC curtis]# cdrecord dev=ATAPI -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J?rg Schilling
scsidev: 'ATAPI'
devname: 'ATAPI'
scsibus: -2 target: -2 lun: -2
Warning: Using ATA Packet interface.
Warning: The related libscg interface code is in pre alpha.
Warning: There may be fatal problems.
Using libscg version 'schily-0.7'
scsibus0:
0,0,0 0) 'LITE-ON ' 'LTR-32123S ' 'XS0X' Removable CD-ROM
cdrecord: Warning: controller returns wrong size for CD capabilities page.
0,1,0 1) 'LITEON ' 'CD-ROM LTN301 ' 'ML16' Removable CD-ROM
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *
[root@LinuxPC curtis]# cdrecord dev=ATAPI 0,0,0 speed=30 Piccies.iso
cdrecord: No such file or directory. No read access for '0,0,0'.
[root@LinuxPC curtis]# cdrecord dev=ATAPI 0,1,0 speed=30 Piccies.iso
cdrecord: No such file or directory. No read access for '0,1,0'.

help! i dont want to have to go back to windows
 
Old 02-02-2005, 06:36 PM   #26
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Quote:
Originally posted by MarkieC
[root@LinuxPC curtis]# cdrecord dev=ATAPI 0,0,0 speed=30 Piccies.iso
cdrecord: No such file or directory. No read access for '0,0,0'.
[root@LinuxPC curtis]# cdrecord dev=ATAPI 0,1,0 speed=30 Piccies.iso
cdrecord: No such file or directory. No read access for '0,1,0'.
The stuff in red, is that exactly the command used? The man page for cdrecord implies it needs to be ATAPI:0,0,0

To double-check me, do man cdrecord, hit the forward slash ( / ), type ATAPI, and hit the Enter key. A few lines down, you should see some text about the dev= option. I'd paste it if I could, but I can't at the moment.

If the commands you pasted are the commands you issued, give it another try using the colon. If you actually did use a colon and it got lost in the copy-paste, then ignore everything I just wrote...
 
Old 02-03-2005, 06:40 AM   #27
MarkieC
LQ Newbie
 
Registered: Sep 2004
Distribution: Gentoo
Posts: 22

Original Poster
Rep: Reputation: 15
AH HA!

I tried it on our Linux box here at work, and it worked!!!

WHOOPEEE!

I still have to get it to work at home though :worried:

one more question, though, after buring to the CD I couldnt do it again, does the CD-R always finalise after burning in Linux, and what do the speed relate to, if the drive is a 4x write drive shoudl i use a speed=30 option?
 
Old 02-03-2005, 04:25 PM   #28
MarkieC
LQ Newbie
 
Registered: Sep 2004
Distribution: Gentoo
Posts: 22

Original Poster
Rep: Reputation: 15
Thumbs up

YEEE HAAAAR!!!

I got home and it works, I burnt my first Linux CDR on my box at home! At last!

DH -thanks for all your help, couldnt have done it without you my friend

I was as you say the ...ATAPI:0,0,0... i missed out the colon!!!

 
Old 02-03-2005, 06:17 PM   #29
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Quote:
Originally posted by MarkieC
one more question, though, after buring to the CD I couldnt do it again, does the CD-R always finalise after burning in Linux, and what do the speed relate to, if the drive is a 4x write drive shoudl i use a speed=30 option?
There are options you can give to cdrecord that will specify how the disk should be finalized. The man page is one of the longer pages I've come across. So, you may have to trudge through a lot of information that doesn't apply.

The speed is how fast you'd like to burn the CD. It's the same value as your burner's rating (8x, 16x, 32x, etc., but without the 'x' of course). From what I can tell, if you give it a value higher than your CD supports, then the process throttles down to a speed the drive can handle. I don't have a lot of experience with different types of burners. So, your mileage may vary.

Congratulations on getting it working! As much as I'd like to take credit for it, you were the one that found the ATAPI thing. All I did was point out a missing colon
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu, Liteon 1633s won't r/w CDs bob1082 Linux - General 4 10-11-2005 11:24 PM
Need help with liteon dvdrw zonen Linux - Hardware 2 05-11-2005 05:23 PM
2 fc3 qs: cdr permissions and not start GNOME/X jasonv Fedora 2 11-28-2004 10:05 AM
Cendyne Liteon 24102b...where is cdrecord??? magicvash Linux - Hardware 6 08-11-2003 06:35 PM
Burn CD with k3b on Liteon 48x24x48 pixelV Linux - Hardware 5 03-21-2003 09:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration