LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Liteon CDR, where do I start? (https://www.linuxquestions.org/questions/linux-newbie-8/liteon-cdr-where-do-i-start-255241/)

MarkieC 11-15-2004 03:43 PM

Liteon CDR, where do I start?
 
I have two cdrom drives, my /etc/fstab files looks like this;

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
LABEL=/home /home ext3 defaults 1 2
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

I can read from both the cdrom drives, but the cdrom1 is a LITEON LTR 32123S drive. It doesnt look like the system is recognising the drive other than a normal cdrom drive. Im running red Hat 9.

Where do I start?

rshaw 11-15-2004 03:46 PM

change 'ro' (readonly) to 'rw' (readwrite) on whichever is the burner
or possibly just remove the 'ro'

MarkieC 11-15-2004 04:06 PM

Thanks, how do i get the system to re-read this file now?

rshaw 11-15-2004 04:14 PM

try mount -o remount /mnt/cdrom1

MarkieC 01-21-2005 02:43 PM

Ho hum...

No such luck im afraid... when i try that mount command i just get a scroll of text listing options for mount.

I tried;

mount /dev/cdrom1 /mnt/cdrom1

but it complains about;

/dev/cdrom1: Input / output error
mount: block device /dev/cdrom1 is write protected, mounting read-only
/dev/cdrom1: Input / output error
mount: you must specify the filesystem type

So im still stuck here. Ive been away so thats why its been so long since the last post on this thread

cs-cam 01-21-2005 06:46 PM

You can't just copy files to a CD on a burner, you need to use a program such as Gnomebaker or K3b to burn, those programs will recognise the burners alright, you may need to change some permissions but that's easy :)

MarkieC 01-22-2005 02:06 AM

I understand what you say about needing a program to write to a CD burner i have Gnome toaster but its still noe recongnising the drive.

I dont want to revert to windows, but i feel i may not have much choice here

Dark_Helmet 01-22-2005 02:38 AM

What do you mean "it's not recognizing the drive"? /dev/cdrom is just a generic term for a CD-based drive. It's not going to say /dev/cdr if that's what you're getting at.

Also, I don't think adding "rw" will do anything for you in /etc/fstab. As you quoted before, mount is just telling you it's a read-only filesystem (which it is) and trying to mount it as such.

If you're thinking the system isn't recognizing it because you can't mount, then try this:
1. Put in a normal CD containing data (one of your Linux install CDs would be perfect)
2. Execute the following command (as root):
Code:

mount -t iso9660 /dev/cdrom1 /mnt/cdrom1
If it spits out an error, paste what it says. If you don't get an error, then you should be able to see the contents of the cd by executing this command:
Code:

ls -l /mnt/cdrom1
And just to make sure we're on the same page, you cannot mount audio CDs or blank CDs.

MarkieC 01-23-2005 02:42 PM

Thanks for your reply DH, i did check this drive initially by popping a normal CD in here. Its acts fine as a normal CD drive.

Strange thing is that when I put a blank CD-R into the drive (this is ok isnt it) a window pops up entitled burn/// or it may be ///burn, anyway you can select some files and drag them into here and click on an icon above called something like "record" or "burn to disc" (i cant remember exactly which at the moment because im not logged into the linux box at the moment),

Anyway when I click this button, my only options from the dialog box is "write to iso image" the option of the CD writer doesn't show.

This is why i didnt think Lunix was recognising the hardware as being capable of writing to a CD.

I know you guys can help me solve my problem, I much prefer Linux to Windows.

Dark_Helmet 01-23-2005 03:22 PM

Oh yeah, it's perfectly fine to put a blank CD into the drive before you start doing any work to actually burn something. You just can't mount it; it's empty, and mounting it would only serve to confuse the computer.

To be honest, I'm a little wary of that feature (referring to the "burn" window you mentioned). I never really tried it because I was comfortable with other tools. I usually just closed the window and proceeded to do my "normal thing". The fact that it came up with a "burn" window should give you a warm-and-fuzzy feeling that the system realized your device was write-capable.

In general, the process for burning a CD in linux is to create an image file to burn to a disc. So, expect to see a message about creating/writing an iso file or something similar. I don't know how knowledgeable you are about iso files, so forgive me if this is "elementary". Think of that iso file as a map for the data on the CD. It contains everything: the CD's table of contents, the filesystem, the actual data in the files, etc. Once this file is created, the computer has "all its ducks lined in a row". To burn, the computer simply needs to stream the data from the file to the burner. It's a necessary evil when dealing with write-once media.

You can do all this over the command line (which is what I'm comfortable with), or you can use a burning application like XCDRoast, GnomeToaster, or others. Actually, those programs are just pretty front-ends for the command line. Anyway, it'll require some reading (you knew it was coming I'm sure) :) Or you can just experiment with the burn window. The worst that could happen is you trash a CD.

cs-cam 01-23-2005 06:13 PM

Unless you change the permissions for the CDROM device you'll need to be logged in as root to burn.

MarkieC 01-24-2005 03:28 AM

Well this is looking promising...:)

I understand what an ISO file is but not too much about the specifics, I wish I knew more... though the explanation above was useful, thanks.

So how can I use the command line? I actually prefer using the command line it gives you feedback that sometimes you may miss if you are using a GUI. I guess being bought up with GUIs (windows) you get lazy, and you rely on the GUI's designer to allow errors through, maybe sometimes they will mask or translate error messages with all the best intentions but this could also mean something gets missed.

If you could help me with the command line DH, then I would really appreciate it. I can log in as root, like DJ p@ckman says. But just a question how does someone change the permissions to a device, is is the same as when you do it with a file (i.e. chmod <filename> ), and do you carry this out on the /dev/cdrom1 device?

cs-cam 01-24-2005 04:24 AM

Post the output from this command
Code:

ls -l /dev/cdroms
That'll give you the real path to the devices and you chmod 0777 that. Once you've done that you should have no problem burning, or you can do it as root without chmod'ing any files.

Dark_Helmet 01-24-2005 01:49 PM

Here's a simple play-by-play of what I do for data CDs.

Go to a temporary/work directory(/home/user/temp for example), and create a new subdirectory (cd_layout perhaps). This new subdirectory will be the top level (or root directory) of the CD you'll burn.

Start copying files and directory structure over, making sure you're not exceeding available disc space.

Whn done copying files, return to the original temp/work directory and create the CD image with the mkisofs command:
Code:

cd /home/user/temp
mkisofs -J -R -o cdimage.iso cd_layout/

You now have an iso image of your data CD in a file named cdimage.iso. You can delete the cd_image tree now if you want (everything is in the cdimage.iso file). I usually keep it around until the burn is good. There are also lots of options for mkisofs. The man page can be a little... "heavy", but if you ever want to do something special, you'll have to buckle down and read it (man mkisofs).

Now you burn the iso file to the cd with the cdrecord command:
Code:

cdrecord dev=0,0,0 speed=30 /home/user/temp/cdimage.iso
Replace the text in red with what's appropriate for your system. To find out what the "dev=" argument should be, execute:
Code:

cdrecord -scanbus
Then identify which drive listed is your burner, and use the numbers provided in the output.

That's all you have to do. As DJ P@CkMaN said, you'll need to be root to execute the cdrecord commands unless you've made appropriate permission changes. I don't mess with permissions and just use "su -c" for the cdrecord command. For instance:
Code:

su -c "cdrecord dev=0,0,0 speed=30 /home/user/temp/cdimage.iso"

bigrigdriver 01-24-2005 06:34 PM

In order to get my LiteOn cd-rom/cd-rw/dvd-rom to work correctly, I had to delete the link between /dev/cdrom and /dev/hdc, and make a new link between /dev/cdrom and /dev/sr0. The LiteOn cd-rom is treated as an ide drive; the drives with other functions such as cd-rw and dvd-rom/rw are treated as scsi drives and need an appropriate kernel module.

Not my word; I got it from documentation and it worked.


All times are GMT -5. The time now is 10:07 PM.