-   Linux - Newbie (
-   -   Linuxant driver, /dev/modem disappears after reboot (

slackist 10-16-2004 10:03 AM

Linuxant driver, /dev/modem disappears after reboot
I have got the linuxant driver for my Thinkpad R51 (Slackware 10) softmodem, when I run hsfconfig it all sets up fine, creates /dev/modem linked to /dev/ttySHSF0 and the modem connects OK.

After reboot /dev/modem doesn't exist and I have to run hsfconfig to set it all up again.

Is this normal for the linuxant drivers?

I could use pkgtool to set up the modem but I am not sure which ttyS* to use and I don't want to assign the wrong one and find out that bluetooth or something gets broken.

Thanks for any ideas on this,


acid_kewpie 10-16-2004 10:24 AM

this isn't related to the driver you are using, but devfs, which is responsible for creating the contents of /dev each time you boot. what you need to do is configure devfs to create that device for you on boot. you need to edit /etc/devfsd.conf or a distro speciic inter[pretation of it. check the devfs manpage for further details about devfsd

slackist 10-16-2004 11:58 AM

Thanks for that acid_kewpie,

following the info you gave it seems that my hand-rolled kernel 2.6.7+chefmark's experiments (still a work in progress!) is using "udev", I have no idea what this means but this site :

gives a lot of info, sadly I am too stupid to understand most of it :o , this is going to take some reading

Thanks again,


acid_kewpie 10-16-2004 12:21 PM

blimey yeah i keep forgetting about udev. i remember a big shift from flat /dev directories to devfs... now it's on the way out... and to be honest i've no knowledge of udev whatsoever at the moment!

slackist 10-18-2004 11:19 AM

I solved this problem by putting the line

hsfconfig -a

into /etc/rc.d/rc.local

it adds a few seconds to the boot time but otherwise seems to work fine

darkleaf 10-18-2004 11:22 AM

Something else, do you really need driverloader. Ndiswrapper is free.

All times are GMT -5. The time now is 12:40 PM.