LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-06-2004, 01:40 AM   #1
jmr0311
Member
 
Registered: Jul 2004
Location: Texas
Distribution: Mandriva 2006
Posts: 97

Rep: Reputation: 15
Linux/Xp uncertainty in what to do?


I install lilo bootloader in my MBR, not knowing the consequences. I have windows XP pro running in partition hda1 and in partition hdb1. I want to be able to boot to those partitions using Lilo but I don't know what to do. I'll being reading a lot about the subject but I still don't feel comfortable doing this because I'm just 2 days old of experience in mandrake linux 10. I need some guidance from the gurus at linux in this forum with specific instructions. Sorry to be so annoyance. This is copy of how the fstab and lilo.conf file looks like:

/etc/fstab file

/dev/hda5 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda7 /home ext3 defaults 1 2
/dev/hdc /mnt/cdrom auto umask=0022,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
/dev/hdd /mnt/cdrom2 auto umask=0022,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0022,iocharset=iso8859-1,sync,codepage=850 0 0
/dev/hda1 /mnt/win_c ntfs umask=0022,nls=iso8859-1,ro 0 0
/dev/hdb1 /mnt/win_c2 ntfs umask=0022,nls=iso8859-1,ro 0 0
none /proc proc defaults 0 0
/dev/hda6 swap swap defaults 0 0
none /mnt/hd supermount dev=/dev/ide/host0/bus0/target1/lun0/part1,fs=ext2:vfat,--,umask=0022,iocharset=iso8859-1,kudzu,codepage=850 0 0

And this is how the Lilo.conf file looks like:

/etc/lilo.conf file

boot=/dev/hda
map=/boot/map
default="linux-i686-up-4GB"
keytable=/boot/us.klt
nowarn
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="linux"
root=/dev/hda5
initrd=/boot/initrd.img
append="devfs=mount acpi=ht splash=silent"
vga=788
read-only
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/hda5
initrd=/boot/initrd.img
append="devfs=mount acpi=ht"
read-only
image=/boot/vmlinuz-i686-up-4GB
label="linux-i686-up-4GB"
root=/dev/hda5
initrd=/boot/initrd-i686-up-4GB.img
append="devfs=mount acpi=ht splash=silent"
read-only
image=/boot/vmlinuz-2.6.3-7mdk
label="263-7"
root=/dev/hda5
initrd=/boot/initrd-2.6.3-7mdk.img
append="devfs=mount acpi=ht splash=silent"
read-only
image=/boot/vmlinuz
label="failsafe"
root=/dev/hda5
initrd=/boot/initrd.img
append="failsafe acpi=ht devfs=nomount"
read-only
other=/dev/hda1
label="windows"
table=/dev/hda
other=/dev/hdb1
label="windows2"
table=/dev/hdb
map-drive=0x80
to=0x81
map-drive=0x81
to=0x80
other=/dev/fd0
label="floppy"
unsafe
 
Old 07-06-2004, 01:47 AM   #2
goofyheadedpunk
Member
 
Registered: Aug 2003
Distribution: Arch Linux
Posts: 140

Rep: Reputation: 15
So what's your problem? You didn't explain what you need help with. Are you not already able to boot to both, and if so which one aren't you able to boot to?

Check this out.

If you did explain your problem, and I missed it, I'm sorry. If that's the case, boy do I feel like a douche.

Last edited by goofyheadedpunk; 07-06-2004 at 02:03 AM.
 
Old 07-06-2004, 01:55 AM   #3
dharmu_r
LQ Newbie
 
Registered: Jul 2004
Posts: 4

Rep: Reputation: 0
Have tried installing the lilo with configuration. As far as I know you should not receive any error when you run lilo. After running lilo just try rebooting the linux box. make sure that you have a backup copy of lilo in floppy or cd.

Dharmendra T.
 
Old 07-06-2004, 08:48 AM   #4
jmr0311
Member
 
Registered: Jul 2004
Location: Texas
Distribution: Mandriva 2006
Posts: 97

Original Poster
Rep: Reputation: 15
To tell you the truth , I don't even know if Lilo is running because everyone talks about the Lilo interface screen that's supose to show you the systems that is booting up, so you can select one. But in my case that never happen, when I boot the machine goes straight to mandrake linux 10. I'm not having any error in the booting sequence, but I lost the capacity of booting into the windows XP system when I decide to install Lilo in the MBR. I need some guidance in what to do with preferably spacefic instructions. I also was trying to create a booting floppy disk so if I mess up lilo I still could load the system and fix any mistakes to "Lilo.conf" but it doesn't seem to work for me or I don't know what i'm doing. I use this instructions I found while exploring the different alternatives in How to create the booting floppy,

1.fdformat /dev/fd0H1440 # Lay tracks on new diskette
2.mkfs -t minix /dev/fd0 1440 # Create minix file system on floppy
3.mount /dev/fd0 /mnt/floppy # Mount floppy
4.cp -p /boot/chain.b /mnt/floppy # Copy chain loader
5.cp -p /boot/boot* /mnt/floppy
6.lilo -v -C /etc/lilo.floppy # Install lilo and the map onto floppy
7.umount /mnt/floppy

I'm able to execute this until I get to instruction 3, then I get permission denie even running as a root. I'm tempted to tackle this problem but I want a safety key inthe event of screwing lilo I still can go back to mandrake and fix it. I'm also tempted to re-load NTLDR in the MBR of my first partition, but doing so I loose the capacity of going back to mandrake and continue working on the problem. Any help, please.

Javi
 
Old 07-06-2004, 12:20 PM   #5
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
I believe in Mandrake you can look in the Mandrake Control center under boot and you should be able to see your Lilo boot options also the time to show lilo to give you a chance to select either option.

Also in here I believe there is a make boot floppy choice
 
Old 07-14-2004, 12:58 PM   #6
mdg
Member
 
Registered: Sep 2003
Distribution: Slackware
Posts: 626

Rep: Reputation: 38
jmr0311 - edit the lilo.conf file and add the line "timeout=100" between "nowarn" and "message=.."
Code:
nowarn
timeout=100
message=/boot/message
Seems to me that lilo is booting immediately to the default with no waiting time to choose any other option in the lilo menu. Adding the line will make the menu stay up long enough to choose windows.

edit: the previous post already mentioned this - I didn't notice
Also didn't notice this is an old thread

Last edited by mdg; 07-14-2004 at 01:08 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
link dies intermittently-seemingly at random- between win<->linux not linux<->linux?? takahaya Linux - Networking 10 03-09-2007 11:37 PM
triple boot linux/linux/linux No Windows involved toastermaker Linux - Newbie 12 03-02-2006 11:40 PM
Redhat (rhel v2.1) bootup problem with linux (linux vs linux-up) namgor Linux - Software 2 06-24-2004 03:49 PM
X script uncertainty offworld Linux - General 6 03-08-2004 11:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration