LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Linux won't load/install on new PC (https://www.linuxquestions.org/questions/linux-newbie-8/linux-won%27t-load-install-on-new-pc-513804/)

screphoe 12-26-2006 11:38 AM

Linux won't load/install on new PC
 
This is my only desktop pc, so i can't swap hardware for older older ones, and i am new to Linux.
I have tried various distros(Mandriva, Fedora, Suse, Ubuntu) but I fear my hardware is too new.
Always gets errors on boot.
Linux distros work fine on my laptop so i know I'm installing right.
Is there a distro to match my PC hardware?

OS: microsoft windows xp pro sp2
Processor: AMD Athlon 64 FX-62 <- might be the problem?
Ram: 2gb
harddrives: 2x 300gb maxtor
Graphics Card: Nvidia geforce 7950 GX2 1024mb <- might be the problem?
Motherboard: Asus M2N32-SLI DELUXE
Sound Card: Creative SoundBlaster X-Fi
Monitor: Viewsonic VA2012w

Robert Diggs 12-26-2006 11:56 AM

Your processor and RAM should be fine. Just make sure you're using the 64 bit version of the OS so it works. Also, you didn't list which version you were trying to use for each distro, but make sure it's the latest one so it's updated. Like you said, it is possible for the OS to choke on your hardware. It's not unheard of.

Regards,

Brandon

JimBass 12-26-2006 02:19 PM

Posting the errors would be the most effective thing you could do so that we could help you. Just saying errors isn't very specific, and forces us to guess.

The processor probably isn't a problem. As already mentioned, you have the option of using a 64bit OS, then you should use that. When a new processor comes out, it might be a while till the OSes can use its full resources (like a 64 bit processor before the 64 bit OS), but it would still work at reduced capacity.

The graphics card might cause a problem with a graphical installer, but probably not. They tend to install at low settings, requiring no optimization. If your distro of choice supports it, do a text install and see if that makes any difference.

The largest area for a problem is installing to Satas on a mobo controller. If you created a raid1 or raid0 system with the motherboard controller in windows, that is most likely the problem. Having the newest version of any distro will help with the sata install, as more recent kernels have more current drivers for hardware.

Peace,
JimBass

screphoe 01-07-2007 09:01 PM

Thanks.
 
I tried these distrubutions.
ubuntu 5.10 & 6.06 & live
suse 10.0 & 10.1 & live
damn small linux
morphix live
mandriva one 2007
fedora core 5
On all the distros they load all the preliminary stuff to the screen where it asks you to press enter to install, then just goes blank. Even when I try a no graphical install or noapic etc. It doesn't display any errors.
I managed to get fedora core 5 to install, but upon re-boot, it just freezes while trying to load. Tried the install 2 more times again fresh but to no luck. I tested all cd/dvd's on a laptop(all install&work) then on the pc, and none even load pass on to install.
no errors displayed or anything. just blank.
kept on at it though and got opensuse 10.2 to successfully install and work.

just kept on truckin'

cheers!


All times are GMT -5. The time now is 06:17 PM.