LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-04-2005, 12:52 PM   #1
zbinwu
LQ Newbie
 
Registered: Sep 2005
Posts: 12

Rep: Reputation: 0
Linux Time setting?


I installed both Linux and Windows XP in my computer. My Linux has a time 4 hour later than the local time. And when I change it to the correct time, the Windows time get 4 hour faster. And if I corrects Windows time, the Lunux time gets wrong again.
Does anyone know what goes wrong?

Thanks!
 
Old 09-04-2005, 01:13 PM   #2
Ynot Irucrem
Member
 
Registered: Apr 2005
Location: Perth, Western Australia
Distribution: Debian
Posts: 233

Rep: Reputation: 30
check that you have your timezone set correctly and that if you are using local time, you don't have "use UTC" checked. just right-click the clock in linux and look around in the preferences or configuration, or whatever menu is there.
 
Old 09-04-2005, 02:06 PM   #3
linuxlastslonge
Member
 
Registered: Jun 2002
Location: Franklin, IN
Distribution: Debian, CentOS, Mac OS X
Posts: 158

Rep: Reputation: 30
it sounds like when you set the time in linux, that it is syncing the software clock with the hardware clock; which in turn is causing trouble with windows' clock. double check your clock settings in your BIOS and make sure that they are set to your local time (as stated from a previous post above).

hope i could help!

-linuxlastslonger-
 
Old 09-04-2005, 05:16 PM   #4
zbinwu
LQ Newbie
 
Registered: Sep 2005
Posts: 12

Original Poster
Rep: Reputation: 0
I checked that the BIOS is right in the time, and Windows is right, too. Both are EST time. The Linux time is wrong (4-hour later), but the timezone settting is EST time too. And If I revise the linux time, it will update hardware clock setting when I exit Linux. Then BIOS and WINDOWs clock will become wrong.

How can I disable the "update hardware clock" function?


Thanks a lot!
 
Old 09-04-2005, 05:33 PM   #5
teebones
Member
 
Registered: Aug 2005
Location: /home/teebones
Distribution: sometimes this, sometimes that..
Posts: 502

Rep: Reputation: 56
why not use a timeserver? this way both os'es use the correct time.
 
Old 09-04-2005, 05:56 PM   #6
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
Just make sure your distro is using local time and not GMT. the distro your using would help since different distros setup time differently.
 
Old 09-04-2005, 06:09 PM   #7
zbinwu
LQ Newbie
 
Registered: Sep 2005
Posts: 12

Original Poster
Rep: Reputation: 0
It seems tha problem is that the Linux regards the system (BIOS) clock as UTC time, but in fact, it is local time.
Now, I change the /etc/default/rcS file UTC=yes to UTC=no.
It seems that the problem is solved.

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hell of a time setting up linux router knappster Linux - Networking 6 10-17-2004 07:45 PM
Setting System Time: kernel in wrong time zone warrenweiss Linux - General 7 05-15-2004 04:25 PM
setting time vwal_13 Slackware 2 04-19-2004 12:40 PM
Setting up a Linux/Redhat system 1st time! andyc1000 Linux - Newbie 3 09-01-2003 02:46 PM
Setting Time monte Linux - Software 4 08-05-2003 09:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration