LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-12-2011, 11:17 PM   #1
static360
LQ Newbie
 
Registered: Oct 2011
Posts: 6

Rep: Reputation: Disabled
Linux redhat Samba configs


Hi, new to the forum. Name is John. Currently a student taking redhat class at Univ.
So am doing one of my workbooks and i have a lab exercise that i need to grade. the Third specification as to add a hosts allow line that explicitly allows clients from the so so and so network, implicitly denying everyone else. I got the first part right about allowing so so and so network but the last part where it says to denying everyone else is what is preventing me from getting a 100 in the exercise. i tried "host deny = all" in the configs but it doesn't work my grade is still at a 66 even after restarting the service and using the testparm command.

This is what the host section of my smb.conf file looks like "

; hosts allow = 127. X.X.0
: hosts deny = all

does anybody have any suggestions on what am doing wrong, i know am new here to the forum and sorry for making it so long but any help would be appreciated.
 
Old 10-13-2011, 03:52 PM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Use

host deny = 0.0.0.0/0

instead.

Restart samba and then give it a try.

Last edited by T3RM1NVT0R; 10-13-2011 at 04:01 PM.
 
Old 10-13-2011, 06:19 PM   #3
ron225
LQ Newbie
 
Registered: Jan 2006
Posts: 1

Rep: Reputation: 0
Did you restart Samba after adding "host deny=all"?
 
Old 10-13-2011, 08:56 PM   #4
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,417

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
Also, try 'testparm' to get Samba to syntax check the cfg
 
Old 10-13-2011, 11:30 PM   #5
static360
LQ Newbie
 
Registered: Oct 2011
Posts: 6

Original Poster
Rep: Reputation: Disabled
Yea i restarted the service and used the testparm command also, i shut the service down completely instead of just restarting it. I am startign the VM now and to try adding the host deny line
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] samba in redhat linux maheshp86 Linux - Server 6 09-06-2010 10:17 AM
samba cannot connect to ldap. log output and configs in message. far_star Linux - Server 1 12-04-2009 08:27 AM
how to use linux server to backup cisco configs steve-0 Linux - Networking 11 06-28-2007 01:22 PM
viewing raid configs under linux wnguza Linux - Newbie 1 11-16-2006 07:54 AM
configs file in the linux kernel source tree ashlesha Linux - Newbie 7 06-29-2006 06:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration