-   Linux - Newbie (
-   -   linux not detecting ethernet card (

pamcat 06-27-2008 03:06 PM

linux not detecting ethernet card
Hi all my son downloaded linux red hat onto my computer and wiped out windows xp. Linux will not detect my ethernet card can you tell me how to detect the ethernet connection Thanks pam

jailbait 06-27-2008 03:21 PM

We need more information. Start a command shell and enter these commands:

lspci -v > lspci.txt

which will list your pci devices in a file called lspci.txt

ifconfig -a > ifconfig.txt

which will list your network interfaces in a file called ifconfig.txt

Please post the contents of lspci.txt and ifconfig.txt here on LinuxQuestions.

Steve Stites

P.S. You can also blindly try the command:
ifup eth0

That is the most likely command to start your network interface.

pamcat 06-27-2008 03:32 PM

how do i get to command shell?
I do not know how to get to command shell. we have Linux red hat 8 thanks pam

alan_ri 06-27-2008 03:50 PM

I would like to know what version of Red Hat is that.If you are new to Linux open a program called console or terminal then type su - and enter your root (admin's) password and hit enter,then cd /etc and then cat /etc/modules.conf or if that command doesn't work use this cat /etc/conf.modules and post the output here.Also post the output of /sbin/lsmod command here.Maybe you just have to enter correct data for your interface.Try with netcfg command.Did you tried any GUI application in Red Hat for network configuration?Also have a look here;

pamcat 06-27-2008 03:59 PM

made it to command shell
made it to command shell with the help of the book

here is what appears after the first command
-v be verbose
-n show numeric id's
-b bus centric view
-x show hex -dump of config spare
-s [[<bus>]:][<slot>][.[<func>]]
-d [<vendor.}:[<device>]
-t show bus tree
-m produce machine readable output
-i <file> use specified id database instead of /usr/share/hwdata/pci.ids
-M enable bus mapping mode
-P <dir> use specified directory instead of /proc/bus/pci
-H <mode> use direct hardware access (<mode. = 1 or 2
-F <file> read configuration data from given file
-G enable PCI access debugging

2nd part config txt shows command not found

thanks for your help pam

Brian1 06-27-2008 04:55 PM

See the output from this. ' /sbin/lspci -v ' adding ' > lspci.txt ' sends the output to a file called lspci.txt

For the other use ' /sbin/ifconfig -a '. The reason for not working is /sbin is not a users path.

Being Redhat 8 is 6-7 years old. Very old in Linux. I would install Fedora 8. New kernel, more hardware support, new rpm files to work with newly released rpm files.


All times are GMT -5. The time now is 03:48 PM.