LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-01-2018, 07:59 AM   #1
Rendrick
LQ Newbie
 
Registered: Jun 2018
Posts: 9

Rep: Reputation: Disabled
Linux Mint 18 Cinnamon has stopped finding my USB devices.


It used to mount my USB devices - memory stick, external hard drive - as soon as I attached them, but now nothing shows up and so I can't access the contents. My USB mouse and keyboard both work so the problem seems to lie with storage devices.
 
Old 09-01-2018, 11:50 AM   #2
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware, OpenBSD
Posts: 4,197
Blog Entries: 11

Rep: Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372
Have you tried mounting them by hand?
 
Old 09-01-2018, 12:12 PM   #3
Rendrick
LQ Newbie
 
Registered: Jun 2018
Posts: 9

Original Poster
Rep: Reputation: Disabled
Sorry I'm so ignorant, but how do I manually mount?
 
Old 09-01-2018, 12:46 PM   #4
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware, OpenBSD
Posts: 4,197
Blog Entries: 11

Rep: Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372
First find out what device name the drive has been given by the kernel. It will be sd*, probably sdb. You can find it at the end of your kernel log immediately after plugging it in. For example, here's one from my machine:
Code:
Aug  5 17:57:29 bigboy kernel: [31249.639601] sd 5:0:0:0: [sdg] 15248832 512-byte logical blocks: (7.81 GB/7.27 GiB)
Aug  5 17:57:29 bigboy kernel: [31249.640216] sd 5:0:0:0: [sdg] Write Protect is off
Aug  5 17:57:29 bigboy kernel: [31249.640220] sd 5:0:0:0: [sdg] Mode Sense: 23 00 00 00
Aug  5 17:57:29 bigboy kernel: [31249.640830] sd 5:0:0:0: [sdg] No Caching mode page found
Aug  5 17:57:29 bigboy kernel: [31249.640832] sd 5:0:0:0: [sdg] Assuming drive cache: write through
Aug  5 17:57:29 bigboy kernel: [31249.666224]  sdg: sdg1
Aug  5 17:57:29 bigboy kernel: [31249.669085] sd 5:0:0:0: [sdg] Attached SCSI removable disk
Aug  5 17:57:34 bigboy kernel: [31255.343762] EXT4-fs (sdg1): mounted filesystem with ordered data mode. Opts: (null)
Here the disk is sdg and the partition on it is sdg1. There will probably be suitably named directories under /media for mounting these things on

If you have an ext4 system on the partition, open a terminal and type (for example) sudo mount -t ext4 /dev/sdg1 /media/usb. This is only a suggested template for the command; you must modify it to fit your system. Note the sudo prefix; you have to be root to do it this way.

If you can mount pluggable devices by hand, you can access their contents but you will still need to find out why they are no longer being mounted automatically.

Last edited by hazel; 09-01-2018 at 01:36 PM. Reason: Added sudo
 
Old 09-01-2018, 03:02 PM   #5
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware, OpenBSD
Posts: 4,197
Blog Entries: 11

Rep: Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372
Further to this:

Having to be root to mount devices is tiresome, so two ways have evolved to allow ordinary users to do this.
The traditional Unix way
An entry for the device is made in the filesystem table /etc/fstab. This includes the mount directory, the filesystem type, and various mount options. If one of the options is "user", then any user can mount the device by typing mount /dev/sd<x>1.
The sloppy modern way
The graphical file manager mounts pluggable devices automatically for any user who clicks the mount directory, providing that the user is in the plugdev group.
 
Old 09-01-2018, 05:24 PM   #6
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 19.3 MATE
Posts: 8,040
Blog Entries: 5

Rep: Reputation: 2897Reputation: 2897Reputation: 2897Reputation: 2897Reputation: 2897Reputation: 2897Reputation: 2897Reputation: 2897Reputation: 2897Reputation: 2897Reputation: 2897
Open the file manager (Nemo). Select Edit->Preferences. Click on the Behaviour tab. In the Media Handing section, check that all 4 options are selected (read them first to verify that you want all of them).
 
Old 09-02-2018, 01:41 AM   #7
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 13,722
Blog Entries: 9

Rep: Reputation: 3791Reputation: 3791Reputation: 3791Reputation: 3791Reputation: 3791Reputation: 3791Reputation: 3791Reputation: 3791Reputation: 3791Reputation: 3791Reputation: 3791
Quote:
Originally Posted by hazel View Post
Here the disk is sdg and the partition on it is sdg1. There will probably be suitably named directories under /media for mounting these things on
this is technically correct, but i advise against using the /media directory for this.
dbus might be using it to atomount things, and messing around in there might confuse it.
better to use a self-created directory for this.
 
Old 09-02-2018, 02:47 AM   #8
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware, OpenBSD
Posts: 4,197
Blog Entries: 11

Rep: Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372
Quote:
Originally Posted by ondoho View Post
this is technically correct, but i advise against using the /media directory for this.
dbus might be using it to atomount things, and messing around in there might confuse it.
better to use a self-created directory for this.
Wow! I am out of date! But of course that's why I hate modern desktops and never use them. They're always doing things behind your back, just like bloody Windows!

OP: If you need to mount things by hand and want to take Ondoho's advice, you can use /mnt rather than /media. That's a very old, traditional directory tree for mounting things in and no modern system is going to interfere with it.
 
Old 09-02-2018, 11:18 PM   #9
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 13,722
Blog Entries: 9

Rep: Reputation: 3791Reputation: 3791Reputation: 3791Reputation: 3791Reputation: 3791Reputation: 3791Reputation: 3791Reputation: 3791Reputation: 3791Reputation: 3791Reputation: 3791
oops, i just realized that on my archlinux system USB sticks are mounted to /run/media.
however, veracrypt defaults to /media (and my guess is it's not veracrypt itself but fuse).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Unable to mount USB drive to Linux Mint 18.1 Cinnamon 64-bit mmm123 Linux - Newbie 25 10-23-2017 09:41 AM
update manager and other software stopped working in mint 17.1 cinnamon mintisurgeon Linux - Newbie 3 01-27-2015 04:08 AM
Two USB ports not recognising any devices including USB mouse: Linux mint 13 MAYA nikiitea Linux - Hardware 6 03-16-2014 11:25 AM
Boot Error on linux mint 13 cinnamon live usb BillThePlatypus Linux - Newbie 6 08-16-2012 09:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration