LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-19-2018, 03:56 PM   #1
AceMcHammer
LQ Newbie
 
Registered: Mar 2018
Posts: 6

Rep: Reputation: Disabled
Linux Mint 18.3 - YouTube video audio extremely choppy, video portion smooth even at HD


Linux Mint 18.3
Cinnamon 64-bit v3.6.7
Internet Browser: Firefox Quantum v58.0.2
Audio input is via HDMI cable from video card (have no other issues with audio except Youtube so far)

I'm totally new to Linux. Been on Windows for 25 years starting with Windows93. Had a problem activating a copy of Windows7 to a Motherboard it was already previously activated on and finally said screw Windows. Microsoft makes all it's customers feel like pirate scoundrels that need to be kept in line. You are owned by Microsoft. You run a computer and browse the Internet at Microsoft's behest. FU Microsoft!! Ok. Got that off my chest.

So I installed Linux Mint last week and have figured out everything I need to do so far to set up Linux for long term operation but I'm stumped on the Youtube audio issue. Got a feeling it's either some kind of setting in Firefox our some kind of audio codec issue in Linux Mint. Anyone got any idea's? The video portion of the video is smooth as can be even at HD resolution. The sound is so choppy it's totally not understandable.
 
Old 03-20-2018, 09:32 AM   #2
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915
As per https://www.reddit.com/r/linux/comme..._choppy_audio/, have you tried disabling "Auto Mute" in alsamixer?

Have you tried another browser?

Have you tried playing a video directly from your PC, using e.g. Xplayer?

Have you tried playing videos from an internet site that isn't YouTube?
 
Old 03-20-2018, 12:04 PM   #3
AceMcHammer
LQ Newbie
 
Registered: Mar 2018
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hello and thanks for the reply. I was getting messed up sound in everything that outputs sound from a music CD playing through Rhythmbox or VLC Media Player to Flash video on YouTube to everything. I kind of have the issue partially resolved. I got on the Linux Mint help chat on HexChat and someone helped me to figure out the problem.

In Linux Mint 18.3 if you click on the Sound Icon in the bottom right hand corner of the taskbar and click on settings/input, there I had two sound input profiles. "Built in Audio" and "HDMI Audio". I had the correct audio profile selected as being "HDMI". However, when I got on Linux Mint help on HexChat someone told me I needed to go to software manager and search for an application called "PavuControl" and install that first in order to set my "Built in Audio" to "Off". After installation of Pavucontrol go to Menu/Sound & Video/PulseAudio Volume Control and open that sound control panel. Then go to the "Configuration" tab and make sure the setting for "Built in Audio" is set to "Off".

After I followed that my sound was still messed up so I decided to reboot to see if that would work and that did finally work. All sound output from everything was fine after that. But, later that night the sound messed up again and I had not changed any settings. So a rebooted Linux and the sound was fixed again. So, I would have to say I have found a partial solution.

There may be an option in my BIOS settings to turn off onboard audio but I do not think so. I have been in my BIOS settings many times and do not recall seeing that but I am going to check for that. As it stands right now my audio is fine. If my sound messes up again I will just reboot. I hope I can find a permanent solution. I will post an update if there was an option to turn of onboard audio on my BIOS settings and if that resolved the issue for good.

By the way, I'm not sure I even have alsamixer installed on my system to see if "Auto Mute" is turned off. It's not in Menu/Sound & Video. Where would that be located at if it was installed?

Last edited by AceMcHammer; 03-20-2018 at 12:13 PM. Reason: Forgot Something
 
Old 03-20-2018, 01:41 PM   #4
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915
Thanks. I'll have a think about your partial solution in a moment - have you followed it up on Mint's HexChat to say that it it only seems to solve the problem temporarily? alsamixer can be run by just entering that command in the Terminal.
 
Old 03-20-2018, 01:50 PM   #5
AceMcHammer
LQ Newbie
 
Registered: Mar 2018
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by hydrurga View Post
Thanks. I'll have a think about your partial solution in a moment - have you followed it up on Mint's HexChat to say that it it only seems to solve the problem temporarily? alsamixer can be run by just entering that command in the Terminal.
I pulled up alsamixer and there is no "Auto Mute" function toggle in any of the preferences in the panel.
 
Old 03-20-2018, 02:42 PM   #6
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915Reputation: 2915
Quote:
Originally Posted by AceMcHammer View Post
I pulled up alsamixer and there is no "Auto Mute" function toggle in any of the preferences in the panel.
Interesting. There is on mine (at the extreme right) and I'm also running Mint 18.3, albeit the MATE flavour.

Never mind. If you would like to try something else, enter the following on the command line:

Code:
pactl set-card-profile 0 output:hdmi-stereo
and then run Pavucontrol, select Configuration and say what the Profile is set to.
 
Old 03-21-2018, 02:31 AM   #7
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 16,881
Blog Entries: 10

Rep: Reputation: 5021Reputation: 5021Reputation: 5021Reputation: 5021Reputation: 5021Reputation: 5021Reputation: 5021Reputation: 5021Reputation: 5021Reputation: 5021Reputation: 5021
Quote:
Originally Posted by AceMcHammer View Post
I pulled up alsamixer and there is no "Auto Mute" function toggle in any of the preferences in the panel.
please have a look at this - it's a bit small but if you look at the far right, it's right there.
are you sure you haven't missed that?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Video is choppy on Mint 17 gugamare Linux - Software 12 08-05-2015 05:02 AM
LXer: How to Download Youtube Video or Audio Tracks from the Linux Terminal LXer Syndicated Linux News 0 01-04-2014 01:12 PM
Linux Mint Nadia on Dell Precision M6400 - wierd slowness, choppy video kourama Linux - Laptop and Netbook 2 02-05-2013 11:40 PM
youtube video streaming extremely slow with puppy linux, how can i fix this? benmanny Puppy 8 01-11-2012 03:50 AM
Choppy dvb-t video and audio shertiger Linux - Software 1 05-23-2009 09:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration