Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 12-15-2013, 01:25 PM   #1
Registered: Aug 2012
Posts: 61

Rep: Reputation: Disabled
Question Linux Mint 13 - Laptop Won't Wake Up from Suspend

Hoping I can get some help for this issue I've been having with my Toshiba laptop. I post on the Linux Mint forums here but I haven't gotten any responses.

I fixed an issue with the screen brightness where it wouldn't get much brighter. I ran a change in the GRUB file using the Terminal which fixed the brightness issue.

However, now my laptop will not turn on after it wakes up from suspend. I tried changing line 11 and 12 in the GRUB file to this;

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_*osi=Linux acpi_backlight=vendor"
It is has not fixed the issue though and still a black screen after waking up from suspend. Anyone have an idea for a fix?

System Specs
Maya 13 - 64 Bit
Kernel Linux 3.2.0-23-generic
GNOME 3.4.2

Toshiba Portege
Memory: 5.7 GiB
Processor: Intel Core i5-2435M CPU @ 2.40GHz 4 (Sandybridge)
*This model does not have it's own graphics card

Last edited by pcfast; 12-15-2013 at 01:26 PM.
Old 12-15-2013, 03:04 PM   #2
LQ 5k Club
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 17 , ChromeOS
Posts: 5,124
Blog Entries: 20

Rep: Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383
Laptop specs would help out in your thread.

~ $ inxi -Fxz
System:    Host: biker Kernel: 3.5.0-17-generic x86_64 (64 bit, gcc: 4.7.2) Desktop: MATE 1.4.2  Distro: Linux Mint 14 Nadia
Machine:   Mobo: SAMSUNG model: RV410/RV510/S3510/E3510 Bios: Phoenix version: 02UC.P026.20100916.LX date: 09/16/2010
CPU:       Dual core Pentium CPU T4500 (-MCP-) cache: 1024 KB flags: (lm nx sse sse2 sse3 ssse3) bmips: 9176.48 
           Clock Speeds: 1: 1200.00 MHz 2: 1200.00 MHz
Graphics:  Card: Intel Mobile 4 Series Integrated Graphics Controller bus-ID: 00:02.0 
           X.Org: 1.13.0 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.0hz 
           GLX Renderer: Mesa DRI Mobile Intel GM45 Express GLX Version: 2.1 Mesa 9.0.3 Direct Rendering: Yes
Audio:     Card: Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 
           Sound: Advanced Linux Sound Architecture ver: 1.0.25
Network:   Card-1: Atheros AR9285 Wireless Network Adapter (PCI-Express) driver: ath9k bus-ID: 06:00.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Marvell 88E8040 PCI-E Fast Ethernet Controller driver: sky2 ver: 1.30 port: 3000 bus-ID: 04:00.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 320.1GB (25.2% used) 1: id: /dev/sda model: SAMSUNG_HM321HI size: 320.1GB 
Partition: ID: / size: 18G used: 4.6G (28%) fs: ext4 ID: /home size: 163G used: 71G (46%) fs: btrfs 
           ID: swap-1 size: 4.19GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 44.0C mobo: 44.0C 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 164 Uptime: 2:33 Memory: 648.3/3887.8MB Runlevel: 2 Gcc sys: 4.7.2 
           Client: Shell (bash 4.2.37) inxi: 1.9.17
Suspend works fine in mine but no major grub changes were made by me

$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="noquiet nosplash"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
Old 12-15-2013, 04:15 PM   #3
Registered: Aug 2012
Posts: 61

Original Poster
Rep: Reputation: Disabled
I had to change the grub file to fix the screen brightness issue apparently.

Let me know if this is good or if I should run a different command in the terminal.

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 42
model name : Intel(R) Core(TM) i5-2435M CPU @ 2.40GHz
stepping : 7
microcode : 0x23
cpu MHz : 800.000
cache size : 3072 KB
physical id : 0
siblings : 4
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips : 4788.94
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 42
model name : Intel(R) Core(TM) i5-2435M CPU @ 2.40GHz
stepping : 7
microcode : 0x23
cpu MHz : 800.000
cache size : 3072 KB
physical id : 0
siblings : 4
Old 12-16-2013, 04:44 PM   #4
Registered: Aug 2012
Posts: 61

Original Poster
Rep: Reputation: Disabled
Somebody on the Linux Mint forums recommended installing the latest kernel. What do LQ members think?
Old 12-16-2013, 08:01 PM   #5
Registered: Aug 2012
Posts: 74

Rep: Reputation: 12
It's worth a shot, but, more importantly, upgrade grub, your display manager (probably MATE or Cinammon), and mdm (or gdm if you have it).

First off, do a
sudo apt-get update; sudo apt-get upgrade
Old 12-16-2013, 09:08 PM   #6
Registered: Aug 2012
Posts: 61

Original Poster
Rep: Reputation: Disabled
I just ran an update and it did not fix the issue.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Laptop wont hibernate/suspend (dell D430 + Linux mint 15.0 Cinnamon) steak1987 Linux - Laptop and Netbook 33 08-10-2013 01:28 PM
[SOLVED] Laptop - Debian/Gnome won't suspend or hibernate orangesky Linux - Laptop and Netbook 14 03-01-2011 01:26 AM
Laptop Suspend: Broken on Wake Up perlhacker14 Debian 0 06-19-2007 03:13 PM
Dell Laptop LCD won't turn on after suspend Zoombie Linux - Hardware 4 06-24-2006 12:24 AM
my laptop won't wake up buldir Mandriva 7 11-16-2004 07:49 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:00 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration