-   Linux - Newbie (
-   -   Linux (knoppix, ubuntu 8.04) won't boot from CD on new system (

blbainb 01-01-2009 06:53 PM

Linux (knoppix, ubuntu 8.04) won't boot from CD on new system
New system: Asus P6t motherboard, win XP, Intel i7 965 CPU, 6 GB ram, XP Pro installed on 400 GB IDE, 100 GB IDE reserved for linux, 2 1-TB SATA drives (configured as IDE drives: not raid or AHCI) , 2 SATA CDROMs

No problems with XP at all but trying to boot Knoppix 3.8.1 from CD fails with kernel panic: not syncing: VFS: unable to mount root fs on unknown block(1,3). Also complains: Knoppix operating system not found. Tried failsafe, debug, nodma, noudev nofstab nomount noswap options with no change. My impression is that it can't find the ram drive where it tries to install the operating system.
Also, unbuntu 8.04 won't boot from live CD either and won't install (drops to minimal text command line). Probably the same issue but no more information is provided.
I was able to install fedora 9 on 100 GB drive (sda) but it won't boot (I changed boot order and boot loader shows both fedora and xp as options; xp does boot properly from boot loader menu). Maybe I used some partitioning option incorrectly but it did install with no problems on sda. The boot loader doesn't seem to find it during boot and numerous errors appear mentioning sda.
Note: 100 GB drive appears as the 0,0 drive when running partitioning software and was the boot drive from my last system while the 400 GB drive appears as the 0,1 drive. 100 GB drive was completely reformated and partitioned before use.

Never seen this before. Previous system had no problems with any linux distros. Help!

blbainb 01-01-2009 07:20 PM

Note: all drives NTFS except for 100 GB drive
Additional information: all drives are NTFS except for the 100 GB IDE drive reserved for linux. The default partitioning was selected when I installed fedora 9.


syg00 01-01-2009 07:44 PM

So Linux liveCDs can boot - even Hardy if you are getting to a prompt.
Try using current distros - Knoppix 3.8 is over 3 years old.

To see what is happening with Fedora, edit the entry on the grub menu (just hit the "e" key) - hints at the bottom of the screen. Then edit the kernel line - remove the "rhgb quiet" bit at the end, and add "s" (no quotes). Hit enter then "b" for boot. These changes are temporary - just for that boot.
You should see all the messages.

blbainb 01-01-2009 11:53 PM

I guess I wasn't clear. No, no live CD will boot: both that I have (knoppix and ubuntu)fail. I do get a boot prompt for knoppix but then it fails after I hit enter (or any other boot option). Ubuntu shows a menu screen but then if I select either 'run from CD' or 'install' it fails and drops to a minimum command line interface with essentially no functionality. Fedora 9 wasn't a live CD but just an installation disk and doesn't try to do 'live install' like knoppix or ubuntu. My impression is that there's something about the hardware or memory that doesn't allow either to set up the ram disk that (I assume) it needs to generate a virtual boot drive. Correct me if I'm wrong!

I assume the instructions for grub are when the boot loader is active. I'll try that.



blbainb 01-02-2009 12:27 AM

Live CD can't see SATA CD drive
I may have found why the live CDs won't boot (install). I tried a live opensuse (linux format) and it's output during the boot process showed that it couldn't detect the cdrom drive (from which it was running) so it couldn't find the os. Both cdrom drives on my system are SATA (there's only a primary IDE channel as on most new motherboards and both are taken up with HDDs).

Is that the problem? Is there some reason why the SATA cdroms aren't seen by essentially ALL live linux distros? Is there a workaround?



All times are GMT -5. The time now is 03:37 PM.