LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-14-2001, 06:31 PM   #1
tomaz
LQ Newbie
 
Registered: Aug 2001
Distribution: Redhat 7.2
Posts: 15

Rep: Reputation: 0
Talking Linux is great! now what?


I just installed linux Redhat 7.2 in another partition in my HD. I now have Win XP and Redhat. I really like linux, its stable, its got lots of cool stuff, its free, its got a photoshop clone (hehe). The problem is that it is kind of hard to use. And my question is:
"How can I access files from windows while using linux?" well thats all, thanks!
 
Old 11-14-2001, 07:16 PM   #2
tomaz
LQ Newbie
 
Registered: Aug 2001
Distribution: Redhat 7.2
Posts: 15

Original Poster
Rep: Reputation: 0
Question anybody home?!

:smash:
 
Old 11-14-2001, 07:54 PM   #3
isajera
Senior Member
 
Registered: Jun 2001
Posts: 1,635

Rep: Reputation: 45
you should have a directory in your / system - /windows - which mounts the windows partition on your linux virtual fs. if it's not there, then you need to edit your /etc/fstab file - i'm not sure off the top of my head what filesystem xp uses tho...

anyway, you'll need something like this in your fstab file, if it's not already in there:

/dev/hda1 /windows vfat auto,owner,uid=500,umask 022 0 0

if it gives you a "not defined" error, then you need to create the directory by hand. just type

mkdir /windows

as root, and that should do it. i'm guessing on the vfat format tho .
 
Old 11-14-2001, 09:24 PM   #4
tomaz
LQ Newbie
 
Registered: Aug 2001
Distribution: Redhat 7.2
Posts: 15

Original Poster
Rep: Reputation: 0
Question .....right

Sorry about all this but i am a true newbie. Linux has not been running in my machine for more than one day. Anyways, the thing you said did not work. Is there any other way to do this that is not editing <u>/dev/fstab</u>???
 
Old 11-14-2001, 09:27 PM   #5
tomaz
LQ Newbie
 
Registered: Aug 2001
Distribution: Redhat 7.2
Posts: 15

Original Poster
Rep: Reputation: 0
Does it help to say that I have GNOME? (the latest version in redhat 7.2)
 
Old 11-14-2001, 09:42 PM   #6
taz.devil
Senior Member
 
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
If you passed over it during install or wasn't an option, that pretty much is it, but very easy as long as the addition to the fstab is correct. Linux see's your hardrive as hda(usually a) and the partitions within hda are hda1, hda2 etc...First in the root '/' directory do a mkdir "whatever you want to call it to see windows" - the quotes. That will be your "mount point". Change directory to /etc by doing cd /etc then edit the fstab file. Before editing, type cfdisk, you will see all partitions. Make note of the name of the FAT/Windows hda number and quit, fon't write or edit anything. Now type jed fstab (jed is the easiest editor for me). You will see everything that is being mounted at boottime. If you want to add the windows partition, make a new line and start it with /dev/hd(whatever number you noted from cfdisk) hit tab and type the mount point which is /windows or whatever you called the new directory. Tab over again and type vfat (that's the file system type, tab again and type the mount options. Before you add these, go to a new terminal by pressing alt+2, login and type man mount and read up per your situation. Hit alt+1 to get back to your first terminal and add the options. Save the file, reboot and you should be good. I know it sounds a little complicated but it's really not, just go for it. Good luck, let me know if I can be clearer on any points.
 
Old 11-15-2001, 12:18 AM   #7
isajera
Senior Member
 
Registered: Jun 2001
Posts: 1,635

Rep: Reputation: 45
it's /etc/fstab, not /dev/fstab. big difference.
 
Old 11-15-2001, 11:54 AM   #8
WindozBytes
Member
 
Registered: Aug 2001
Location: CT, USA
Distribution: Mandriva 2008
Posts: 105

Rep: Reputation: 15
If cfdisk doesn't work,

http://www.linuxquestions.org/questi...&threadid=8612

you can get the same information from fdisk; as root, type:

fdisk -l
 
Old 11-15-2001, 03:24 PM   #9
tomaz
LQ Newbie
 
Registered: Aug 2001
Distribution: Redhat 7.2
Posts: 15

Original Poster
Rep: Reputation: 0
ok, I already knew how to open files and all and how to access files but you didnt explain the hardest part! I have in /etc/fstab an extra line in the bottom:
/dev/hda1 /windows vfat
... what comes after that?
I read man mount, but I did not understand...
thanks for you help.
 
Old 11-15-2001, 04:57 PM   #10
zhenwu
Member
 
Registered: Jul 2001
Location: Taiwan (ex-Victoria BC)
Distribution: RH 9.0
Posts: 126

Rep: Reputation: 15
I believe what you are looking for is:

mount /windows

which will allow you to view your /windows partition

Then, if you wish to unmount it:

umount /windows
 
Old 11-15-2001, 06:02 PM   #11
tomaz
LQ Newbie
 
Registered: Aug 2001
Distribution: Redhat 7.2
Posts: 15

Original Poster
Rep: Reputation: 0
nope! I need to do the fstab thing first before mounting windows..
 
Old 11-15-2001, 06:26 PM   #12
isajera
Senior Member
 
Registered: Jun 2001
Posts: 1,635

Rep: Reputation: 45
check man fstab - the mount man page won't give you too much info. the line i gave above should be for the automounting at boot for the /windows partition.
 
Old 11-15-2001, 09:20 PM   #13
drthornt
Member
 
Registered: May 2001
Location: Toronto
Distribution: RH 7.2
Posts: 33

Rep: Reputation: 15
ok let's start simple.

let's not worry about /ets/fstab for now, let just see if you can even mount the windows partition.
Try this:
mount /dev/hda1 /windows
what does that give you?
does it spit out an error?
(if no then go take a looksee "cd /windows")
mount might complain about not knowing the fstype.. try:
"mount /dev/hda1 /windows -t vfat"
so now you have mounted the fs manually, how about getting it to come up everytime you boot?
try changing the line in the fstab:
"/dev/hda1 /windows vfat"
to:
"/dev/hda1 /windows vfat defaults 1 2"
next step see if mount can read the entry in the fstab, try:
"mount /windows"
cool? if not then go back and check your (and my) work.
if yes, then reboot and see if the fs was mounted, try:
"df"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux.... is..... GREAT! jasonlambert LinuxQuestions.org Member Intro 3 10-10-2006 02:31 PM
Linux is great... but it's not quite there yet. Skrilla Linux - General 20 06-26-2005 06:35 PM
Linux is just a Great Teacher vharishankar LinuxQuestions.org Member Success Stories 6 09-26-2004 06:54 AM
We all know that Linux is great but... nny0000 Linux - General 4 02-11-2004 10:19 PM
The Great Linux Roadblock Lostman Linux - General 4 11-04-2003 05:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration