LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Linux Drivers (https://www.linuxquestions.org/questions/linux-newbie-8/linux-drivers-261132/)

peaceslp 11-30-2004 09:13 PM

Linux Drivers
 
I have just installed Slackware 10. My problem is that it wont recognize my network card. I opened up the linux kernel with all the modules. I noticed that the module for my nic is there, is there something i need to do to get it to work? If i was reading right I need the lisa? daemon running to connect, and when I tried to set it up it said it couldnt find a card. Any ideas, thanks.

P.S. If you do have any help, im not familiar with linux's command line interface, so please be specific if you could. Thanks

mjrich 11-30-2004 09:17 PM

Which network card (make, model) do you have ?

Cheers,

mj

peaceslp 11-30-2004 09:19 PM

Its a national semiconductor, model DP83815 10-100 mbit

mjrich 11-30-2004 09:29 PM

Yes, it's supported. As far as I can tell, the module it uses is natsemi. So you could always run <grep natsemi /etc/modules> and/or lsmod | grep natsemi and see if it's there.

It may just be a matter of running something along the lines of <ifconfig eth0 up> though.

peaceslp 11-30-2004 09:44 PM

when i ran lsmond | grep natsemi,
natsem 15840 1
crc32 2880 0 [natsemi]

when i ran ifconfig eth0 up
-it didnt show anything?

Thanks for the help so far

Edit: I ran ifconfig eth0, it shown some stuff, didnt know if it would help. Im also assuming since i cant ping a server like yahoo.com and i cant use the browser, i have no access to the internet, thats how im testing the connection.

mjrich 12-01-2004 02:47 PM

After running ifconfig eth0 up, what is the output of running ifconfig (as-is) ?

peaceslp 12-01-2004 04:48 PM

It shows that eth0 is up and running, same with lo ( callback) is running too. Do you need more specifics?
Thanks

mjrich 12-01-2004 05:12 PM

Sounds like it might be a dns name resolution problem. Can you ping individual ip addresses (e.g. 216.239.39.99 www.google.com) ?

In your /etc/resolv.conf you should have your primary and secondary dns ip addresses, e.g.
Code:

nameserver xxx.xxx.xxx.xx
nameserver yyy.yyy.yyy.yy

Cheers,

mj

peaceslp 12-01-2004 05:17 PM

I have tried pinging before, I tried www.yahoo.com, it couldnt find it (no dns lookup-dns error, or something of that nature), and i pinged the callback address to make sure things were working, and they were.

Edit: I looked in /etc/resolv.conf it only had (search example.net) so im assuming i need to change that, and if i do, is there a certain format?
Thanks

mjrich 12-01-2004 05:26 PM

Yes, see previous post, above... :)

peaceslp 12-01-2004 05:33 PM

Umm, I opened that up with Konqueror, and I cant type anything in the resolv.conf file. Do I have to use the konsole to change the dns servers. I can only change the directory to /etc/. I know this may sound stupid, but I really dont know how to get around this os yet. Thanks, for your patience

mjrich 12-01-2004 05:41 PM

The best method is to use the command line, as it's fairly standard across distributions. GUI's are great, but they do differ depending on the flavour of the month :)

Right, hopefully you have the Vim editor installed, so open up a terminal (any one will do) and here goes:
Code:

su
  (enter root password)
cd /etc
vim resolv.conf              (opens the resolv.conf file using Vim)

Now, move the cursor down to the line after the one beginning with "Search" (or the end of it) using the arrow keys, and press "i" to get into "insert" mode. Now type the nameserver keyword and the ip addresses, as per above. When you're finished, press the [ESCAPE] key to return to "control" mode, and then type ":wq" to write the file, and then quit. (Without the speech marks, but including the colon).

Now, try using the network again.

peaceslp 12-01-2004 05:50 PM

Well, I didnt use the konsole, i just ran /etc/resolv.conf with the run command. By the way Im using kde. I opend it up like you said with vim in the konsole and checked to make sure the dns was there, it was. It had "nameserver 192.150.175.93". Thats the only dns server i know of, im on a school network. Would it make a difference if im using a router, I took the dns ip off of my router. There was only one. I tried no luck so far. Do i need to restart?

mjrich 12-01-2004 05:57 PM

Quote:

Originally posted by peaceslp
I looked in /etc/resolv.conf it only had (search example.net) so im assuming i need to change that, and if i do, is there a certain format?
This contradicts
Quote:

checked to make sure the dns was there, it was. It had "nameserver 192.150.175.93".
Do you mean that you *added* the dns ip address to the previously nearly empty file ?

peaceslp 12-01-2004 06:00 PM

Yes, thats the dns I added, I was also wondering, do i have to set up for dhcp. I have a router and my router connects to the school network. So my computer would get the ip assigned from my router, but i didnt know if i needed to do some configurations with that. Sorry not being specific.

Edit: I also tried to connect to my router, it said it couldnt connect to the network with a direct connection from my computer to the router.

mjrich 12-01-2004 06:06 PM

If the output of ifconfig indicated that eth0 was already up, and you can ping individual ip addresses (which I assume from your post #9) then it is almost certainly due to either the dns or gateway not being configured, rather than dhcp.

You may need to set the netmask and gateway ips, i.e.
Code:

ifconfig eth0 ip <ip address> netmask 255.255.255.0
route add default gw <gateway ip>


peaceslp 12-01-2004 06:15 PM

It says host name lookup failure, im assuming its still a problem with the dns.
Edit: and i cant ping any addresses

mjrich 12-01-2004 06:18 PM

Do you mean that you can't ping *numbered* ip addresses (eg. ping 216.239.37.99), or *named* ip addresses, eg. ping yahoo.com ?

Have you added your default gateway, as above ?

peaceslp 12-01-2004 06:23 PM

Ok, I have tried pinging named servers like yahoo.com and it says unknown host; I have also tried pinging my router with the ip address (numbered) and it says the network is unreachable.

Edit: I tried adding the gateway like you had above with my addresses instead, but it said the host could not be looked up, something like that. Thanks again for your persistence

mjrich 12-01-2004 06:33 PM

If you have rebooted, you may need to check that eth0 is still up (use ifconfig, as root). If eth0 is up, the default gateway and netmask are set, and you have an ip address, then I would check, carefully, that you do in fact have the correct nameserver listed in /etc/resolve.conf !

peaceslp 12-01-2004 06:42 PM

This is exactly what i get with ifconfig,

eth0 Link encap:Ethernet HWaddr 00:03:0D:0B:76:56
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Rx Pactkets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX ytes:0 (0.0 b) TX bytes: (0.0 b)
Interrupt: 3 Base address:0x20000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask 255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1


(some more junk) but no ip addresses are listed with ifconfig?

Edit: I was able to assign an ip address to it and ping my router, but i still cant ping yahoo. I tried to change the route agian, but it said host not found.

Edit2: How do you change the gateway?, I was looking under ifconfig --help. I changed the ip like you had above, but i left out ip before the ip address. Maybe im putting things in wrong, not being able to change the gateway.

mjrich 12-01-2004 07:02 PM

You would normally have an additional line, before the one begining with UP, e.g.

addr:<ip address> Bcast:<bcast address> Mask:255.255.255.0

However this may just be due to distro differences (try ifconfig -a to be sure). Otherwise, you'll probably have to run dhclient to set the ip dynamically. Just a thought, but there is often a gui to set this automatically - you may want to have a poke around to check for something along the lines of Network Card Config on your menu. And yes, I know I derided Gui's earlier on :)

EDIT: If you can ping your router, then try pinging the ip address (as the number) of, say google. If that's successful, then your dns entries are pretty likely to be wrong (or temporarily down).

mjrich 12-01-2004 07:07 PM

From post #16 above...

# route add default gw <gateway ip>

peaceslp 12-01-2004 07:11 PM

i tried that, it didnt work. I figured if i could ping my router i must have part of it right, i just need to tell it to use my router as a gateway. The default ip for my router is 192.168.1.1, thats the one i use as a gateway right, or do i use the ip assigned by the school dhcp server to the router?

mjrich 12-01-2004 07:19 PM

What do you mean by 'it didn't work' ? Error messages ? Clouds of smoke ?

The ip of your router is the one you should use as your gateway. So,

# route add default gw 192.168.1.1

peaceslp 12-01-2004 07:25 PM

Umm, Well i got it to work (you did), i was putting # ifconfig route add default 192.168.1.1 in instead of the other way. Thats awsome! My next project is to get my wireless card to work next. I have already tried ndiswrapper, but i wont bother you with that right now. Thanks for the help, it was greatly appreciated.

mjrich 12-01-2004 07:26 PM

No worries - glad to be of help :)

Cheers,

mj


All times are GMT -5. The time now is 10:36 PM.