LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Linux Drivers (https://www.linuxquestions.org/questions/linux-newbie-8/linux-drivers-261132/)

peaceslp 11-30-2004 10:13 PM

Linux Drivers
 
I have just installed Slackware 10. My problem is that it wont recognize my network card. I opened up the linux kernel with all the modules. I noticed that the module for my nic is there, is there something i need to do to get it to work? If i was reading right I need the lisa? daemon running to connect, and when I tried to set it up it said it couldnt find a card. Any ideas, thanks.

P.S. If you do have any help, im not familiar with linux's command line interface, so please be specific if you could. Thanks

mjrich 11-30-2004 10:17 PM

Which network card (make, model) do you have ?

Cheers,

mj

peaceslp 11-30-2004 10:19 PM

Its a national semiconductor, model DP83815 10-100 mbit

mjrich 11-30-2004 10:29 PM

Yes, it's supported. As far as I can tell, the module it uses is natsemi. So you could always run <grep natsemi /etc/modules> and/or lsmod | grep natsemi and see if it's there.

It may just be a matter of running something along the lines of <ifconfig eth0 up> though.

peaceslp 11-30-2004 10:44 PM

when i ran lsmond | grep natsemi,
natsem 15840 1
crc32 2880 0 [natsemi]

when i ran ifconfig eth0 up
-it didnt show anything?

Thanks for the help so far

Edit: I ran ifconfig eth0, it shown some stuff, didnt know if it would help. Im also assuming since i cant ping a server like yahoo.com and i cant use the browser, i have no access to the internet, thats how im testing the connection.

mjrich 12-01-2004 03:47 PM

After running ifconfig eth0 up, what is the output of running ifconfig (as-is) ?

peaceslp 12-01-2004 05:48 PM

It shows that eth0 is up and running, same with lo ( callback) is running too. Do you need more specifics?
Thanks

mjrich 12-01-2004 06:12 PM

Sounds like it might be a dns name resolution problem. Can you ping individual ip addresses (e.g. 216.239.39.99 www.google.com) ?

In your /etc/resolv.conf you should have your primary and secondary dns ip addresses, e.g.
Code:

nameserver xxx.xxx.xxx.xx
nameserver yyy.yyy.yyy.yy

Cheers,

mj

peaceslp 12-01-2004 06:17 PM

I have tried pinging before, I tried www.yahoo.com, it couldnt find it (no dns lookup-dns error, or something of that nature), and i pinged the callback address to make sure things were working, and they were.

Edit: I looked in /etc/resolv.conf it only had (search example.net) so im assuming i need to change that, and if i do, is there a certain format?
Thanks

mjrich 12-01-2004 06:26 PM

Yes, see previous post, above... :)

peaceslp 12-01-2004 06:33 PM

Umm, I opened that up with Konqueror, and I cant type anything in the resolv.conf file. Do I have to use the konsole to change the dns servers. I can only change the directory to /etc/. I know this may sound stupid, but I really dont know how to get around this os yet. Thanks, for your patience

mjrich 12-01-2004 06:41 PM

The best method is to use the command line, as it's fairly standard across distributions. GUI's are great, but they do differ depending on the flavour of the month :)

Right, hopefully you have the Vim editor installed, so open up a terminal (any one will do) and here goes:
Code:

su
  (enter root password)
cd /etc
vim resolv.conf              (opens the resolv.conf file using Vim)

Now, move the cursor down to the line after the one beginning with "Search" (or the end of it) using the arrow keys, and press "i" to get into "insert" mode. Now type the nameserver keyword and the ip addresses, as per above. When you're finished, press the [ESCAPE] key to return to "control" mode, and then type ":wq" to write the file, and then quit. (Without the speech marks, but including the colon).

Now, try using the network again.

peaceslp 12-01-2004 06:50 PM

Well, I didnt use the konsole, i just ran /etc/resolv.conf with the run command. By the way Im using kde. I opend it up like you said with vim in the konsole and checked to make sure the dns was there, it was. It had "nameserver 192.150.175.93". Thats the only dns server i know of, im on a school network. Would it make a difference if im using a router, I took the dns ip off of my router. There was only one. I tried no luck so far. Do i need to restart?

mjrich 12-01-2004 06:57 PM

Quote:

Originally posted by peaceslp
I looked in /etc/resolv.conf it only had (search example.net) so im assuming i need to change that, and if i do, is there a certain format?
This contradicts
Quote:

checked to make sure the dns was there, it was. It had "nameserver 192.150.175.93".
Do you mean that you *added* the dns ip address to the previously nearly empty file ?

peaceslp 12-01-2004 07:00 PM

Yes, thats the dns I added, I was also wondering, do i have to set up for dhcp. I have a router and my router connects to the school network. So my computer would get the ip assigned from my router, but i didnt know if i needed to do some configurations with that. Sorry not being specific.

Edit: I also tried to connect to my router, it said it couldnt connect to the network with a direct connection from my computer to the router.


All times are GMT -5. The time now is 01:17 AM.