-   Linux - Newbie (
-   -   Linux (CentOS) and Atheros Wireless Driver (

nentendo 08-20-2006 12:55 AM

Linux (CentOS) and Atheros Wireless Driver
HI all friend

i am really new in this feild but i already install the CentOS and now the matter of installing Atheros Wireless Drive but really i dont have any clue at all how to install. where to get this drive but some satying about if you install .rpm you dont have to do any thing so i really dont know any thing. Is ther any way any of my friend tell me the command and trick and procedure and if they have any software whcih help me to install that driver that would be really really great.

thanks in Advance

dangerboy 08-20-2006 02:20 AM

For the best results, I recommend getting MadWifi and installing the latest version of the Atheros drivers.

Go here and download the appropriate RPM for your distribution.

The command should be something like:

rpm -i name-of-package.rpm

_UnPrEdictAbLe_ 08-20-2006 02:23 AM


Atheros chipset is supported by madwifi driver. You can get the drivers for "FEDORA CORE" at I guess the RPM for Fedora wont work on your OS. You can anyway download the tarball and compile.

Anyways, just to recheck,

[anurag@localhost ~]$ /sbin/lspci -vv
01:00.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
        Subsystem: Global Sun Technology Inc Trust Speedshare Turbo Pro Wireless PCI Adapter
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 168 (2500ns min, 7000ns max), Cache Line Size 10
        Interrupt: pin A routed to IRQ 185
        Region 0: Memory at ff900000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>

The madwifi driver works perfectly for my device. Do come back if you have doubts.

nentendo 08-27-2006 02:10 AM

hi friend

i tried to install from dangerboy link but seem like didnt work becuae it ask me so many Kernel packages missing. i really need step by step guide from one of my friend

i really appriciate about this link it should work but seem like i am either missing somethign or doing somethign wrong.

please advice.


dangerboy 08-27-2006 02:15 AM

Can you post the exact error you are getting when you try to install?

nentendo 08-27-2006 11:11 AM


when i am trying to use this
it saying that youa re missing

than i cant find this one and then trying to install lower version of this file it saying you are missing some lib files.

please advice.


btmiller 08-27-2006 11:33 AM

I suggest you use yum to solve the dependencies for you. There are isntructions for adding the yum repository with the MadWifi drivers at the MadWifi site. If you want to download directly from ATRPMs all of the packages for CentOS 4 are available on this page. If you are unable to get these installed please post the exact error messages you see.

nentendo 08-27-2006 12:45 PM

hi there

this error i am getting when i am tring to install

on windows it saying that

unlocatable package Required by ('madwifi','0.9.2',''

that do i have to do.


btmiller 08-27-2006 12:48 PM

Get the correct madwifi-kmdl package from the site I gave you the link to above. Then install it with the madwifi package, e.g.

rpm -ivh madwifi*.rpm

nentendo 08-27-2006 01:03 PM

now when i am trying to install

from your link i am getting theses error

Unlocatable packeges

dangerboy 08-27-2006 02:28 PM

I'm not quite sure about your output there. Did you copy and paste the output from your console into your web browser?

You can try quoting the package name:


rpm -i "/path/of/package/"
Make sure you specify what directory the package is located in (/path/of/package could be /home/nentendo/Desktop for example).

If you continue to get errors copy and paste the error (including the command) and reply to this post. Good luck.

nentendo 08-27-2006 03:29 PM

ok this time when i run this line on my terminal windows i am getting this message make sure i am login in as a root

warning: /root/Desktop/ rpm: V3 DSA signature: NOKEY, key ID 66534c2b
error: Failed dependencies:
/boot/vmlinuz-2.6.9-42.ELhugemem is needed by madwifi-hal-kmdl-2.6.9-42.
madwifi-kmdl-2.6.9-42.ELhugemem = is needed by madwifi

dangerboy 08-27-2006 03:57 PM

Okie dokie, that helps immensely.

That package appears to be compiled against the 2.6.9-42 kernel with hal support.

Since CentOS, AFAIK, is based on Redhat, I would recommend installing a Fedora Core 3 package instead.

Go here:

And get this package:

Try installing that and see what kind of results you get. I recommend Fedora Core 3 packages because you might not have the latest glibc libraries that FC5 apparently has builtin. But that's another topic. Let me know how this works. :)

This is pretty much what unpredictable suggested.

nentendo 08-27-2006 04:12 PM

this time when i used

i got this
rpm -i "/root/Desktop/"
warning: /root/Desktop/ V3 DSA signature: NOKEY , key ID 66534c2b
error: Failed dependencies: is needed by

any suggestion

dangerboy 08-27-2006 04:14 PM

Ok. What's your kernel version?


'uname -r'

without quotes.

All times are GMT -5. The time now is 10:05 AM.