LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-17-2011, 02:48 PM   #1
jeckels
LQ Newbie
 
Registered: Mar 2011
Posts: 2

Rep: Reputation: 0
Linux and FTP


I am running windows 7 and using FileZilla as client FTP software to upload/download files to and from a Linux server. I have tried every option within FileZilla to get ASCII files to upload and automatically strip off the carriage return from the end of each line. ASCII mode file transfer is SUPPOSED to do this for me.

Even though the message log says the transfer is in ASCII mode, I still end up with cntl-M characters (carriage returns) at the end of each line.

The developers of FileZilla have told me that there is a FTP setting on the server that will allow/handle this ASCII mode conversion.

Does anyone know of such a setting? Thanks in advance.

Jonathan Eckels
je186005@teradata.com
 
Old 03-17-2011, 02:51 PM   #2
lrtward
Member
 
Registered: Feb 2011
Distribution: CentOS, Ubuntu
Posts: 97

Rep: Reputation: 9
What FTP daemon are you running on your server?
Like, vsftpd or something else?
 
1 members found this post helpful.
Old 03-17-2011, 03:44 PM   #3
SL00b
Member
 
Registered: Feb 2011
Location: LA, US
Distribution: SLES
Posts: 375

Rep: Reputation: 112Reputation: 112
When you FTP in ASCII mode, the client and the server both have to be set to the correct code page for translation to happen successfully.

I don't know which server you're using, but I found this bit of info in vsftp.conf to be interesting:

Code:
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
#
#ascii_upload_enable=YES
#ascii_download_enable=YES
 
1 members found this post helpful.
Old 03-25-2011, 06:46 AM   #4
jeckels
LQ Newbie
 
Registered: Mar 2011
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks for your help. The settings of "#ascii_upload_enable=YES" "#ascii_download_enable=YES" did the trick.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Automate FTP / Scripting FTP Transfers files from linux to windows m/c ashishshukla Programming 5 05-26-2016 09:10 AM
when I use ftp://user@ftp.blah.com it works. But when I type just ftp.blah.com says.. hunterhunter Linux - General 15 03-05-2014 09:12 AM
About Slackware 9.1 boot disk?? ftp://ftp.kpn.be/pub/linux/slackware/slackware-9.1-is AL3OMDAH Slackware 4 04-18-2007 09:54 AM
ftp from LInux to Serv-U ftp server problem csross Linux - General 2 11-07-2005 04:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration