-   Linux - Newbie (
-   -   Linpus Lite - Change File/Folder Permissions (

osaddict 08-19-2010 06:17 AM

Linpus Lite - Change File/Folder Permissions
I own an Acer Aspire One which has Linpus Lite installed. Last night I attempted to delete a couple of files only to find they are read only and that I cannot change the permissions by right clicking and changing the drop down menu from read only.

These aren't protected files or anything, they are files I've downloaded or created myself (one using the onboard web cam to test it).

I attempted to play with Terminal for a bit but as a newbie I got easily lost, not like I can fall back on command prompt knowledge from Windows!

I think it's somehow connected with the user which accesses these docs or tries to change the permissions. I also tried with an su- which meant I was using Terminal as root, however, I wasn't sure how I could then set the permissions for a particular file/folder within the file system.

Thanks in advance!

yancek 08-19-2010 10:17 AM

You can see the permissions with ls -l command. This command will show permissions for user, group and other as well as who the user/owner is and which group has what access. You can remove files from the command line with the rm -i command (the i will prompt to ask if you want to remove). Need to be careful with this because when removed, it is removed and no going back.

I would suggest you do a google search for linux commands or more specifically the rm (remove) and chmod (for changing permissions) chown (change ownership) and chgrp (change group). There are many sites with detailed information available.

osaddict 08-19-2010 10:40 AM

Thanks for the reply.

I was in a specific folder and opened Terminal, from here I attempted to change these permissions using chmod, however, this didn't work. I suspect this is because Terminal was not logged on as root.

When I used su- to run as root (I guess like Elevated command prompt in Vista/Win7) I think it would have worked but I'm not sure how I could navigate to the same directory I was in - When I tried the same commands it didn't recognise the filename.

How do I go about moving around in Terminal? - i.e. cd\ cd directory name etc in cmd prompt?


RockDoctor 08-19-2010 04:40 PM

Quick guide to get you started:

cd <directory name> moves you to directory <directory name>

cd ~ moves you to the current user's home directory

PS1="\w$ " changes the prompt to the full path name of the current directory followed by a dollar sign followed by a space. Very useful for figuring out where you are in the filesystem.

sudo <command> execute <command> as the root user (doesn't change your location)

osaddict 08-20-2010 01:27 AM

I think the file system may be the issue here.


[root@localhost Videos]# chmod a+w video_0000.mpg
chmod: changing permissions of `video_0000.mpg': Read-only file system

so i tried

[root@localhost Videos]# cat /proc/mounts
which produced a few lines, critically (i think) this one:

/dev/mmcblk0p1 /media/disk vfat ro,nosuid,nodev,uid=500,fmask=0022,dmask=0022,codepage=cp437,iocharset=iso8859-1,shortname=winnt,utf8 0 0
The ro after the vfat suggests to me it's a read only file system so even changing properties as root to write will fail.

I tried this, but i think it's incomplete as i got sort of help file text:

[root@localhost Videos]# mount -o remount,rw/
any help please guys?! I think I'm making slow progress lol


konsolebox 08-20-2010 01:50 AM


Originally Posted by osaddict (Post 4072012)

[root@localhost Videos]# mount -o remount,rw/

You should specify / as separate argument.

mount -o remount,rw /
Edit: It should not be the root filesystem.

mount -o remount,rw /media/disk

osaddict 09-01-2010 08:51 AM

Thanls konsolebox, I've yet to try this. Hopefully this evening when I get home :)

osaddict 09-01-2010 02:36 PM

I went to the videos directory, opened terminal...


then I entered my password.

I tried:

mount -o remount, rw /media/disk
all on the one line. It didn't complain. I went to my directory and tried to change the permissions of a file within. It didn't allow me. Back in terminal:


chmod a+w video_0000.mpg
When still logged in as root. This produced the same error as before:


chmod: changing permissions of `video_0000.mpg': Read-only file system
Starting to get annoying - logically it should work. I must be missing something. Any clues anyone?


konsolebox 09-02-2010 01:12 AM

Have you tried the disk on other systems?.. Like just know if it's still capable of writing data. Maybe it's the drive that already has the problem. Btw the filesystem in the drive is not NTFS right?

Kenny_Strawn 09-02-2010 01:23 AM

As I have said many times, Linpus Lite is a crippleware distro. Comparing it to something more complete like Fedora, Ubuntu or Mint is like comparing Windows 7 Starter to Windows 7 Ultimate!

You don't get the full effect of Linux with Linpus, I'm sorry. There's no display manager, so there's no way of logging out and in again as root. Acer's application launcher is burned into the desktop, which means there's no option to change the wallpaper (Well, doesn't that sound familiar!). The package manager is hidden: you literally have to type "sudo system-config-packages" in a terminal window. And even if you attempt to use it to change the DE, you get enough errors resolving dependencies that it doesn't really matter.

osaddict 09-02-2010 02:38 PM

I got that impression Kenny. I'm in no way attached to it what so ever! - How would I go about installing a new, better, more supported distribution? - I do have a portable CD drive which works with this laptop - would I be able to try a 'live cd' of a distro?

osaddict 09-02-2010 02:48 PM

This: for example looks ideal - a decent distro and intended for netbooks.

I'm aware of how I'd do this on a windows PC - boot from cd, Win GUI gives you the option of where to install, how to format the existing hdd, etc. Is this the same with this Ubuntu Netbook Remix?

I'm fully aware of the need to backup documents/media etc - that's not a major headache.

Kenny_Strawn 09-02-2010 04:32 PM


Originally Posted by osaddict (Post 4086311)
I got that impression Kenny. I'm in no way attached to it what so ever! - How would I go about installing a new, better, more supported distribution? - I do have a portable CD drive which works with this laptop - would I be able to try a 'live cd' of a distro?

Do you also have a USB flash drive you can use?

osaddict 09-03-2010 01:08 AM

I do but pen drives often seem to be the problem (only root can mount etc.)

However, I burnt Ubuntu netbook remix to a cd and gave it a try last night. I liked it :)

1. Is that a suitable distro? (I thought it sounded ideal!)
2. If I had backed up my docs is it a straight forward click n go gui install? - disposing of linpus :)?
3. I assume installing stuff like VLC etc is a doddle and done in a similar way to linpus? - some kind of package manager where you add/remove bits etc?

Cheers :D

Kenny_Strawn 09-03-2010 03:14 AM

When you start the installation and get to the partitioning stage, select "Edit partitions manually (advanced)" or the like. The partitioner will launch. Select the partition you had Linpus on (will register as Fedora 8), and for the file system, select the same as it was and DO NOT FORMAT!!! Ubuntu will give you a warning but will still allow you to continue. Create your user, and after that, the installation will prompt you with checkboxes to migrate documents and settings from existing user accounts (such as the one Linpus created). Check the boxes, and then select "Next". Ubuntu will now install and, on top of that, migrate your docs and settings over to the new installation.

All times are GMT -5. The time now is 10:54 AM.