LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   linksys wmp54g wireless card + ubuntu 7.04 (https://www.linuxquestions.org/questions/linux-newbie-8/linksys-wmp54g-wireless-card-ubuntu-7-04-a-548384/)

neocorps 04-23-2007 04:19 PM

linksys wmp54g wireless card + ubuntu 7.04
 
hi, im completely new to linux, i've just installed ubuntu 7.04, and im having problems with my linksys wmp54g wireless card, i've seen other threads, but i just dont understand, i've decided to post this thread.

i've heard about ndiswrapper, i've just installed it, but i just dont know how to use it, and i have not found any drivers for my wireless card, can anyone help?

i've configured my wireless connection in network settings.

I selected wireless connection > properties > i unchecked "enable roaming mode" and i selected the Network name ( it seemed to be working because i could select my actual network name called Home ), y typed the network password wich is a hexadecimal wep key, and pressed OK, but i could not get to internet.

Can anyone help with this?

thanx anyway!

caddymob 05-03-2007 02:27 PM

Me too!
 
I tried the previous version of Ubuntu (Dapper Drake) and could not for the life of me get my Linksys WMP54G to work. I went through ~10 differnt work arounds seen on various forums all to no avail. After that much rebooting to windows and then back to Linux, I had had enough!

Any, I just checked the wifi docs on Ubuntu's page and see for this card the last update was 2005-10-17. So then, anyone got this card working and have a solution that works?

Thanks!
:newbie:

neocorps 05-04-2007 10:17 AM

i've fixed the problem thanx
 
Hey caddymob,

i've fixed the problem, turns out that feisty fawn(ubuntu 7.04), has great compatibility with many wireless network cards, what i did was:

selected wireless connection > properties > i unchecked "enable roaming mode" and i selected the Network name ( it seemed to be working because i could select my actual network name called Home ), y typed the network password wich is a hexadecimal wep key, and pressed OK, but i could not get to internet.

i thought i had a problem with drivers, but after i restarted ubuntu, guess what?, it worked perfectly!.. so if you have Dapper Drake, i recommend upgrading to feisty fawn!

hope this works for you!

sctech29169 05-23-2007 04:34 PM

Re Wmp54gs V1.1
 
I am using Fiesty Fawn and it still will not autodetect this card. I contacted Lynksys TS and they state that the ONLY card they have that is linux compatable is the WUSB11 V2.5.

Anyway, does Fiesty Fawn support WPA2? I looked and only saw WEP encryption :cry:

Help.

Rodney

clinto 05-24-2007 02:23 PM

Okay, I've been reading all over the place and what I could understand didn't help me that much.

Here's my dilema: I'm working on my parents' pc. They had XP Professional installed, but it just went haywire yesterday(imagine that!). I'm not sure what triggered all simultaneous critical errors, but I'm not really worried about it neither. I wiped off their hard drive and used Gparted to prepare for an Ubuntu Feisty install. This is their partition table on a 40gb:

hda1 | 10gb for a future reinstallation of XP
hda2 | 15gb | ext3 | /home (which they will be able to access with Windows as well)
hda3 | 11gb | extended
hda5 | 10gb | ext3 | / Ubuntu Feisty
hda6 | 100mb | ext | /boot
hda7 | 1gb | linux-swap

I've installed Ubuntu and everything is beautiful. The only problem is internet access. I'd installed the Linksys WMP54G v4 before Windows went capoot. Ubuntu picks up my home network, but I can't get it to connect to it.

From what I've gathered from this chart, it's detected as ra0 and I need to enter my router's information.

When I use iwconfig, it tells me indeed I'm using ra0, that my router is RT2500, my home network is listed in the ESSID, I have a link and my quality is good. But I'm unable to access the internet.

Earlier, I couldn't even draw a link to my home network. I'm not sure what changed, for I've been trying all sorts of things. I'd downloaded a driver, referred [url=http://ubuntuforums.org/showthread.php?t=241565&highlight=WMP54G]here[url], I'd unpacked it and used make.

I'm not using any kind of security, since there's not really anyone living around here to mess with it. I didn't want to make things any more difficult. However, I probably should learn how to use different security features. I didn't use the manual settings in Ubuntu's Network Settings, I'd left it on Enable roaming mode.

*edit*I checked the connection information and it doesn't list the ip address, subnet, dns, nothing except the interface, speed, driver and hardware address.*edit*
Do I have to disable the roaming mode and enter the wireless settings manually? Is this my problem or am I missing something else?

decartes 08-08-2007 08:06 AM

Wireless PCMCIA CARD CONFIG ON FIESTI
 
Quote:

Originally Posted by clinto
Okay, I've been reading all over the place and what I could understand didn't help me that much.

Here's my dilema: I'm working on my parents' pc. They had XP Professional installed, but it just went haywire yesterday(imagine that!). I'm not sure what triggered all simultaneous critical errors, but I'm not really worried about it neither. I wiped off their hard drive and used Gparted to prepare for an Ubuntu Feisty install. This is their partition table on a 40gb:

hda1 | 10gb for a future reinstallation of XP
hda2 | 15gb | ext3 | /home (which they will be able to access with Windows as well)
hda3 | 11gb | extended
hda5 | 10gb | ext3 | / Ubuntu Feisty
hda6 | 100mb | ext | /boot
hda7 | 1gb | linux-swap

I've installed Ubuntu and everything is beautiful. The only problem is internet access. I'd installed the Linksys WMP54G v4 before Windows went capoot. Ubuntu picks up my home network, but I can't get it to connect to it.

From what I've gathered from this chart, it's detected as ra0 and I need to enter my router's information.

When I use iwconfig, it tells me indeed I'm using ra0, that my router is RT2500, my home network is listed in the ESSID, I have a link and my quality is good. But I'm unable to access the internet.

Earlier, I couldn't even draw a link to my home network. I'm not sure what changed, for I've been trying all sorts of things. I'd downloaded a driver, referred [url=http://ubuntuforums.org/showthread.php?t=241565&highlight=WMP54G]here[url], I'd unpacked it and used make.

I'm not using any kind of security, since there's not really anyone living around here to mess with it. I didn't want to make things any more difficult. However, I probably should learn how to use different security features. I didn't use the manual settings in Ubuntu's Network Settings, I'd left it on Enable roaming mode.

*edit*I checked the connection information and it doesn't list the ip address, subnet, dns, nothing except the interface, speed, driver and hardware address.*edit*
Do I have to disable the roaming mode and enter the wireless settings manually? Is this my problem or am I missing something else?


OK heres how to fix it if your card uses the rt2500 chipset (not ndiswrapper)

1. Dont even think about using WEP encryption on Linux without a windows driver
2. Completely remove network-manager as in most cases it wont work
3. Install package wifi-radar
4. Open a shell and type sudo bash
5. Create a file called /etc/wifi-radar.conf and paste the following into it
--
[DEFAULT]
scan_timeout = 5
auto_profile_order = your-ssid,ssid
speak_up = False
ifup_required = False
interface = ra0
commit_required = False

[your-ssid]
prescript =
use_wpa = no
postscript =
mode = auto
key =
use_dhcp = yes
security =
channel = auto
--

Now execute the following shell commands:

ifconfig ra0 down
ifconfig ra0 up
wifi-radar


That's it, your card is now working and will auto detect all wireless networks. On the wifi-radar window simply click connect and it should work with the default setup.

If you experience very slow connectivity (ie 5kps instead of 200kps - guaranteed if you use a Belkin PCMCIA card) it is probably a card issue, you could try redoing it with ndiswrapper but I'd advise buying a new card that is known to work on Linux, go to www.linuxemporium.co.uk, you'll get a quality card for under 20.00.


Hope this helps:study:

clinto 08-09-2007 10:33 PM

Thank you decartes. That's a very detailed reply.

I apologize for not posting the solution I'd found. Ubuntu said that it supported the nic I was using, but it... well, didn't. I had to uninstall the network manager like you said and I installed a program called wicd. Worked like a charm.

I had bought a Gigabyte GN-WP01GS PCI Wireless adapter for my new computer which I haven't tested yet, but it should be compatible. It was only just over $20. I got an Asus WL-107G card for my laptop which works fine with the distros I've used. A buddy of mine uses the same card and said he had slight difficulty setting his up with Slackware. But Ubuntu/Xubuntu recognized it with no problems. This card only cost about $20 as well on newegg.com.

pyush 01-14-2008 02:47 AM

Quote:

Originally Posted by caddymob (Post 2735138)
I tried the previous version of Ubuntu (Dapper Drake) and could not for the life of me get my Linksys WMP54G to work. I went through ~10 differnt work arounds seen on various forums all to no avail. After that much rebooting to windows and then back to Linux, I had had enough!

Any, I just checked the wifi docs on Ubuntu's page and see for this card the last update was 2005-10-17. So then, anyone got this card working and have a solution that works?

Thanks!
:newbie:

its very strange, when i 1st time installed ubuntu 7.1 2 weeks ago,i was
surprised my linksys card auto decected by ubuntu and i just set the network name and password, and my internet was started in 1 minute, and today i installed ubuntu again on my xp disk(now duel boot) i am surprise again ubunto did not detecting my same linksys card.I can only connect through lane, but not through wireless card. strange, can any1 help me how to fix this issue.
thanx


All times are GMT -5. The time now is 02:55 PM.