LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-28-2003, 02:10 PM   #1
LinuxBAH
Member
 
Registered: Jun 2003
Distribution: FreeBSD
Posts: 119

Rep: Reputation: 15
Linking /mnt/win_d to my desktop for easy access


Subject line explains it all, how would I go about doing this though?
 
Old 06-28-2003, 04:32 PM   #2
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
You don't specify whether you're using GNOME or KDE...

This will work for GNOME...

Change to your home directory, and then go into the .gnome-desktop
Then create a symbolic link to the mount directory.

As an example, if you wanted a link to /mnt/win_d, you would type something like this:

ln -s /mnt/win_d win_d

You should see a folder appear on the desktop with a green arrow indicating it is a link. Then you should be able to open it like normal.
 
Old 06-28-2003, 07:32 PM   #3
thefallen
LQ Newbie
 
Registered: Jun 2003
Distribution: Gentoo, Debian
Posts: 15

Rep: Reputation: 0
Edit the fstab from /etc/fstab, where it should be something like

dev/hdXN vfat defaults 0 0

, (where X could be a,b,c,etc and N=1,2,3,4,5,6, etc) depends on partition and hard-drive (although being win_d most probably it is hda5 or hda6), X and N points to the partition and the hard-disk.
you should modify it this way:

dev/hdXN vfat auto,users,rw,suid,exec,umask=7000 0 0

(X and N should remain what they originally were)

the umask=7000 makes all files in the partition writable, readable and executable for all users/groups.

After reboot there should appear a nice icon of a hard drive on the desktop, and not on your user account only (as it would linking it), but for every user.
(Actually depends on what linux distribution and version you have, but most do this).
 
Old 06-28-2003, 11:09 PM   #4
LinuxBAH
Member
 
Registered: Jun 2003
Distribution: FreeBSD
Posts: 119

Original Poster
Rep: Reputation: 15
Ok cool. Kinda a multiple learning experience for me there. I didn't know different wm's vary in how these things are done. I thought a wm is just basically the amount of configurational ability you have and everything else was global, on a lower level like the kernel. Whereas, the same commands are used. Or did I take what you said out of context?

"You don't specify whether you're using GNOME or KDE..." ??

Anyways, thanx for the quick responses guys, I'm gonna mess around with what you had suggest just to see how it works. And be happy and lazy with my new founded shortcut.
 
Old 06-28-2003, 11:20 PM   #5
LinuxBAH
Member
 
Registered: Jun 2003
Distribution: FreeBSD
Posts: 119

Original Poster
Rep: Reputation: 15
Well I did the ln command idea first. It worked but it creates another directory called win_d within the win_d on my dsektop and within THAT directory are the contents of the partition. How would I remove the useless directory so that the contents of the partition are directly placed within the directory on the desktop?>
 
Old 06-28-2003, 11:25 PM   #6
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
well the way i do is just create a shortcut like you would any other shortcut, simple as that
i know in gnome which i use, it is as easy as right clicking the desktop select new launcher and specify /mnt/win_d and make it type "link" in the drop down list....
in kde when you right click the desktop it says something like link to application rather than new launcher...
 
Old 06-28-2003, 11:44 PM   #7
LinuxBAH
Member
 
Registered: Jun 2003
Distribution: FreeBSD
Posts: 119

Original Poster
Rep: Reputation: 15
Too sweet. Ok thanx Dr0zz that is exactly how I want it.
 
Old 06-28-2003, 11:45 PM   #8
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
no problem d00d!
 
Old 06-29-2003, 12:57 AM   #9
LinuxBAH
Member
 
Registered: Jun 2003
Distribution: FreeBSD
Posts: 119

Original Poster
Rep: Reputation: 15
Hrm... I tried editing the /etc/fstab file and used
/dev/hda5 /mnt/win_d vfat user, rw, exec, uid=500 0 0

to auto mount win_d but when rebooting AND on booting it says bad fstab line 6.. line 6 is this line, the line I just added. What's wrong with it?
 
Old 06-29-2003, 01:01 AM   #10
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
the only thing i can suggest from looking at that is the spaces you have between --> user, rw, exec, uid=500, unless hda5 is wrong if its not get rid of the spaces ( user,rw,exec,uid=500)
 
Old 06-29-2003, 01:30 AM   #11
LinuxBAH
Member
 
Registered: Jun 2003
Distribution: FreeBSD
Posts: 119

Original Poster
Rep: Reputation: 15
On the money! Woohoo..
 
Old 07-05-2003, 07:10 AM   #12
thefallen
LQ Newbie
 
Registered: Jun 2003
Distribution: Gentoo, Debian
Posts: 15

Rep: Reputation: 0
"/dev/hda5 /mnt/win_d vfat user, rw, exec, uid=500 0 0"
What's wrong is that vfat doesn't have uid, you have to use umask=XXXX, where XXXX are the bits you don't want to be enabled (it kinda is the !XXXX (not XXXX) in C++) so if you want 500 you probably would write emm... 5 = 101 => 010 = 2 => umask=277) anyway as far as I can remember without looking to some documentation umask has 4 digits that's why i put umask=7000 (write/execute/read) for every user. Secondly you should check the spaces between the comma separated arguments (user,rw,exec,umask=7000)
just try instead

"/dev/hda5 /mnt/win_d vfat user,rw,exec,suid,umask=7000 0 0"
and see what happens, than experiment with the 7000 thing.
Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot create directory `/mnt/win_d/MP3': Read-only file system PapaJac Mandriva 11 03-04-2004 06:25 AM
cannot create directory `/mnt/win_d/MP3': Read-only file system PapaJac Mandriva 0 03-02-2004 05:09 PM
easy linking question bosewicht Linux - Newbie 1 12-17-2003 03:52 PM
Can't access /mnt can access subdirectories pboggio Mandriva 7 10-05-2003 08:58 AM
easy question - umount /mnt/cdrom ? 360 Linux - General 2 11-27-2001 03:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration