LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-13-2002, 01:30 AM   #1
Zachary
LQ Newbie
 
Registered: Aug 2002
Location: Toronto, Canada
Distribution: Redhat 7.3
Posts: 17

Rep: Reputation: 0
LILO not allowing me to boot into XP


Hi,

This is my first post here, but i'm hopeful one of you guys (and gals) will be able to help me out:

I have a system with XP Pro installed. XP is the main partition with others holding my games, etc (all NTFS though)

I used partition magic to create a primary partition (ext2) for a Linux install after my main partition for XP and before my other partitions (so it is the second partition), also created a logical partition for the swap file (ext2), and then made the primary linux partition active.

I used the RedHat 7.3 CDs and installed it. I picked LILO and told it to load from the boot sector of the partition with Redhat (i'm pretty sure of that)

It installed without any problems, but when it rebooted, it did not prompt me with the choice of booting to Windows XP, just Linux

What do I do to have LILO give me the option of picking Windows (or even having it default choose XP instead of Linux)

here is my system setup:

hda1: ntfs (pretty sure this is the XP partition)
hda3: ext3 (dunno)
hda4: ext3 (dunno)
hda2: extended (dunno)
hda5: ntfs (one of my partitions with games)
hda6: ntfs (one of my partitions with programs)
hda7: linux swap (the linux swap partiton i guess

**this info came from a program i ran in redhat, not sure which one, but it came with the install**

here is my LILO.CONF (in entirety):

prompt
timeout=50
default=linux
boot=/dev/hda3
map=/boot/map
install=/boot/boot.b
message=/boot/message
linear

image=/boot/vmlinuz-2.4.18-3
label=linux
initrd=/boot/initrd-2.4.18-3.img
read-only
root=/dev/hda4
append="hdc=ide-scsi"


**there may be some typos, but i basically transcribed what i saw into this post**

please tell me what to do!

thanks,

Zach.
 
Old 08-13-2002, 02:06 AM   #2
concoran
Member
 
Registered: Jun 2001
Location: 28N,82W
Distribution: XP,Ubuntu 9
Posts: 472

Rep: Reputation: 30
If you look at lilo.conf closely, you do not see any entry for XP.

Add these lines at the end of Lilo.conf and save the file.

other=/dev/hda1
optional
label=WinXP

and at the shell prompt, type "#lilo -r /". A new lilo will be installed
in your MBR with XP support. It worked for Win2k, and I hope it
works for XP too even though W2k's NTFS and that of XP are a
little different.
 
Old 08-13-2002, 11:16 AM   #3
Zachary
LQ Newbie
 
Registered: Aug 2002
Location: Toronto, Canada
Distribution: Redhat 7.3
Posts: 17

Original Poster
Rep: Reputation: 0
thanks, but i have another question:

how do i get to the shell prompt????, and what do i use to edit the LILO.CONF file???

I read you have to use VI or somethinglike that....where do i find this program???? is it in Linux? or do i have to install it somehow???
 
Old 08-13-2002, 11:31 AM   #4
jetblackz
Member
 
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
Welcome to LQ!

"used partition magic to create a primary partition (ext2) for a Linux install" is old, sorry. You must've read something somewhere recently. The new trend is, though not many know it, create an empty partition for Linux. Since you just have done the same in Disk Druid. Save your time.

# after you installed XP & Linux
#
# replace /dev/hda2 if need be
#
boot Linux & open Terminal
dd if=/dev/hda2 of=boot.lnx bs=512 count=1
cp boot.lnx /mnt/floppy
Boot XP CD
Repair
fixmbr
Boot XP
copy boot.lnx c:\
edit boot.ini
After multi(0)..., add a new line
C:\boot.lnx="linux"
Reboot
 
Old 08-13-2002, 11:42 AM   #5
Zachary
LQ Newbie
 
Registered: Aug 2002
Location: Toronto, Canada
Distribution: Redhat 7.3
Posts: 17

Original Poster
Rep: Reputation: 0
sorry if i sound like a complete idiot, but i barely understand what you want me to do ;(

are these steps you want me to take??? please if you don't mind, can you give me a bit more details....this is only my second day attempting to run Redhat with XP (and my second day with Redhat to begin with!)


**are these instructions for using XP's NTLOADR Boot loder thing??? what happened with LILO??? I heard that XP bootloader is quite substandard when compared to LILO**


# after you installed XP & Linux
#
# replace /dev/hda2 if need be

-- how do i do this??? how do i know if it needs to be replaced?

#
boot Linux & open Terminal

--where do i run Terminal from?

dd if=/dev/hda2 of=boot.lnx bs=512 count=1

--do i type this into the Terminal window???

cp boot.lnx /mnt/floppy

--is this a copy command i run from the Terminal window?

Boot XP CD

--i know this part

Repair

--yah i have to choose repair from the XP cd menu

fixmbr

--where do i run this one?

Boot XP

-- ok i know this one

copy boot.lnx c:\

where is the boot.lnx file originating from?

edit boot.ini

ok i know this one

After multi(0)..., add a new line

C:\boot.lnx="linux"

Reboot
 
Old 08-13-2002, 12:13 PM   #6
concoran
Member
 
Registered: Jun 2001
Location: 28N,82W
Distribution: XP,Ubuntu 9
Posts: 472

Rep: Reputation: 30
Zachary,
vi editor is an integral part of any Unix/Linux system. However,
it takes a little bit learning to use it. On Linux though, you may not
actually need a vi editor to type text. Go to start menu, and
applications, you will see one or two editors like gedit, kedit etc.
No need to go to shell prompt.
From there you can open lilo.conf. This file is in /etc directory.
These GUI based editors work very much like Windows Notepad.

Now follow the steps I asked you to do, in my earlier post to
enable LILO to boot XP too.

As far as Shell promt is concerned, you can look at the Panel
(linux's version of Windows quicklaunch), and you can see the
icon. On the other hand, you can press ctrl+shift+F1 to go to
full fledged terminal. BUt remember, you will need to use
ctrl+shift+F7 to come back to X11 (i.e GNOME or KDE).

Hope this helps. Linux is a beautiful Operating System, and is
as powerful as Unix. Hope you will like it.

Last edited by concoran; 08-13-2002 at 12:15 PM.
 
Old 08-13-2002, 12:45 PM   #7
Zachary
LQ Newbie
 
Registered: Aug 2002
Location: Toronto, Canada
Distribution: Redhat 7.3
Posts: 17

Original Poster
Rep: Reputation: 0
Thanks Concoran.

I went into Redhat and was only able to find Gedit

I used Gedit to find the lilo.conf file from the /etc location

but it did not allow me to edit the file - it said 'read only' on the title bar of the dialog box

do i have to change the file attribute for Lilo.conf? before i can change the text??

I gonng give this a try when i get home later on....i look forward to your response!

thanks,

Zach.

PS. oh yah..i know that Linux is a very exceptional OS.....and i'm VERY keen on learning the ins and out of it....now that i know XP fairly well.
 
Old 08-13-2002, 04:44 PM   #8
concoran
Member
 
Registered: Jun 2001
Location: 28N,82W
Distribution: XP,Ubuntu 9
Posts: 472

Rep: Reputation: 30
Zach
You probably logged in as a user, not as a root. Try loggin in as a root.
I would be surprised if it were marked read-only even for the root.
If so, you can always change the attributes.
Note: As a cautionary measure, make a backup copy of lilo.conf file.
HTH

Last edited by concoran; 08-13-2002 at 04:48 PM.
 
Old 08-13-2002, 07:03 PM   #9
Zachary
LQ Newbie
 
Registered: Aug 2002
Location: Toronto, Canada
Distribution: Redhat 7.3
Posts: 17

Original Poster
Rep: Reputation: 0
ok...you're right..i wasn't in the root mode..thanks for the heads up.

well i went about trying to change the LILO.conf file and found out that when i press the '/' key on my keyboard the '' character shows up instead.

I think i may have chosen the wrong keyboard layout when i installed Redhat. I'm pretty sure i chose the Canadian layout (as i live in Toronto), but it may have chosen the French layout for some reason.

How do I change my keyboard setting in the Redhat?? I tried to do it from the main panel, but there was no option to change the actual keyboaurd layout, just some useless options that wouldn't help meout one bit.

thanks again


Zach.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie probs upgrading to 9.2, Yast not allowing disk partition or DVD boot!! Laura Q SUSE / openSUSE 1 04-21-2005 12:46 PM
SAN Storage Not allowing SLES 9 to boot. MontanaD Linux - Networking 1 10-07-2004 04:19 PM
Lilo lost, Install disk failing to restore Lilo on dual boot? Dobie Linux - Newbie 2 05-05-2004 06:00 PM
I install Slackware on small HDD with LILO, can't boot LILO? kleptophobiac Slackware 4 08-10-2003 05:50 PM
Made a bootdisk with RedHat 7.1 to boot: Gave me SYSLINUX, not LILO:Want to use LILO Colonel Panic Linux - Software 0 08-17-2001 07:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration