-   Linux - Newbie (
-   -   Lilo - How do I remove "Windows" from the boot menu ? (

themadatter 03-30-2008 12:17 PM

Lilo - How do I remove "Windows" from the boot menu ?
Hi there,

I run LILO with Slackware 12 and when the computer starts, I get the LILO screen with 2 boot options; Windows and Linux.
There is a counter that will boot the selected OS after a period of time if RETURN key is not pressed.

I do not have windows on this machine and it must be picking up some remnant of windows on the boot sector.

Because the computer is remote (usually) I sometimes do restarts and it will always try to boot this fantasy windows OS unless I intervene.


How do I remove windows from the boot menu and get LILO to automatically boot linux without having to select anything ?

Thanks !!

Nylex 03-30-2008 12:19 PM

Edit /etc/lilo.conf and remove the section for Windows. Edit: after doing so, you'll need to re-run lilo (or /sbin/lilo).

themadatter 03-30-2008 01:31 PM

Reply -
Hey Nylex,

Thanks for the reply.
I have already done this.

Here is shot of my current /etc/lilo.conf file.

Any ideas ?

Thanks !

# LILO configuration file
# generated by 'liloconfig'
# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda4
label = Linux
# Linux bootable partition config ends

Maligree 03-30-2008 01:42 PM

Did you run /sbin/lilo after changing lilo.conf? It'll 'reinstall' lilo with the new configuration.

You can always try running liloconfig if you don't want to mess with the config file yourself. On the other hand.. Slackware is all about getting your hands dirty. ;)

themadatter 03-30-2008 02:12 PM


First, Nylex, I'm sorry I didn't re-run /sbin/lilo !

Maligree :

Thanks for re prompting me to do that !

It has solved my problem. LILO now boots straight to Slackware but I have a new problem in the form of :

"Kernel panic : can't load INIT - try passing INIT = to the Kernal".

I can't figure how this has happened as LILO has done it's job by this point (I think?).

Anyway. Thanks for the help; I'm off to battle my first boot-loader problem (forces a flatly enthusiastic smile) -


onebuck 03-30-2008 07:42 PM


It looks like you need to make a initrd. Read the '/boot/README.initrd' to see what is necessary.

All times are GMT -5. The time now is 03:20 AM.