-   Linux - Newbie (
-   -   LILO fails when run from live CD after installing Slack (skipped LILO during setup) (

sysfce2 07-20-2009 01:01 AM

LILO fails when run from live CD after installing Slack (skipped LILO during setup)
I'm receiving the following error message when running LILO under SystemRescueCD after installing Slackware 12.2 (the slackware setup hung when installing LILO so I am trying to install manually - I have re-run setup, including formatting all drives again):
FATAL: Trying to map files from unnamed device 0x0010 (NFS/Raid mirror down?)

Windows XP is installed on a RAID0 array (sda, sdb, sdc, sdd).
A SCSI (SATA card) drive is sde:
-Linux swap is on sde1
-root is on sde2 (ext3)
-a NTFS file storage is sde3
-the rest of the file system is on ext3 drives sde4, sde5, and sde6

I have given up on installing LILO on the RAID array - I have been trying to install it in the Linux partition and using windows boot loader to call it.

I have been copying lilo.conf to /etc/lilo.conf after mounting the Slackware drive.

Here's the current lilo.conf:

disk=/dev/sda inaccessible
disk=/dev/sdb inaccessible
disk=/dev/sdc inaccessible
disk=/dev/sdd inaccessible
disk=/dev/sde3 inaccessible
menu-title=" Server "

Let me know if any more information is necessary and thank you in advance for any help you can provide.

wr3ck3d 07-20-2009 06:13 AM

Did you chroot?

onebuck 07-20-2009 08:35 AM


Welcome to LQ!

The easiest way would be to use the install cd1 to boot the system as if you were going to install.

After you get to the login then from the cli (command line);


~#mkdir /slacktemp                  #temporary mount point
~#mount /dev/your_device /slacktemp  #the device you installed to
~#chroot /slacktemp                  #change to yours
~#cd /slacktemp/etc                  #change to directory with lilo.conf
~#vi lilo.conf                      #edit lilo.conf, if need be
~#lilo -v -t -b /dev/your_device    #sda, hda this will only test
~#lilo -v -b /dev/your_device        #this will write to your boot device

You can 'man commands' in the above example to get a full understanding of the commands and options.

sysfce2 07-20-2009 09:22 PM

Thanks, guys - the chroot got me on to the next step.

I'll try booting from the install disk (although I'm using the DVD).

LILO now installs albeit with warning messages - "'/proc/partitions' does not exist" being the most concerning one so that probably explains why I'm now getting scrolling 01s when starting up.

I can see why Linux can be frustrating for newbies - good thing I'm doing this on a spare system ;-) but I'm doing it for a learning experience. There sure is a lot of reading required!

I've got some more ideas to try and I'll let you know how I make out.

Thanks again...

malekmustaq 07-21-2009 06:56 AM


If it is not necessary to enable RAID you may disable it at the bios setup.

LILO is a good boat loader, but if you get fed up with LILO you may try Grub. In your installer CD it is located at /extra/grub folder, you may install it. You may want to read a good tutorial from here


Hope this helps.

wr3ck3d 07-21-2009 06:58 PM

You can try to mount /proc with something like this.

mount -t proc none /slacktemp/proc

You might need to mkdir /slacktemp/proc before mounting it. And do this before you chroot.

Lilo is a PITA compared to grub in my opinion. I remember when switching from the old ATA to the new ATA layer caused problems for me. Because as I was setting up lilo /dev/sda* didn't exist. Forgot how I got to work. Was a combination of making a fake device and appending a few things to lilo to finally get it to boot the first time I think. On my other box that uses grub was no problems.

Just keep at it, you will eventually get it.

sysfce2 08-04-2009 12:57 AM

This is just an update on my progress for those interested - Problem is now solved.

Thanks again guys - sorry it has been so long in responding, but I haven't had much of a chance to play with it recently and I just got it working now.

I gave up on LILO (after many hours of playing - but since it was a learning exercise for me, that is OK) - I think I could get it to work now anyway after playing with GRUB (although GRUB is a pleasure compared to LILO).

The eventual solution was quite complicated - I destroyed my RAID0 array and reinstalled Windows (something I wanted to do anyway). I also moved the connectors from the RAID card (onboard) over to the IDE connectors on the motherboard (mostly for ease of Windows install without making RAID driver floppies - although it did make the GRUB install easier too).

Also, I had to create a separate boot partition in order for GRUB to see my boot directory.

Another thing throwing me off was the hard drive order changed depending on what I booted in (SystemRescueCD (Gentoo live CD), Slackware install disk/HD copy of Slack, or even Windows). I eventually used Super GRUB Disk to determine what order GRUB was seeing (it was different again) and got the right drives listed.

Thanks again for your help guys.

Wim Sturkenboom 08-04-2009 01:16 AM


Originally Posted by sysfce2 (Post 3614550)
LILO now installs albeit with warning messages - "'/proc/partitions' does not exist"

I'm 99% sure that I saw that same error message when I run the lilo command to install lilo in the MBR, but it does not affect my installation on a HP DL380.

All times are GMT -5. The time now is 12:22 AM.