-   Linux - Newbie (
-   -   libz error when installing messenger sw - kopete, kmess (

darrenj 08-21-2003 12:52 AM

libz error when installing messenger sw - kopete, kmess
I recently got myself going with Debian Linux. Now I'm trying to install a few programs and I can't figure out why I'm getting this error when I run ./configure for kopete or kmess:

checking for libz... configure: error: not found. Check your installation and look into config.log

I have both of these packages installed:
zlib1g, zlib-bin
I tried adding directories with zlib.h to my PATH, and it made no difference.

Any suggestions or general advice? I suspect its more to do with how I have my system set up than any problem with kmess or kopete. Wild guesses are welcome!


Orococco 08-21-2003 04:26 AM

Try installing the development package zlib1g-dev.

darrenj 08-21-2003 09:01 AM

Thanks a lot for the suggestion. I installed zlib1g-dev and libc6-dev. It didn't work, but it helped me figure out how I've been using dselect and kselect without looking on the package download sites.

So, I still get the same error. Any other ideas?

If I look in kselect or dselect and it says I have a package installed, is it definitely true that the package is installed, running, available, active or whatever? Is there something else I'm supposed to do after I install a new package?

Thanks again.


Orococco 08-22-2003 03:50 AM

Did you check the version for libz required by kopete or kmess?

Perhaps you have to install packages from debian-testing or even unstable. But especially "unstable" can get you in trouble.

darrenj 08-29-2003 12:52 AM

I still haven't gotten this working.

I don't know what libz version kopete requires. apt-get says libz or zlib has been included in zlib1g, which I have installed. I can also see that I have the libz.a,, in my /usr/lib/. Also, in my /usr/include/ I can see zlib.h.

As far as dev packages go, I have zlib1g-dev, which claims to include libz-dev. I recently installed libc6-dev, kdelibs-dev, kde-devel, kde-designer, kdebase-dev, and all associated packages. None of these made a difference.

So I downloaded a new kernel (2.4.22) and installed it. I noticed a libz/zlib section which was turned off by default, which may have meant it was turned off for my previous install. This definitely got my hopes up. But it still made no difference.

I've noticed quite a few postings on various forums about similar problems with libz. Nothing that seems to do it though.

Thanks for the help so far. Very much appreciated. Let me know if you have any other thoughts.


All times are GMT -5. The time now is 06:54 PM.