LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-15-2019, 11:56 AM   #1
gmat
LQ Newbie
 
Registered: Jun 2019
Posts: 5

Rep: Reputation: Disabled
Question libssl1.1:amd64 crash


Trying to use Update Manager to update most recent updates. But am receiving error msg.

Setting up libssl1.1:amd64 (1.1.1-1ubuntu2.1~18.04.2) ...
Checking for services that may need to be restarted...done.
Checking for services that may need to be restarted...done.
Checking init scripts...
dpkg: error processing package libssl1.1:amd64 (--configure):
installed libssl1.1:amd64 package post-installation script subprocess returned error exit status 10
Errors were encountered while processing:
libssl1.1:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Setting up libssl1.1:amd64 (1.1.1-1ubuntu2.1~18.04.2) ...
Checking for services that may need to be restarted...done.
Checking for services that may need to be restarted...done.
Checking init scripts...
dpkg: error processing package libssl1.1:amd64 (--configure):
installed libssl1.1:amd64 package post-installation script subprocess returned error exit status 10
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Errors were encountered while processing:
libssl1.1:amd64

Any help would be greatly appreciated. But, please, please make it simple. I'm old.
 
Old 06-15-2019, 06:39 PM   #2
greencedar
Member
 
Registered: Sep 2018
Location: Missouri / Taiwan
Distribution: Ubuntu 18.04 Bionic Beaver
Posts: 408
Blog Entries: 1

Rep: Reputation: 25
Can you give us your computer OS information?
 
Old 06-15-2019, 07:10 PM   #3
gmat
LQ Newbie
 
Registered: Jun 2019
Posts: 5

Original Poster
Rep: Reputation: Disabled
Linux Mint 19.1 Cinnamon
Version 4.0.10
Kernel 4.15.0-51-generic
 
Old 06-16-2019, 04:11 AM   #4
greencedar
Member
 
Registered: Sep 2018
Location: Missouri / Taiwan
Distribution: Ubuntu 18.04 Bionic Beaver
Posts: 408
Blog Entries: 1

Rep: Reputation: 25
The OS information is helpful

Have you tried the following, in order, two update commands? If not, do so and let us know the results.

Code:
sudo apt-get update
sudo apt-get upgrade
Also, if you know how to put
Quote:
code tags
on codes that you send us it would be helpful. If you are not sure how to put code tags please follow the link to know how.
https://www.linuxquestions.org/quest...q-information/

Last edited by greencedar; 06-16-2019 at 04:43 AM. Reason: spelling
 
Old 06-16-2019, 09:05 AM   #5
gmat
LQ Newbie
 
Registered: Jun 2019
Posts: 5

Original Poster
Rep: Reputation: Disabled
libssl1.1:amd64 crash

Thank you greencedar. Tried both. Same results.

I don't think I understand your reference to code I've submitted. The only thing I've submitted is a copy of the Terminal results from update attempt, using the Update Manager. I don't have a working knowledge of Linux coding. I look up any problem I'm having on the Internet, (like now) and copy paste code suggestions into Terminal.

I'm a long time Windows user and am relatively new to Linux. So it's going to take awhile to learn to navigate a new system. I really disliked MSDOS because of the need to memorize commands and syntax. Relearning the old way of doing things will take some getting used to. So please bear with me if I seem to not be too bright at times. I'm new to Linux, but not computers.
 
Old 06-16-2019, 11:03 AM   #6
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 12,804

Rep: Reputation: 4020Reputation: 4020Reputation: 4020Reputation: 4020Reputation: 4020Reputation: 4020Reputation: 4020Reputation: 4020Reputation: 4020Reputation: 4020Reputation: 4020
code tags are used on this forum, regardless of your linux/windows knowledge. That will format your post. See the link in post #4.
linux is not the "old way" like msdos. http://linux.oneandoneis2.org/LNW.htm
Actually if you wish to fix this problem you need to learn some command line tools, because I'm afraid there is no graphical tool to do that.
It looks like something is corrupted on your computer. Probably you need to debug that dpkg --configure command (which went wrong).
But that requires executing commands and without practice that can cause additional issues.
 
Old 06-16-2019, 01:32 PM   #7
gmat
LQ Newbie
 
Registered: Jun 2019
Posts: 5

Original Poster
Rep: Reputation: Disabled
Thanks for nothing pan64. If I were looking for lessons in how Linux or this web site functions I would have done more than simply posting a question here. Believe it or not, this is not the only Linux forum on the Internet. And they don't all use the same format and procedures. I have absolutely no interest in learning the ins and outs of each site. My only interest is in finding a simple solution to my current problem. The fact that you don't know of any is unfortunate. But I posted my problem on several sites and may find someone who knows the answer and can explain the solution without trying to tell me what I need to know before they may be willing to help.
 
Old 06-16-2019, 01:52 PM   #8
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.6
Posts: 3,233

Rep: Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104
Quote:
Originally Posted by gmat View Post
Thanks for nothing pan64. If I were looking for lessons in how Linux or this web site functions I would have done more than simply posting a question here. Believe it or not, this is not the only Linux forum on the Internet. And they don't all use the same format and procedures. I have absolutely no interest in learning the ins and outs of each site. My only interest is in finding a simple solution to my current problem. The fact that you don't know of any is unfortunate. But I posted my problem on several sites and may find someone who knows the answer and can explain the solution without trying to tell me what I need to know before they may be willing to help.
What? Please see the link to the rules of this form in my sig. As in anyplace in life or on the 'net...if you don't want to play by the rules, don't come to the game.

You've said you don't know nothin' You were given the advice that you'll need to learn some things in order to fix what appears to be a glitch on your system. The people on this forum are all volunteers. Lashing out like you have is absolutely unacceptable.

Good luck finding a solution without doing any work.

Last edited by scasey; 06-16-2019 at 03:13 PM.
 
Old 06-16-2019, 04:23 PM   #9
gmat
LQ Newbie
 
Registered: Jun 2019
Posts: 5

Original Poster
Rep: Reputation: Disabled
You're absolutely right scasey. With HELP like your's and pan64, this is the wrong site for me. You boys have a great time together. I'll be unsubscribing now. So don't bother responding. I'll never see it. Time to move on.
 
Old 06-16-2019, 04:45 PM   #10
greencedar
Member
 
Registered: Sep 2018
Location: Missouri / Taiwan
Distribution: Ubuntu 18.04 Bionic Beaver
Posts: 408
Blog Entries: 1

Rep: Reputation: 25
Wink

gmat,

Could you copy paste the following code and give us the results

Code:
sudo apt-get install --reinstall libssl1.1:amd64
I understand your frustration. Learning how to find a problem with Linux - Ubuntu, takes some time, effort, and in some cases it takes a series of codes, or steps, to find the desired solution. And, sometimes it is difficult to understand other peoples abilities, and or lack of abilities, and how to cope a new learner with a new system. Just give us a little more time.

Last edited by greencedar; 06-16-2019 at 04:46 PM. Reason: revised the code
 
Old 06-17-2019, 03:55 AM   #11
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 12,804

Rep: Reputation: 4020Reputation: 4020Reputation: 4020Reputation: 4020Reputation: 4020Reputation: 4020Reputation: 4020Reputation: 4020Reputation: 4020Reputation: 4020Reputation: 4020
Quote:
Originally Posted by gmat View Post
I have absolutely no interest in learning the ins and outs of each site.
That is your decision. Refusing the rules of this [any] forum is your own choice.
Quote:
Originally Posted by gmat View Post
My only interest is in finding a simple solution to my current problem.
That is fine. I tried to explain you [probably] there is no simple solution. Accepting the answer or denying to work on it is your decision again.
Quote:
Originally Posted by gmat View Post
The fact that you don't know of any is unfortunate.
This statement is not true. From the other side it is against the rules of this forum again. Please post only [real] facts on your problem, not on me.
Quote:
Originally Posted by gmat View Post
But I posted my problem on several sites and may find someone who knows the answer and can explain the solution without trying to tell me what I need to know before they may be willing to help.
That is nonsense. Without knowing linux (the OS, package management and some scripting) you will not understand the answer, you will not be able to follow suggestions. You stated you are new to linux, I replied solving it will not be so easy [probably]. There is no trivial answer available for every question.
 
Old 06-17-2019, 03:04 PM   #12
tets
Member
 
Registered: Aug 2005
Location: Prague, Czech Rep.
Distribution: Gentoo, Mint
Posts: 30

Rep: Reputation: 16
Hi guys! (if you're still following the thread :-) )

I have the same problem. Tried everything listed here:

Code:
# dpkg --configure -a
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Setting up libssl1.1:amd64 (1.1.1-1ubuntu2.1~18.04.2) ...
Checking for services that may need to be restarted...done.
Checking for services that may need to be restarted...done.
Checking init scripts...
dpkg: error processing package libssl1.1:amd64 (--configure):
 installed libssl1.1:amd64 package post-installation script subprocess returned error exit status 10
Setting up libssl1.1:i386 (1.1.1-1ubuntu2.1~18.04.2) ...
Checking for services that may need to be restarted...done.
Checking for services that may need to be restarted...done.
Checking init scripts...
dpkg: error processing package libssl1.1:i386 (--configure):
 installed libssl1.1:i386 package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of openssl:i386:
 openssl:i386 depends on libssl1.1 (>= 1.1.1); however:
  Package libssl1.1:i386 is not configured yet.

dpkg: error processing package openssl:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libssl-dev:amd64:
 libssl-dev:amd64 depends on libssl1.1 (= 1.1.1-1ubuntu2.1~18.04.2); however:
  Package libssl1.1:amd64 is not configured yet.

dpkg: error processing package libssl-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Errors were encountered while processing:
 libssl1.1:amd64
 libssl1.1:i386
 openssl:i386
 libssl-dev:amd64
root@mybox:/home/tets# apt-get install --reinstall libssl1.1:amd64
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 2 reinstalled, 0 to remove and 1 not upgraded.
4 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] 
E: Internal Error, No file name for libssl1.1:amd64
And
Code:
# apt-get install --reinstall libssl1.1:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 2 reinstalled, 0 to remove and 1 not upgraded.
4 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] 
E: Internal Error, No file name for libssl1.1:amd64
Mint 19

Any idea?

Last edited by tets; 06-17-2019 at 03:52 PM.
 
Old 06-17-2019, 05:11 PM   #13
paolode
LQ Newbie
 
Registered: Dec 2012
Posts: 8

Rep: Reputation: Disabled
I had the same problem with libssl1.1. I think it is a problem with dpkg configuration. I solved it doin a 'sudo nautilus' (or you can sudo rm ,,' in terminal. I went to /var/lib/dpkg/info and deleted libssl1.1:amd64.postinst libssl1.1:amd64.shlib
libssl1.1:amd64.postrs. Then runned update and upgrade via terminal again and everything worked fine. You can also reinstall via apt libssl1.1 (and openssl) after this.

Hope this helps.
 
2 members found this post helpful.
Old 06-18-2019, 01:29 AM   #14
tets
Member
 
Registered: Aug 2005
Location: Prague, Czech Rep.
Distribution: Gentoo, Mint
Posts: 30

Rep: Reputation: 16
Thumbs up

Quote:
Originally Posted by paolode View Post
I had the same problem with libssl1.1. I think it is a problem with dpkg configuration. I solved it doin a 'sudo nautilus' (or you can sudo rm ,,' in terminal. I went to /var/lib/dpkg/info and deleted libssl1.1:amd64.postinst libssl1.1:amd64.shlib
libssl1.1:amd64.postrs. Then runned update and upgrade via terminal again and everything worked fine. You can also reinstall via apt libssl1.1 (and openssl) after this.

Hope this helps.
Yes! This helped, thank you very much.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
crash () { crash|crash& }; crash grob115 Linux - Security 6 05-07-2011 03:06 AM
Need badly kernel 2.6.29-1-amd64 or 2.6.29-2-amd64 Zup Debian 4 06-28-2009 07:59 AM
Difference between amd64 generic and amd64 k8? halfpower Linux - General 6 09-07-2006 05:28 PM
Crash, Crash, Crash, Crash and You Guessed it Crash! little_penguin SUSE / openSUSE 8 07-04-2005 09:34 AM
xmms crash xine crash mplayer crash paledread Linux - Software 9 03-09-2004 07:09 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration