LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-10-2016, 08:01 AM   #1
rg83rg
LQ Newbie
 
Registered: Dec 2016
Posts: 2

Rep: Reputation: Disabled
libssl-dev. How can I fix this error


libssl-dev : Depends: libssl1.0.0 (= 1.0.1k-3) but 1.0.1k-3+deb8u4 is to be installed

Can someone help me figure out how to fix this. I am trying to install secp256k1
 
Old 12-10-2016, 08:14 AM   #2
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,465

Rep: Reputation: 299Reputation: 299Reputation: 299
Could you please specify your distribution and version.
libbssl1 was removed for security reasons though still installable from old-backports, old-versions and other dated/insecure sources (only install it if you know what your doing).
https://packages.debian.org/jessie/libssl1.0.0 (jessie/security - you need the security repo for this)
https://packages.debian.org/jessie-b...ts/libssl1.0.0 (jessie-backports - you need backports for this)
https://packages.debian.org/sid/libssl1.0.0 (debports, sid - you need debports or sid for this)

*(last two options should work for testing as well)
*Link to the correct name/location if needed.
deb8u4 is just a security fix, link to whatever name your binary is asking for and it should just work.

Last edited by jens; 12-10-2016 at 10:48 AM.
 
Old 12-10-2016, 12:45 PM   #3
rg83rg
LQ Newbie
 
Registered: Dec 2016
Posts: 2

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jens View Post
Could you please specify your distribution and version.
libbssl1 was removed for security reasons though still installable from old-backports, old-versions and other dated/insecure sources (only install it if you know what your doing).
https://packages.debian.org/jessie/libssl1.0.0 (jessie/security - you need the security repo for this)
https://packages.debian.org/jessie-b...ts/libssl1.0.0 (jessie-backports - you need backports for this)
https://packages.debian.org/sid/libssl1.0.0 (debports, sid - you need debports or sid for this)

*(last two options should work for testing as well)
*Link to the correct name/location if needed.
deb8u4 is just a security fix, link to whatever name your binary is asking for and it should just work.
Gnome 3.14.1
Kali GNU/Linux 2.0 (sana) 32-bit

I need to install Secp256k1 but I am having issues, which source shall I use?

Thanks for your help
 
Old 12-10-2016, 04:16 PM   #4
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (15 current), Slack15, Ubuntu studio, MX Linux, FreeBSD 13.1, WIn10
Posts: 10,342

Rep: Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242
usually if the version number is greater then what it says it still works, unless a function that the software needs within the depends has been removed.
 
Old 12-10-2016, 06:26 PM   #5
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 421

Rep: Reputation: 74
I'm not a Kali user here, and I'm not sure if they use debian repo?
 
Old 12-10-2016, 07:52 PM   #6
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,524

Rep: Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015
If the version is >= and the package manager is griping about some extraneous label, one of my favorite methods is to download the package and use:
Code:
$ dpkg -i --force-depends name_of_package_file
which turns all dependency problems into warnings instead of breaking the install.

After you use that, you should run:
Code:
$ apt-get -f install
to make sure all other dependencies are met.
 
Old 12-14-2016, 10:03 AM   #7
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,465

Rep: Reputation: 299Reputation: 299Reputation: 299
Quote:
Originally Posted by AwesomeMachine View Post
which turns all dependency problems into warnings instead of breaking the install.
This only fixes dpkg's warnings/dependencies and not those from external sources.
In the OP's case his version should just work when properly linked (using the expected name for his binary) or by changing it in the install/make/whatever script (something upstream should have done already).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fix Linux Boot Error message : "a start job is running for dev-disk-by..." andrehardianto Linux - Newbie 6 10-05-2016 11:24 PM
libssl-dev, SDL, libX11: finding the corresponding package in AUR? 0li Arch 5 02-23-2016 12:07 PM
package libssl-dev Prisca Ubuntu 1 08-05-2011 12:08 PM
how to install libssl-dev in ubuntu 8.04.1 twinscomp Linux - Newbie 1 08-15-2008 10:12 AM
libxcurser-dev error on install, apt-get wont fix efi360 Linux - Software 0 03-01-2004 11:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration