LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-02-2014, 06:11 AM   #1
NotAComputerGuy
Member
 
Registered: Jun 2012
Distribution: Linux Mint - Debian Edition
Posts: 349

Rep: Reputation: 13
Libreoffice - No Spell Checker


My LibreOffice Writer appears to have no spell checker. In the options the language is set to English (UK), but there is no red line, and if I click spell checker it says that check is complete.

Without a Spellchecker, it feels to me that there is little more function to Writer than Nano. How do I fix this please?

Thanks
 
Old 03-02-2014, 07:13 AM   #2
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
You probably need the dictionary package: it will be libreoffice-dict-en whatever.
 
Old 03-02-2014, 07:21 AM   #3
NotAComputerGuy
Member
 
Registered: Jun 2012
Distribution: Linux Mint - Debian Edition
Posts: 349

Original Poster
Rep: Reputation: 13
There's nothing matching that using LMDE "aptitude search", so I thought I'd search for "en-gb" as I know that's the version of English that I'd like to use, it returns a few titles, but this is the only seemingly appropriate one:
Code:
i   libreoffice-l10n-en-gb                                                                     - office productivity suite -- English_british language package
 
Old 03-02-2014, 07:42 AM   #4
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Yeah, that's what you want. I think they've changed the name of the package for newer releases of Libreoffice for some reason. I'm using 4.2.1.
 
Old 03-02-2014, 07:43 AM   #5
NotAComputerGuy
Member
 
Registered: Jun 2012
Distribution: Linux Mint - Debian Edition
Posts: 349

Original Poster
Rep: Reputation: 13
Ah, it's already installed then. How do I activate it please?
 
Old 03-02-2014, 07:49 AM   #6
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Can't remember, but it's bound to be in a configuration menu somewhere - look through them. I don't use it much, and usually turn off spellchecking.
 
Old 03-02-2014, 07:52 AM   #7
NotAComputerGuy
Member
 
Registered: Jun 2012
Distribution: Linux Mint - Debian Edition
Posts: 349

Original Poster
Rep: Reputation: 13
According all the settings in Writer it should be active, but doesn't work. Are the any other Word Processing programs that are recommended for me to try?
 
Old 03-02-2014, 07:58 AM   #8
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Are you sure you're bad at spelling? You might not be making any mistakes.
There's OpenOffice, and AbiWord if you just need a word-processor.
 
Old 03-02-2014, 08:04 AM   #9
NotAComputerGuy
Member
 
Registered: Jun 2012
Distribution: Linux Mint - Debian Edition
Posts: 349

Original Poster
Rep: Reputation: 13
To be very honest, I didn't release until a few pages into a document and then noticed a few mistakes upon proof reading.

I thought OpenOffice was LibreOffice? That's what it's been 'replaced' with in my repository. I shall try AbiWord and see if it's just LibreOffice behaving like an amateur.
 
Old 03-02-2014, 08:09 AM   #10
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,576
Blog Entries: 31

Rep: Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195
I have the same problem. AFAIK everything that is required for spell checking is set up and it used to work but now it does not. It hasn't been important enough to try to solve ...
 
Old 03-02-2014, 08:20 AM   #11
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,599

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Oh, it works all right. I have been using LibreOffice Writer 4.2.1 just now and the damn thing has been annoying because it does not understand the jargon I have been using. Not a LibreOffice problem, just my current circumstance.
 
Old 03-02-2014, 08:29 AM   #12
NotAComputerGuy
Member
 
Registered: Jun 2012
Distribution: Linux Mint - Debian Edition
Posts: 349

Original Poster
Rep: Reputation: 13
Shamefully, I've just asked my boss to buy a Microsoft Office licence to see if I can get it work work under wine.
 
Old 03-02-2014, 08:40 AM   #13
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
1. Open LibreOffice
2. Click on the Tools menu.
3. Select the Options... item
4. Go to the Language Settings section
5. Fill in the options as you want them.
6. Go to the Writing Aids section
7. Fill in the options as you want them
jdk
 
1 members found this post helpful.
Old 03-02-2014, 08:53 AM   #14
NotAComputerGuy
Member
 
Registered: Jun 2012
Distribution: Linux Mint - Debian Edition
Posts: 349

Original Poster
Rep: Reputation: 13
I think that's all set?

http://oi59.tinypic.com/2nui1yu.jpg
 
Old 03-02-2014, 10:34 AM   #15
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,575

Rep: Reputation: 1425Reputation: 1425Reputation: 1425Reputation: 1425Reputation: 1425Reputation: 1425Reputation: 1425Reputation: 1425Reputation: 1425Reputation: 1425
LibreOffice and OpenOffice need the Hunspell spellchecker, so make sure that it's installed. Then you need the UK English dictionary for it. That may be listed in the repository under Hunspell or Myspell. After that, follow the instructions in post 13.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Alien bobs Libreoffice 4.1.2, spell checker not working in slackware64-current rc2 sparkyhall Slackware 9 10-29-2013 05:56 PM
How do l install and enable the australian spell checker in libreoffice vers 3.3.0 Glenn D. Linux - Software 1 02-03-2011 03:05 PM
Spell Checker Kahless LQ Suggestions & Feedback 4 07-15-2007 11:35 PM
Spell Checker royleith Linux - Desktop 2 06-15-2007 07:30 AM
FF 2.0 spell checker ??? lleb Linux - Software 11 02-03-2007 09:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration