-   Linux - Newbie (
-   -   /lib/ version 'GLIBC_2.3.2' not found (

solutionseeker 01-29-2005 09:41 AM

/lib/ version 'GLIBC_2.3.2' not found
How do I get this?

When I run my program from root it says this /lib/ version 'GLIBC_2.3.2' not found (required by myprogram)

acid_kewpie 01-29-2005 09:52 AM

helps if you tell us what system you're on for a start... we're not psychic. go fill in your user profile please.

essentially you need to upgrade glibc by whatever means your unknown system might let you do that.

solutionseeker 01-29-2005 10:14 AM

Hello... Sorry about that... I am using debian.

solutionseeker 01-29-2005 12:41 PM

when I did where is I can see that the file is in the /usr/lib directory...

Myexefile which needs it is in /usr/bin/usr/bin/myexefile...

How do I tell that the file its looking for is in the /usr/lib? Please help............

acid_kewpie 01-29-2005 01:14 PM

it should find it automatically, if not, try runnign "ldconfig"

solutionseeker 01-29-2005 01:28 PM

I tried ldconfig and still it doesnt work...

I am not sure if this make a difference but when I run the program it says /lib/ version GLIBC_2.3.2 not found

The file which I find using whereis the file is without the .0

acid_kewpie 01-29-2005 01:35 PM

you don't seem to be having much luck with this myexefile thing... (it's a secret what it is i assume..... :confused:) if you're installing random prebuilt binary files, you can't really expect an easy ride... compile whatever it is from source, or find a prebuilt RPM suitable for your distributon of linux.

solutionseeker 01-29-2005 01:41 PM

naah its not a secret :)

I am trying to run the HP's itanium ski simulator.

When u sar tar -zxvf it already opens it with /usr/bin and in one of my earlier posts I asked if I needed to use a program to install anything I was told there was no need for it.

I said tar -zxvf ski.tar.gz (put this file in the /usr/bin) when I logged in as root. Then it created another /usr/bin inside the already existing /usr/bin

It was giving the same error.. I thought I didnt place it in the right place because the usr/lib where the missing file is cant be found... I changed a lot of classpaths before again doing a tar -zxvf ski.tar.gz from the /root

Now I have the file in /usr/bin/ski but it still cant find that file...

I googled around and I find posts in different languages... none of which I understood...

I doono what to do....

solutionseeker 01-29-2005 01:57 PM

The software that I have is looking for a newer version and I have a older version of the libpthread file?

If so then I have to download an older version of the software.

I can do this however how do I remove these files?

Do I just delete them ?

acid_kewpie 01-29-2005 01:58 PM

well if they are distributing a binary only, then you can try some nasty hacks to get it working. try creating a symlink from your real to the file it wants. with those symbols matching there shouldn't be any other incompatabilities.

solutionseeker 01-29-2005 02:03 PM

Okay I can try that... Do you know how to create the symlink?

solutionseeker 01-29-2005 02:14 PM

let me try doing ln -s /usr/lib/

I searched on google and found this on

solutionseeker 01-29-2005 02:21 PM


Originally posted by solutionseeker
let me try doing ln -s /usr/lib/

I searched on google and found this on

I did a ln -s /usr/lib/ /usr/lib/

and this didnt work either........

acid_kewpie 01-29-2005 02:34 PM

well it's after /lib/ so only that path will do. is there a file there already?

solutionseeker 01-29-2005 02:36 PM

yes it created a file

u mean I shld just say ln -s /lib/ /lib/

All times are GMT -5. The time now is 05:09 PM.