LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Less doesn't accept commands unless I press enter (https://www.linuxquestions.org/questions/linux-newbie-8/less-doesnt-accept-commands-unless-i-press-enter-783891/)

maya_maya 01-21-2010 08:57 PM

Less doesn't accept commands unless I press enter
 
I am not a new user of linux but the last time I used linux was five years ago.

I am having a hard time using less. It dont want to accept commands immediately. I need to press 'Enter' to accept the command.

Like if I press 'q' to quit, it will echo 'q' and dont do anything. I have to press 'Enter' to make it quit. Same with other commands.

I am using Windows PuTTy 0.60 with ssh to connect to linux machine.

The linux system is: Linux <removed> 2.6.18-53.el5 #1 SMP Wed Oct 10 16:34:19 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux

The less version is :
less 394
Copyright (C) 1984-2005 Mark Nudelman

I dont have any problem with vim and more. Only with less.

I have also tried changing the TERM from xterm to vt100. But still the same problem with less.

Googling didn't help as 'less' is a very common word.

Can you suggest other things that I can try to fix this problem?

thanks in advance...

kbp 01-22-2010 08:49 AM

Sounds like a problem with putty... does the problem occur at the console ?

Maybe you can reset putty to default settings and see if that makes a difference, might have to delete reg keys from under 'HKEY_CURRENT_USER\Software\SimonTatham\PuTTY'

cheers

MTK358 01-22-2010 08:56 AM

Maybe some program between you and less is buffering the input until it recieves a newline?

maya_maya 01-24-2010 10:42 PM

I found a workaround to my 'less' problem:

cat file_1.txt | less

'less' works fine if I pipes a file. That will do for now...

But I still wish I know the reason why 'less' is acting weird on our linux machine.

Thanks for the replies...


All times are GMT -5. The time now is 04:20 PM.