Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 01-21-2010, 07:57 PM   #1
LQ Newbie
Registered: Jan 2010
Posts: 2

Rep: Reputation: 0
Less doesn't accept commands unless I press enter

I am not a new user of linux but the last time I used linux was five years ago.

I am having a hard time using less. It dont want to accept commands immediately. I need to press 'Enter' to accept the command.

Like if I press 'q' to quit, it will echo 'q' and dont do anything. I have to press 'Enter' to make it quit. Same with other commands.

I am using Windows PuTTy 0.60 with ssh to connect to linux machine.

The linux system is: Linux <removed> 2.6.18-53.el5 #1 SMP Wed Oct 10 16:34:19 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux

The less version is :
less 394
Copyright (C) 1984-2005 Mark Nudelman

I dont have any problem with vim and more. Only with less.

I have also tried changing the TERM from xterm to vt100. But still the same problem with less.

Googling didn't help as 'less' is a very common word.

Can you suggest other things that I can try to fix this problem?

thanks in advance...
Old 01-22-2010, 07:49 AM   #2
Senior Member
Registered: Aug 2009
Posts: 3,790

Rep: Reputation: 653Reputation: 653Reputation: 653Reputation: 653Reputation: 653Reputation: 653
Sounds like a problem with putty... does the problem occur at the console ?

Maybe you can reset putty to default settings and see if that makes a difference, might have to delete reg keys from under 'HKEY_CURRENT_USER\Software\SimonTatham\PuTTY'

Old 01-22-2010, 07:56 AM   #3
LQ 5k Club
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 723Reputation: 723Reputation: 723Reputation: 723Reputation: 723Reputation: 723Reputation: 723
Maybe some program between you and less is buffering the input until it recieves a newline?
Old 01-24-2010, 09:42 PM   #4
LQ Newbie
Registered: Jan 2010
Posts: 2

Original Poster
Rep: Reputation: 0
I found a workaround to my 'less' problem:

cat file_1.txt | less

'less' works fine if I pipes a file. That will do for now...

But I still wish I know the reason why 'less' is acting weird on our linux machine.

Thanks for the replies...


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] BASH - how to press ENTER carolflb Linux - Newbie 2 10-28-2009 01:03 PM
C++/QT3 accept button when press entered... BUT ... DropSig Programming 3 07-31-2008 06:41 AM
getline, why press enter twice?? blizunt7 Programming 3 09-06-2005 10:34 PM
Cant press enter for install B McHack Mandriva 4 01-22-2004 08:58 PM
press 'I' to enter interactive startup? xiaoxiao Linux - Software 3 04-06-2001 07:39 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:39 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration