LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-23-2004, 01:48 PM   #1
Draylath
Member
 
Registered: May 2004
Location: Great Paxton
Distribution: Debian
Posts: 112

Rep: Reputation: 15
ldconfig command not found


I'm trying to install Xine from source. everything so far is going just peachy. I've got the main engine installed, but when I follow instructions and do "ldconfig" I get told that the bash command not found, I (albeit a bit naughtily) went on to install the gui but it told me I needed to do this ldconfig step or no dice.

To be honest I don't know what it is os what it does (I read something about it making sym links but it didn't mean much to me) can any one shed any light on what to do to get it all installed so I can watch the matrix again
Thanks,
Draylath
 
Old 06-23-2004, 01:53 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975
you're probably not root. su to root and run it with the full path "/sbin/ldconfig" you probably will be fine without this though.
 
Old 06-23-2004, 02:15 PM   #3
Draylath
Member
 
Registered: May 2004
Location: Great Paxton
Distribution: Debian
Posts: 112

Original Poster
Rep: Reputation: 15
I am root as I did the whole tar -zxvf and ./config thing first.
The /sbin/ldconfig didn't return any error output this time but it didn't seem to do anything just put me on another prompt line.

when I do the ./configure for the gui source I still get the same error about it not being able to find the test program and to make sure xine-lib is installed,

anything else would be appreciated
 
Old 06-23-2004, 04:03 PM   #4
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
Quote:
Originally posted by Draylath
I am root as I did the whole tar -zxvf and ./config thing first.
The /sbin/ldconfig didn't return any error output this time but it didn't seem to do anything just put me on another prompt line.

when I do the ./configure for the gui source I still get the same error about it not being able to find the test program and to make sure xine-lib is installed,

anything else would be appreciated
You've probably installed xine-lib in /usr/local/lib which is the default option when doing ./configure, so you have 2 choices:

1. Reinstall xine-lib using:
Code:
./configure --prefix=/usr
to put the library file in /usr/lib instead, which is automatically searched by ldconfig

2. Add /usr/local/lib to /etc/ld.so.conf if it's not already there.

If it is already there then it may be you're installed too early a version of xine-lib. Make sure the version you're installing is the same or greater version as the one needed by the program.
 
Old 06-23-2004, 04:21 PM   #5
Draylath
Member
 
Registered: May 2004
Location: Great Paxton
Distribution: Debian
Posts: 112

Original Poster
Rep: Reputation: 15
thanks for the replys,

though I have had a bit of a change of heart on things, I have gone for giving up on fedora core and totaly thrown off my windoze armbands and started swimming in the deep end that is slackware. (please don't let me drown guys )
 
Old 06-23-2004, 04:30 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
/usr/local/lib would by slack-default be part of
/etc/ld.so.conf

What ldcondif does is to look through all directories
listed in /etc.ld.so.conf, and update /etc/ld.so.cache
with all dynamic libraries it can find. It's there so programs
can load libraries they depend on quickly.

If ldconfig doesn't give you any output that means
that all is well with the world ;)


Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
bash: <command name> command not found smash Programming 5 03-13-2006 08:48 AM
command not found matthewa Linux From Scratch 2 04-05-2005 07:12 PM
imwheel "ldconfig: not found" but its really there... AHHH! FocusedWolf Linux - Hardware 2 03-02-2004 06:00 PM
et: command not found twan Linux - Games 2 01-31-2004 09:08 AM
Command not found weaver2112 Linux - General 6 06-26-2003 09:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration