Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 12-16-2008, 08:33 PM   #16
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 884

Original Poster
Rep: Reputation: 45
New resolv.conf

Ladies & Gents,

I do believe I am winning. The current score

Laptop .5 rbees 1.5

With the cat5 cable plugged in I installed the most recent updates. Don't really think that had anything to do with it. Because the updates contained a new kernel I did a restart. When it came back up the ndiswrapper had loaded and the card was active.

After some playing around it the kde control panel and putting in a gateway ip and the dns for my isp I restarted the wlan0 and it came up with internet access. So I know the driver is working and accessing the card correctly. Hence my current score.

That leaves getting it to auto connect like my laptop does. Been a couple of years since I set mine up and I don't recall that I had any issues except the broadcom wireless that required ndiswrapper. But the auto part all worked after I got the driver working. Of coarse in the process of getting my laptop set up I had a crash and lost my setup log that I maintain on all my systems so I can't go back and look.

Thanks pentnode

Yes, my linux router has dhcp. My local laptops come and go off the network at will with almost no problems. The one has some problems, vista based I think, but it may be impatients on the part of the user.

Thanks Drakeo

as the super user make sure your /etc/rc.d/rc.inet1 is set to executable. if it is not kde will never get it set in the control sent a auto dhcpcd will not happen at but. or it will not know to load the device. this is the same for /etc/rc.d/rc.inet2. while your in there the /etc/rc.d/rcinit1.conf make sure it

USE_DHCP[0]="yes" <----.
I don't have these files. I am assuming that these are those in or controlled by /etc/init.d I think you have pointed to a Slackware file system and I have Debian. What files would they then be?

Ok, I think I have found something. In comparing the way my laptop is setup with the way this one is I see a difference in the file structure. It may only be because mine is running Lenny64 and the one I am setting up is running Lenny32. The thing is that where mine has a /etc/resolv.conf that contains the name servers where the one I am setting up has a symlink to a file buried down in /lib/init/rw/resolvconf/resolv.conf

It says
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
So in seams that the developers have changed something since I set up my laptop.

My linux router is also running Lenny32 It has a /etc/resolv.conf plain text file and not a link down into the /lib directory. It is the same with one other Lenny based desktop I have easy access to. Interesting.

Any thoughts

Old 12-17-2008, 05:54 AM   #17
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 884

Original Poster
Rep: Reputation: 45
Score laptop 0 rbees 2

Ladies & Gentlemen

Thanks for the excellent counsel, even if you only read along. The current score is, drum roll please, ----------*

Laptop 0 rbees 2

and the crowd roars

Ok so enough of fantasy island.

I didn't figure out what the developers changed or why. I started out to read the script that takes care of all this auto stuff and it didn't make any sense to me. Also it may have something to do with this install starting as a pure kde install with gnome getting pulled in later to meet dependencies.

But like I said before, it seamed as though a program was missing. That was kind of true. I installed wicd and the connection problems went away. Wicd conflicts with the stock network managers in kde and uninstalled them. Then after a reboot to make sure everything was kosher I was able to connect to my wifi.

Side note: My netgear wifi router did not die. It seams that if you reset it to the factory defaults you have to disconnect it from every thing except one wired connection and log in via the default password to reactivate the crazy thing.

Anyway, it seams that the stock network managers were not executing these new scrips correctly somehow. But WICD is

I still have a couple of minor issues with this laptop that I want to address. Suspend to ram/disk and the clock.

I remember reading at one time something about windows setting the hardware clock to local time and linux setting it to grenich mean time? I don't suppose any one would have a link that would tell me how to make windows and linux read the clock so that both systems have the correct time? Please?

Once again thanks, give yourselves a pat on the back and an 'at-a-boy.
Old 12-17-2008, 05:57 AM   #18
Registered: Jun 2004
Location: India
Distribution: Red Hat
Posts: 30

Rep: Reputation: 15
try this option after kernel parameters during boot "locale=fr_FR i8042.reset"
Old 12-17-2008, 08:38 AM   #19
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 884

Original Poster
Rep: Reputation: 45
benoy4007 thanks

I guess I just had to set the time DUH

hibernate is working suspend2ram is not it is not handleing the ndiswrapper correctly. No big deal, the hibernate is more important.


Now to get the rest of the software installed.
Old 12-17-2008, 04:28 PM   #20
Senior Member
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,389
Blog Entries: 3

Rep: Reputation: 393Reputation: 393Reputation: 393Reputation: 393
type in your gate way address sign in to you router. some some IP's work off your mac address so make sure if you need it to supply it.yeap open your favorite web browser and type in the router gateway from there you will sign into your IP. the router will save it and then from now on your good to go. I hoped this helped.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mepis 6 is kicking my butt, help! lenny45 MEPIS 10 09-07-2006 11:22 AM
Linux saved my butt again. /bin/bash Member Success Stories 2 10-01-2005 01:20 AM
Linux Scripting Issue Kicking my Butt !!! steve_f60 Linux - General 1 04-29-2005 05:00 PM
Samba Is Kicking My Butt!! pentax9380 Linux - Networking 7 09-28-2004 06:57 PM
My PC becoming a real sore in the butt schatoor General 2 12-26-2002 03:05 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:42 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration