LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-16-2005, 04:42 PM   #1
val54321
LQ Newbie
 
Registered: May 2005
Posts: 2

Rep: Reputation: 0
Language/locale setting


Hello All,

I am trying to set up a language support in my LINUX 2.6.11 kernel. I have looked at all the HOWTOs on the LINUX sites and changed the settings as suggested, but I am still unable to see certain characters like the tilda above the n and things like that. They just show up as question marks.

For example "configuración" is shown as "configuraci?n", "españa" as "espa?a"
and thigs like that.

I have tried the following:
my languages are located in .pcf files, I have moved these to a local directory under the font directory, added bitmap support to my kernel, changed my locale, and nothing is working.

Any ideas would be hugely helpful. Thank you for the help.

Valerie
 
Old 05-17-2005, 11:42 AM   #2
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Rep: Reputation: 35
KDE and GNOME work, I think, perfect with all kinds of languages/keyboard layouts.
Check if your kernel have support for the languages you want to use.
If you see ??? instead of normal symbols on FAT32/NTFS partition - that's probably because you didn't read "man mount".
If this happens on a Linux partition... where do you see ??? in console, or X? What language?

The more info you provide - the better the answer
 
Old 05-17-2005, 12:39 PM   #3
val54321
LQ Newbie
 
Registered: May 2005
Posts: 2

Original Poster
Rep: Reputation: 0
I am seeing the issue in XWindows. I have verified that the language is supported in my kernel. I have used the export LANG command. I have also used the mkfont command, I have not seen or heard anything about the mount command when using languages, so I will look there. I am also using LILO.

Thank you.
 
Old 05-18-2005, 08:26 AM   #4
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Rep: Reputation: 35
Quote:
I have also used the mkfont command, I have not seen or heard anything about the mount command when using languages
I haven't heard too I'm speaking about only Windows partitions. E.g., for me to see Russian folders on it I added option "iocharset=koi8-r" in /etc/fstab... All possible mount options are described in mount manual.

What distro? What Desktop Environment/Manager do you use? What is the language you're trying to set up?
I found info on how to localize console and X in Slackware 9.1 just typing in Google "russification linux" (in Russian, of course). You can do the same to find many guides written by people who uses "this" language.

I can only show you the example how to localize X so that it can show Russian:
Code:
~~~Console localization~~~
Add to /etc/rc.d/rc.font the following:

setfont -v Cyr_a8x16
mapscrn koi2alt
for i in 1 2 3 4 5 6; do
echo -ne "\033(K" > /dev/tty$i
done
loadkeys ru-ms

After rerunning "/etc/rc.d/rc.font" console can understand Russian symbols and language can be changed pressing left <Ctrl+Shift>

~~~System localization~~~
Add to /etc/profile.d/lang.sh the following:

    export LANG=ru_RU.KOI8-R
    export LC_MESSAGES=C# This forces apps to use English instead                                                       #of Russian, but switching is possible.
    export LC_NUMERIC=C

Then open /usr/share/locale/locale.alias and find a string where keyword "russian" is written. Replace this string with the following:

russian ru_RU.KOI8-R
ru ru_RU.KOI8-R
ru_RU ru_RU.KOI8-R

~~~X localization~~~
Add to /etc/X11/xorg.conf (or /etc/X11/XF86Config) the following:
FontPath 	"/usr/X11R6/lib/X11/fonts/cyrillic" #but I had it already

In Input Device section modify what's there to the following:

Option "XkbModel"   "pc105"
Option "XkbLayout"  "us,ru(winkeys)"
Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"

This allows to switch between the languages pressing <Ctrl+Shift>
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 04:34 AM
Locale and language setting stefaandk Linux - General 2 07-11-2005 12:08 AM
locale setting ’ mnaumanca Linux - Software 0 02-18-2005 04:39 PM
Chage the language locale ust Linux - Software 0 08-16-2004 03:59 AM
Changing default locale/GNOME language elluva Linux - Software 5 01-13-2004 03:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration