LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Kubuntu Boot troubleshooting (https://www.linuxquestions.org/questions/linux-newbie-8/kubuntu-boot-troubleshooting-773713/)

_Kelly 12-05-2009 06:17 PM

Kubuntu Boot troubleshooting
 
My first post on this forum... Been funbling with ubuntu for about a month now and slowly starting to really like it. But I ran into a snag.

Yesterday I turned it on, booted Kubuntu and it freezes during boot at swap: Waiting for UUID=xxx. One step before that, it says fsck unable to detect wmid devices... not sure if that is the cause or not.

So I boot into 2.6.31-14 (same partition) and it ran perfectly.

After some more fiddling, I decide to uninstall 2.6.31.15 and reinstall which synaptics decided to install .16 instead.

After rebooting BOTH KERNELS fail with the same problem described above.

I tried to boot either kernel in rescue mode but all I get is snowy white boxes. I thought rescue mode is no graphics...

Out of desperation, during boot up I mashed atl, ctl and F1 and F2 and ctrl C and esc and somehow after beating on the keys like a rabid money, it booted up and worked.

I suspect when I reboot it will be broke again... how do I begin to troubleshoot? Do I need to just reinstall?

It's ok if I do, I made several partitions and have Ubuntu running in another partition as well as puppy in another one and XP... now how many newbs quadruple boot? LMAO!

linus72 12-05-2009 06:43 PM

Welcome to LQ Kelly!
LOL

Which version of Ubuntu?
9.10?

maybe a re-install is best

What other distros you tryin?

_Kelly 12-05-2009 07:17 PM

Update
 
Yes. 9.10 UNR.

I have been goofing with Unbuntu, Kubuntu, Knoppix, BT3 and Puppy.

I don't mind a reinstall, this particular partition has been buggy starting with the sound wigging out.

BTW, I made progress... turns out the swap partition isn't mounting during boot. But if I break the mounting process, it boots in. I can then type swapon /dev/sda7 and it mounts perfectly.

So during boot it can't mount the swap using the uuid but I can mount the swap manually.

How do I fix that? Do I delete the partition and rebuild it as swap?

_Kelly 12-05-2009 08:04 PM

One more thing, my other distros can use this swap just fine. Only this one can't mount it during boot.

_Kelly 12-05-2009 08:31 PM

Checked the UUID in blkid and discovered the UUID in fstab was totally wrong. Changed it in fstab and all is well. Not sure how it got changed though....


All times are GMT -5. The time now is 10:06 PM.