-   Linux - Newbie (
-   -   KUbuntu 11.04 x64 - Radeon 6950 & Catalyst - Screen tearing issue. (

edooze 08-27-2011 04:46 AM

KUbuntu 11.04 x64 - Radeon 6950 & Catalyst - Screen tearing issue.
Hi all.

Just finished a new build with a (Sapphire) Radeon 6950 1GB.

I'm having huge screen tearing issues both watching video and even moving windows around the desktop. So far, my old GeForce 8500GT coped better than the Radeon does!

I've installed the catalyst drivers, but I'm unable to turn on the tear-free option in the catalyst control center. No idea why, but every time I open the program it's set to 'disabled'. So I enable it and restartx. And it's disabled. So I enable it and restartx. You see where I'm going here?

Can anyone help, please?


edooze 08-27-2011 06:50 PM

Nobody? I've tried replacing the xorg.conf file numerous times with the aticonfig --initial command, and still nothing. Is there even a fix for this issue? Maybe I have to go back to GNOME... :(

edooze 08-29-2011 11:50 PM

Still nothing, it would seem. A bit disconcerting.
If anyone's interested, I've now re-installed KUbuntu because the issue was so bad as to make it unusable. That's put me back into Windows, as without drivers I can't set the screen resolution over 1400x900 (or something like that).

Would anyone care to suggest anything? I'm at a total loss, so even suggestions can't hurt!

fecjanky 02-01-2012 03:32 PM

KUbuntu 11.04 x64 - Radeon 6950 & Catalyst - Screen tearing issue.
Hi edooze,

I've experienced exactly the same problem as you(almost have the same config),i red in other topics that usng the linux driver for radeon instead
of proprietary ati driver will solve the problem, but it didn't work form me.
It's a pity that i've used ubuntu/kubuntu distribution for almost 3 years with my crappy old machine (celeron 1700d, 1 gb ram) without any problem, and now with my new PC it's not working properly.
I hope someone will post an easy workaround/fix/solution for this issue or maybe ATI will release a new driver, because i really would like the use this OS.



colorpurple21859 02-01-2012 05:34 PM

add nomodeset in the linux line of grub and see if that works

edooze 02-01-2012 06:03 PM

I fecjanky

Please see the following thread for the solution I found.

Sounds like you may have tried it already, but could be worth a shot:

Good luck!

All times are GMT -5. The time now is 03:49 PM.