-   Linux - Newbie (
-   -   kppp dialer exit on 16 (

emeu 04-03-2007 01:20 PM

kppp dialer exit on 16

I would need assistance with my remote connection to internet via kppp.
Running free mandriva 2006, using kppp as a dialer, tried 2 different external modems, (usr sporter 56k) and (supra express 56e)
When i create my connection and enter manualy the isp parameters (login,passw,chap protocol) ect, the system test the connection and always succeed in connecting but it take about 50 seconds before i get the message connected.
Then i can surf the internet and do a ping to a site and all is fine.
If i try to stop my connection with kppp i can only do a Quit and this does not disconnect the modem (what is the proper way of disconnecting? )
I power of my modem and tried to connect again ,this time i get no sound on modem but looking at log i see an exit on 16 and hangup.
The /etc/ppp files chap and pap secrets show my login and password correctly (it seems)
The only way i can get back on internet is to delete my connection and recreate it.
I look at some threads with similar problem but could not fix my little problem.

can someone help please
tks in advance

Larry Webb 04-03-2007 08:00 PM

I had a similar problem and I had to unhook my local network, reinstall the live distro, configure my kppp and then hook up my network.

dracolich 04-04-2007 09:47 AM

It's been a while since I've used a dial-up connection, but I remember having a disconnect button. After establishing the connection there's either a second kppp window or a tray icon that shows the connection status and a button to disconnect. I think your problem is that without properly disconnecting, kppp still has a lock file open and so it thinks the connection is still active.

emeu 04-04-2007 02:38 PM

kppp connection
Tank for taking the time to answer my question.

Dracolich you where right about the icon in the tray,it is the same for ether0 and ppp0, you need to chose wich connection to disconect.
By using it the moden is closing normaly but i still have the same basic problem (exit16)
by activating the log option option on kppp i know i get connected and a few seconds later an exit 16.
It seems that pppd does not transmit login/password to my ISP. I called my provider, they do not support linux but at least i confirmed they use chap .

Lary Webb thanks for you suggestion, i will wait a few days and if still not solve i will rebuild as you mentionned


Junior Hacker 04-04-2007 03:00 PM

In 'modem commands' section of kppp configuration is a line which is usually empty, init 2 I think, I always add these init strings which are the ones wvdial uses by default:


ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Also, there are times when I get the exit status 16 numerous times during certain periods in any of my Linux systems on my multi-boot, although I'm not sure about Debian Etch that I have not installed kppp and use wvdial, I don't recall seeing it exit with status 16, come to think of it, I've never had to re-connect with Etch or Mandrake 10.2 that use wvdial. But I sometimes feel it is an ISP or a current phone line condition causing this because it will happen in more than one distribution for just a short period of time or most of an evening. Some times it will be shortly after the connection, other times it could be a few minutes to half an hour after. But usually not more than twice to three times, after that it sticks.

emeu 04-05-2007 10:08 AM

making progress on dial up problem
Hi everyone
Tanks for your assistance, it help me determine what is happening.
I also discovered a document on the web which is very helpful to set up dial to an ISP.

the document name is:How to hook up PPP in linux
Here is an extract
Your computer passes messages for addresses it does not know to the default
route. ppp assumes that there can only be one default route on any system.
This is almost always the route to ISP's computer. However, if pppd finds
that a default route already exists, it will not set up one to your ISP,
causing problems (nothing gets through). In order that you not have any
conflicts between the routing across ppp and onto some network you have, run
/sbin/route -n
(or you can also run
/bin/netstat -nr
which does the same thing)
while not connected via ppp, and look for a default entry. (First entry
in line is This almost certainly should not be there. (Unless
you already have a hookup to the internet via an Ethernet connection, you
do not want such a default route.) Unless you know that your computer has
an Ethernet connection to other computers already, the only thing there
should be a route to or If there is such a default
route (line starting with, and you want the ppp interface to be
your default route, (the usual situation), run
/sbin/route del default
this works fine and i can surf with my modem but it disconnect my ether0 lan connection.
if i reconnect the lan the defaultroute comes back and i cannot dial
any ideas?

dracolich 04-05-2007 02:06 PM

That's a good howto you found. After seeing the title I remember using it. I might've even printed it somewhere.

It's been my understanding that there can only be one default route. If you're ppp is connected and sets a default route, all packets, ppp and eth, will pass through that route. If you config your eth and set a new default route, all packets will now pass through that route, which will break your ppp connection. Try configuring the eth interface with a regular route, not a default gateway.

route add

emeu 04-05-2007 03:24 PM

kpp dialer exit 16
Bonjour dracolich

i am a bit confused with your explanation. i used system/configure your computer/create a lan connection and did the same for dial up.
Is there something wrong in the way i answered the question?
i am not certain i un derstand what is the difference betwen default route and regular route.

could you give me a breifing please or if you know of a document that would explain a bit more

I did not read all 29 pages of the documents i mentionned ,so i will go thru it in case it offerts some information.
i apologise for my english and thanks again for your help

dracolich 04-05-2007 06:10 PM

I'm not familiar with using graphic tools to configure a connection. I do all mine from the commandline. Yours is probably automatically setting the route via preconfigured settings in a config file.

The best explanation I can come up with for the difference, off the top of my head, is - the [default] gateway route is the route to the external network (internet) while any other route is simply the point at which the network you're on connects to another network.

Example: When you dialup, your ppp interface gets its address and gateway from your isp. That gateway address is the door to the internet for your ppp interface. When you bring up the eth interface it sets a new gateway which moves that door, so now ppp is looking in the wrong door for the internet.

hope this helps

emeu 04-06-2007 07:00 AM

Hi dracolich

the problem is solve and can now surf the net and i still have the connection to my network
my problem was the gateway.

All times are GMT -5. The time now is 05:49 PM.