LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Knoppix: copying files from NTFS to FAT32 (https://www.linuxquestions.org/questions/linux-newbie-8/knoppix-copying-files-from-ntfs-to-fat32-356545/)

Manhhh 08-24-2005 12:26 PM

Knoppix: copying files from NTFS to FAT32
 
I've been reading this forum and many other sites on the web for a few weeks now, and cannot figure out how to write files from my NFTS hard drive to my external FAT32 hard drive.

I recently installed a fresh copy of Windows XP on my brand new hard drive which crashed. To prevent data loss like last time, I would simply like to know how to transfer the files to my external HD.

I know a lot about Windows, but not about Linux or the Knoppix 3.8 CD I have. It seems that several people have had the same problem as me, and the answers are something like:

"Become root, then...."
"type Knoppix@[/}...."
"go to your etc/fstab..."

You see, I don't know what this stuff means, how to become root, or where to type these commands! I did go to the fstab thing and tried to edit something and save it like was explained in few other threads somewhere, but it's impossible since it won't let me save the file.

I figured I'd just be able to drag and drop, but it won't let me, even if I mount/unmount, give permission, or set as writeable. I'm totally at a loss.

If someone could give me a step-by-step post of how to transfer files I'd be greatful. Thank you.

PenguinPwrdBox 08-24-2005 12:36 PM

You have an internal HDD, from which you are trying to copy everything to the external HDD? On the internal, your OS is windows, so I'm not sure why you are using Knoppix to copy it?

Manhhh 08-24-2005 10:36 PM

Sorry. Yes, for now, I use Windows XP to transfer all important files to the external hard drive. I try to do this every couple weeks. But, the last time I hadn't made a back up for 2 months, and I lost 2 months worth of files (due to my laziness to not backup) when Windows XP went bad and was unable to boot. When this happens, which is not surprising with Windows, I would like to ignore the Windows XP OS and access my files on the internal hard drive by booting from a Knoppix 3.8 CD. This, I can do fine, but, I'm unable to copy the files to the external hard drive using Knoppix because of something dealing with "permissions."

PenguinPwrdBox 08-24-2005 11:36 PM

Just be sure you mount them both with loose perms, to be safe, since it's only you using it.

mount -o umask=0000 /device /mountpoint

makuyl 08-25-2005 05:19 AM

IIRC you can right click the device icon -> Actions -> Change read/write mode, or some such.
If it's already mounted try: sudo mount -o remount,rw /dev/??? /mnt/???
To mount everything rw do: sudo mount -a

Manhhh 08-25-2005 03:18 PM

----------------------------------------
Just be sure you mount them both with loose perms, to be safe, since it's only you using it.

mount -o umask=0000 /device /mountpoint
-----------------------------------------
Penguin, thank you for the command line. The problem is that I don't know where to paste it. Right click on the HD icon and paste it under Properties? Does "0000" have to be changed to the name of my external HD? I know how to open a terminal and etc/fstab, but I can't save anything because it won't write to any HD on my machine.


--------------------------------------
Just be sure you mount them both with loose perms, to be safe, since it's only you using it.

mount -o umask=0000 /device /mountpoint
--------------------------------------
Sorry, but I just don't know what loose perms are and where to try to write "
mount -o umask=0000 /device /mountpoint." It's not that I don't understand computers or English, it's just that I haven't worked with Linux and don't understand the terms and where to write the commands.

bosewicht 08-25-2005 03:21 PM

you would type that in a terminal as root. device being the hard drive, it would prob be hda1, hda2, hdd1, hdd2, etc. whatever it is in fstab. the mountpoint would be the directory under /mnt that you are mounting the device to, again this would be in fstab as well


All times are GMT -5. The time now is 12:03 AM.