Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 06-01-2009, 05:23 PM   #1
Registered: Mar 2009
Posts: 53

Rep: Reputation: 15
Kickstart installation via NFS

Hello everyone. I'm having a problem configuring a kickstart installation via NFS using CentOS 4.7. Two servers I have are connected with a crossover cable and I want one server to double as the NFS server and the BOOTP/DHCP server to install CentOS4.7 on the other.

I am doing this as practice for the "real thing." I figured this would be an excellent way to learn how to do future slightly-larger scale installs, but I am having problems tackling just this first one. The problem I have is that I want to configure the eth0 of the server to be installed to accept it's IP via the BOOTP/DHCP server. I am unsure if I have not activated a service necessary to complete this task but a quick check of daemons using
ps -aux
shows that rpc.statd, portmap, nfsd, lockd, and rpc.mountd are running on the BOOTP/DHCP&NFS Server (they are actually one server combined. Also,
chkconfig --list portmap
chkconfig --list nfs
are also showing those two services on. I also made sure that the IP address of the server to be installed is included (ro)read-only in the file. Can you tell me anything I should check to continue troubleshooting because I haven't done anything like this before and am not sure what else to do. The literature on the subject is not clueing me to check anything else. I feel like I just need some guidance. Thanks.

Last edited by Latitude; 06-01-2009 at 05:25 PM.
Old 06-06-2009, 11:41 AM   #2
LQ 5k Club
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,397
Blog Entries: 2

Rep: Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908
Simply starting the daemons for your services is not enough to make them useful. Have you configured at least /etc/exports for the NFS server? And for DHCP, you must also set up the appropriate config file, with information suitable to your setting. You will need to determine what that configuration is, based on your requirements, and the nature of your system.
--- rod.
Old 06-08-2009, 01:02 PM   #3
Registered: Mar 2009
Posts: 53

Original Poster
Rep: Reputation: 15
I want to share the only two files in a directory we will call the "latitude" directory, which are the kickstart file that will be reachable by NFS and a file which is a CentOS 4.7 install iso image. Therefore, the latitude directory is shared with, the IP address of the server I want to kickstart.

I have configured my /etc/exports to include simply the following:

With regard to the appropriate DHCP config file, I have the following in my dhcpd.conf file:

ddns-update-style interim;
ignore client-dates;

allow bootp;
allow booting;

subnet netmask

{ host hostname
{ hardware ethernet MAC Address ;
filename "/home/latitude/;
next-server NFSserverHostName.localdomain; }

I have started NFS but am having a DHCP problem now. When I go to kickstart the server, the server can't find the kickstart file even though I have it included in the /etc/host.allow and /etc/exports files. I am unsure, and am still troubleshooting to find a problem.

Last edited by Latitude; 06-08-2009 at 01:10 PM.
Old 06-08-2009, 03:14 PM   #4
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,899
Blog Entries: 27

Rep: Reputation: 2186Reputation: 2186Reputation: 2186Reputation: 2186Reputation: 2186Reputation: 2186Reputation: 2186Reputation: 2186Reputation: 2186Reputation: 2186Reputation: 2186

Once you setup the config files the information must be shared. You should 'man exportfs' which shows that you will need to perform 'exportfs -a' at least.

A search here on LQ will provide a lot of useful information on 'NFS' as this has been covered before.
Old 06-09-2009, 10:30 AM   #5
Registered: Mar 2009
Posts: 53

Original Poster
Rep: Reputation: 15
Yes, I use exportfs -a -v so I can see what I am doing, and I'm still unable to get the server I want to kickstart to get access to the kickstart file. I'm searching for a solution in RHEL 4 and CentOS docs/manuals, using Google as well. I tried service iptables stop and still could not get the server to reach the kickstart file, even after relaunching nfs services (service nfs restart). I am reading into SELinux, it's hard to understand at first. I might try and find an SELinux tutorial somewhere. The Red Hat manual on SELinux is hard to reign in without strong linux skills and knowledge.

Last edited by Latitude; 06-09-2009 at 10:32 AM.
Old 06-10-2009, 05:28 PM   #6
LQ 5k Club
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,397
Blog Entries: 2

Rep: Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908
Since you have two hosts, and two network components on each host, it seems to make sense to start narrowing down the source of errors. The DHCP server can be tested from the client side (probably even as localhost), using 'dhclient -d'. This should report receipt of a valid IP for the client, and should cause the DHCP server to leave some information in your server's system logs. An example transcript follows:
$ su -c ' /sbin/dhclient -d'
Internet Systems Consortium DHCP Client V3.0.1
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit

Listening on LPF/eth0/00:19:d1:81:8e:30
Sending on   LPF/eth0/00:19:d1:81:8e:30
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to port 67 interval 8
DHCPOFFER from xx.xx.xx.38
DHCPREQUEST on eth0 to port 67
DHCPACK from xx.xx.xx.38
bound to yy.yy.yy.22 -- renewal in 34082 seconds.
I see, now, that you have specified a filename in your DHCP configuration for the client. Conventionally, the filename specified here will be fetched from the server using tftp (not NFS). I am unacquainted with the kickstart procedure, so I will guess that the filename may be used by the kickstart client as an NFS-hosted file.
In either case, you should be able to test the server, be it TFTP (which you have not mentioned configuring) or NFS. In the case of TFTP:
$ tftp
$ tftp xx.xx.xx.38
tftp> get pxelinux.0
tftp> quit
$ ls -lash pxelinux.0
16K -rw-r--r--  1 owner group 14K Jun 10 14:11 pxelinux.0
Use your '/home/latitude/' filename (although, there may be issues with directory names prefixed to the filespec for a simple protocol like TFTP).

You can mount the NFS server from any host allowed in your /etc/exports file:
mount -t nfs server:/share/name /mount/point/on/localhost
ls /mount/point/on/localhost
Doing these diagnostics should illuminate where your problems are.

--- rod.

Last edited by theNbomr; 06-10-2009 at 05:33 PM.
Old 10-02-2009, 06:53 AM   #7
Registered: Nov 2005
Posts: 80

Rep: Reputation: 15
Is this worked?

I didn't do any DHCP configuration and tried installing through NFS.

But I am getting the window "Error downloading kickstart file" with message "Unable to download the kickstart file. Please modify the kickstart parameter below or press cancel to proceed as an interactive installation".

But I tested the NFS mount is working from other servers. But i think the fresh install is not picking the NFS share. is there any configuration I am missing?

Please help me.
Old 10-02-2009, 07:19 AM   #8
Registered: Oct 2003
Location: Elgin,IL,USA
Distribution: Sidux, LinHES, and Mythbuntu
Posts: 209

Rep: Reputation: 32
What does /etc/xinetd.d/tftp say the server_args are? it should point to the directory your have the pxe boot files.
server_args = -s /opt/RedHat/TFTP

In /opt/RedHat/TFTP I have vmlinuz and initrd.img and another dir called pxelinux.cfg with a file called default.
Default has this;
default linux
#delay 3000
label linux
        ##4.7 image
        kernel vmlinuz
        append initrd=initrd.img ks=nfs:xx.xx.xx.xx:/opt/RedHat/ks.cfg eth0_ethtool="autoneg=off speed=100 duplex=full" acpi=off mptsas
The append line tells kickstart were to find the ks.cfg file for an automated install, and passes some boot variables. mptsas is a drive I need for some machines to load the SAS drive for the hard drive.

Last edited by uteck; 10-02-2009 at 07:20 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
kickstart over nfs jon2kx Linux - Software 2 05-14-2009 07:17 AM
Kickstart with nfs keeps using boot CD for rpm's jamsda Fedora - Installation 1 07-31-2008 03:01 AM
LXer: Unattended Fedora 8 Installation With NFS And Kickstart LXer Syndicated Linux News 0 04-08-2008 11:00 PM
kickstart through nfs problem rohit_67066 Linux - Newbie 0 10-12-2007 09:29 AM
KickStart with NFS ! ongxanga Linux - Networking 16 02-20-2004 01:41 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:14 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration